summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-13 08:20:05 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-13 08:20:05 +0000
commit3f790b39bdc8b6cfd12061e2546c446570c78787 (patch)
treec78b062f21d69281e3c244be55d4c4ae9873f281 /net-libs/rest/rest-0.7.12.ebuild
parentNew ebuild dev-ruby/notify. ebuild written by Matsuu Takuto <matsuu@gentoo.org> (diff)
downloadgentoo-2-3f790b39bdc8b6cfd12061e2546c446570c78787.tar.gz
gentoo-2-3f790b39bdc8b6cfd12061e2546c446570c78787.tar.bz2
gentoo-2-3f790b39bdc8b6cfd12061e2546c446570c78787.zip
Bump, drop old. Notable changes: by default (i.e. when SOUP_SESSION_SSL_STRICT is used) rest-0.7.12 will reject self-signed ssl certificates.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rest/rest-0.7.12.ebuild')
-rw-r--r--net-libs/rest/rest-0.7.12.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/rest/rest-0.7.12.ebuild b/net-libs/rest/rest-0.7.12.ebuild
new file mode 100644
index 000000000000..bc76ed022bb2
--- /dev/null
+++ b/net-libs/rest/rest-0.7.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rest/rest-0.7.12.ebuild,v 1.1 2011/11/13 08:20:04 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Helper library for RESTful services"
+HOMEPAGE="http://git.gnome.org/browse/librest"
+
+LICENSE="LGPL-2.1"
+SLOT="0.7"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +gnome +introspection test"
+
+# Coverage testing should not be enabled
+RDEPEND="app-misc/ca-certificates
+ >=dev-libs/glib-2.22:2
+ dev-libs/libxml2:2
+ net-libs/libsoup:2.4
+ gnome? ( >=net-libs/libsoup-gnome-2.25.1:2.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ test? ( sys-apps/dbus )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-gcov
+ --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
+ $(use_with gnome)
+ $(use_enable introspection)"
+ DOCS="AUTHORS README"
+}
+
+src_test() {
+ # Tests need dbus
+ Xemake check || die
+}