summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-13 02:19:55 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-13 02:19:55 +0000
commit121764bd542277e2a587ab2783a3060b29e12f8e (patch)
treeae996c27457a28cb26610445a63c7c0fdabc8de2 /net-libs/serf/serf-1.0.1.ebuild
parentVersion bump. Ebuild by Arfrever. (diff)
downloadgentoo-2-121764bd542277e2a587ab2783a3060b29e12f8e.tar.gz
gentoo-2-121764bd542277e2a587ab2783a3060b29e12f8e.tar.bz2
gentoo-2-121764bd542277e2a587ab2783a3060b29e12f8e.zip
Version bump. Ebuild by Arfrever.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/serf/serf-1.0.1.ebuild')
-rw-r--r--net-libs/serf/serf-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/serf/serf-1.0.1.ebuild b/net-libs/serf/serf-1.0.1.ebuild
new file mode 100644
index 000000000000..855ff1ffa5e2
--- /dev/null
+++ b/net-libs/serf/serf-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/serf/serf-1.0.1.ebuild,v 1.1 2012/03/13 02:19:55 floppym Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="HTTP client library"
+HOMEPAGE="http://code.google.com/p/serf/"
+SRC_URI="http://serf.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x64-macos"
+IUSE=""
+
+DEPEND="dev-libs/apr:1
+ dev-libs/apr-util:1
+ dev-libs/openssl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.3.1-disable-unneeded-linking.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-apr="${EPREFIX}/usr/bin/apr-1-config" \
+ --with-apr-util="${EPREFIX}/usr/bin/apu-1-config" \
+ --with-openssl="${EPREFIX}/usr"
+}