summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-07-22 20:56:10 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-07-22 20:56:10 +0000
commitbea4c25e4ba150445c8feb6b6d91de0a94320a32 (patch)
treee61ed74b78a4437331b38b9beb2f897490eae4eb /net-libs/stem/stem-1.2.2.ebuild
parentUpdate HOMEPAGE (diff)
downloadgentoo-2-bea4c25e4ba150445c8feb6b6d91de0a94320a32.tar.gz
gentoo-2-bea4c25e4ba150445c8feb6b6d91de0a94320a32.tar.bz2
gentoo-2-bea4c25e4ba150445c8feb6b6d91de0a94320a32.zip
Initial version.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs/stem/stem-1.2.2.ebuild')
-rw-r--r--net-libs/stem/stem-1.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/stem/stem-1.2.2.ebuild b/net-libs/stem/stem-1.2.2.ebuild
new file mode 100644
index 000000000000..4dbc987e0694
--- /dev/null
+++ b/net-libs/stem/stem-1.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/stem/stem-1.2.2.ebuild,v 1.1 2014/07/22 20:56:10 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-misc/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_info/a \
+ \ \ \ \ return" test/unit/interpreter/commands.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}