summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2011-11-09 09:54:43 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2011-11-09 09:54:43 +0000
commitbd1a24aa6422353a4b8b7db14eda60a709982094 (patch)
tree668c3faa0ccadbd6456ef86483fe1f62a26f2ab6 /net-libs/telepathy-farsight
parentversion bump (diff)
downloadgentoo-2-bd1a24aa6422353a4b8b7db14eda60a709982094.tar.gz
gentoo-2-bd1a24aa6422353a4b8b7db14eda60a709982094.tar.bz2
gentoo-2-bd1a24aa6422353a4b8b7db14eda60a709982094.zip
Bump to 0.0.19. Mostly minor fixes.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-farsight')
-rw-r--r--net-libs/telepathy-farsight/ChangeLog8
-rw-r--r--net-libs/telepathy-farsight/telepathy-farsight-0.0.19.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/net-libs/telepathy-farsight/ChangeLog b/net-libs/telepathy-farsight/ChangeLog
index 1748a6b81108..81006b0e8822 100644
--- a/net-libs/telepathy-farsight/ChangeLog
+++ b/net-libs/telepathy-farsight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-farsight
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/ChangeLog,v 1.27 2011/10/24 06:18:30 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/ChangeLog,v 1.28 2011/11/09 09:54:43 ford_prefect Exp $
+
+*telepathy-farsight-0.0.19 (09 Nov 2011)
+
+ 09 Nov 2011; Arun Raghavan <ford_prefect@gentoo.org>
+ +telepathy-farsight-0.0.19.ebuild:
+ Bump to 0.0.19. Mostly minor fixes.
24 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
telepathy-farsight-0.0.15.ebuild, telepathy-farsight-0.0.16.ebuild,
diff --git a/net-libs/telepathy-farsight/telepathy-farsight-0.0.19.ebuild b/net-libs/telepathy-farsight/telepathy-farsight-0.0.19.ebuild
new file mode 100644
index 000000000000..33211628b0bc
--- /dev/null
+++ b/net-libs/telepathy-farsight/telepathy-farsight-0.0.19.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/telepathy-farsight-0.0.19.ebuild,v 1.1 2011/11/09 09:54:43 ford_prefect Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit python
+
+DESCRIPTION="Farsight connection manager for the Telepathy framework"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=sys-apps/dbus-0.60
+ >=dev-libs/dbus-glib-0.60
+ >=net-libs/telepathy-glib-0.14.3
+ >=net-libs/farsight2-0.0.29
+ python? (
+ >=dev-python/pygobject-2.12.0:2
+ >=dev-python/gst-python-0.10.10 )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ if use python; then
+ python_convert_shebangs -r 2 .
+ fi
+}
+
+src_configure() {
+ econf $(use_enable python) --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ python_clean_installation_image
+ dodoc NEWS ChangeLog || die
+}