summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-02-09 11:45:23 +0000
committerPacho Ramos <pacho@gentoo.org>2014-02-09 11:45:23 +0000
commit587fa0587b244595bbbfb268a6729ac4de8ea573 (patch)
treef369d4606d3076f89342259bc59a345b724a7282 /net-libs/telepathy-glib
parentVersion bump, drop old (diff)
downloadgentoo-2-587fa0587b244595bbbfb268a6729ac4de8ea573.tar.gz
gentoo-2-587fa0587b244595bbbfb268a6729ac4de8ea573.tar.bz2
gentoo-2-587fa0587b244595bbbfb268a6729ac4de8ea573.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog9
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.22.1.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 86176d2a93c5..d3f0c7d792f2 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-glib
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.142 2013/12/08 19:27:48 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.143 2014/02/09 11:45:23 pacho Exp $
+
+*telepathy-glib-0.22.1 (09 Feb 2014)
+
+ 09 Feb 2014; Pacho Ramos <pacho@gentoo.org> +telepathy-glib-0.22.1.ebuild:
+ Version bump
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> telepathy-glib-0.20.4.ebuild:
x86 stable, bug #478252
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.22.1.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.22.1.ebuild
new file mode 100644
index 000000000000..f08d0ff29f4c
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.22.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.22.1.ebuild,v 1.1 2014/02/09 11:45:23 pacho Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 python-r1 vala virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+
+IUSE="debug +introspection +vala"
+
+# Broken for a long time and upstream don't care
+# https://bugs.freedesktop.org/show_bug.cgi?id=63212
+RESTRICT="test"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ vala? ( introspection )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.32.0:2
+ >=dev-libs/dbus-glib-0.90
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ ${PYTHON_DEPS}
+"
+
+src_configure() {
+ python_export_best
+
+ gnome2_src_configure \
+ --disable-static \
+ --disable-installed-tests \
+ $(use_enable debug backtrace) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings)
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Needs dbus for tests (auto-launched)
+ Xemake -j1 check
+}