summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-10-11 13:47:37 +0000
committerPacho Ramos <pacho@gentoo.org>2010-10-11 13:47:37 +0000
commitaf7ae62fdadff6f6b2a64f8eb125dc021d540f4c (patch)
treeaff6fb4b7af061ffce91c7ec50732fc0b020c50d /net-libs/webkit-gtk
parentStable on amd64 wrt bug #340024 (diff)
downloadgentoo-2-af7ae62fdadff6f6b2a64f8eb125dc021d540f4c.tar.gz
gentoo-2-af7ae62fdadff6f6b2a64f8eb125dc021d540f4c.tar.bz2
gentoo-2-af7ae62fdadff6f6b2a64f8eb125dc021d540f4c.zip
Version bump with multiple security fixes, remove old testing.
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog15
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.2.1-icu-4.4.patch109
-rw-r--r--net-libs/webkit-gtk/metadata.xml4
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild (renamed from net-libs/webkit-gtk/webkit-gtk-1.2.1.ebuild)39
4 files changed, 33 insertions, 134 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 732273ee9eba..7967272ab0d3 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.79 2010/09/11 18:35:55 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.80 2010/10/11 13:47:37 pacho Exp $
+
+*webkit-gtk-1.2.5 (11 Oct 2010)
+
+ 11 Oct 2010; Pacho Ramos <pacho@gentoo.org> -webkit-gtk-1.2.1.ebuild,
+ -files/webkit-gtk-1.2.1-icu-4.4.patch, +webkit-gtk-1.2.5.ebuild,
+ metadata.xml:
+ Version bump: fixes for CVE-2010-1780 CVE-2010-3113 CVE-2010-1814
+ CVE-2010-1812 CVE-2010-1815 CVE-2010-3115 CVE-2010-1807 CVE-2010-3114
+ CVE-2010-3116 CVE-2010-3257 CVE-2010-3259 CVE-2010-1781 CVE-2010-1782
+ CVE-2010-1784 CVE-2010-1785 CVE-2010-1786 CVE-2010-1787 CVE-2010-1788
+ CVE-2010-1790 CVE-2010-1792 CVE-2010-1793 CVE-2010-2648 CVE-2010-2647.
+ Bump to EAPI3, add introspection support, drop libtool-1 compatibility
+ hack that should no longer be needed, remove old.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> webkit-gtk-1.2.3.ebuild:
Marked ppc for bug #324077.
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.2.1-icu-4.4.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.2.1-icu-4.4.patch
deleted file mode 100644
index 054430dcd1d0..000000000000
--- a/net-libs/webkit-gtk/files/webkit-gtk-1.2.1-icu-4.4.patch
+++ /dev/null
@@ -1,109 +0,0 @@
-diff --git a/WebCore/platform/text/TextBreakIteratorICU.cpp b/WebCore/platform/text/TextBreakIteratorICU.cpp
-index 44423c0..f5575ee 100644
---- a/WebCore/platform/text/TextBreakIteratorICU.cpp
-+++ b/WebCore/platform/text/TextBreakIteratorICU.cpp
-@@ -24,7 +24,6 @@
-
- #include "PlatformString.h"
- #include "TextBreakIteratorInternalICU.h"
--
- #include <unicode/ubrk.h>
- #include <wtf/Assertions.h>
-
-@@ -38,7 +37,7 @@ static TextBreakIterator* setUpIterator(bool& createdIterator, TextBreakIterator
-
- if (!createdIterator) {
- UErrorCode openStatus = U_ZERO_ERROR;
-- iterator = static_cast<TextBreakIterator*>(ubrk_open(type, currentTextBreakLocaleID(), 0, 0, &openStatus));
-+ iterator = reinterpret_cast<TextBreakIterator*>(ubrk_open(type, currentTextBreakLocaleID(), 0, 0, &openStatus));
- createdIterator = true;
- ASSERT_WITH_MESSAGE(U_SUCCESS(openStatus), "ICU could not open a break iterator: %s (%d)", u_errorName(openStatus), openStatus);
- }
-@@ -46,7 +45,7 @@ static TextBreakIterator* setUpIterator(bool& createdIterator, TextBreakIterator
- return 0;
-
- UErrorCode setTextStatus = U_ZERO_ERROR;
-- ubrk_setText(iterator, string, length, &setTextStatus);
-+ ubrk_setText(reinterpret_cast<UBreakIterator*>(iterator), string, length, &setTextStatus);
- if (U_FAILURE(setTextStatus))
- return 0;
-
-@@ -85,44 +84,44 @@ TextBreakIterator* sentenceBreakIterator(const UChar* string, int length)
- staticSentenceBreakIterator, UBRK_SENTENCE, string, length);
- }
-
--int textBreakFirst(TextBreakIterator* bi)
-+int textBreakFirst(TextBreakIterator* iterator)
- {
-- return ubrk_first(bi);
-+ return ubrk_first(reinterpret_cast<UBreakIterator*>(iterator));
- }
-
--int textBreakLast(TextBreakIterator* bi)
-+int textBreakLast(TextBreakIterator* iterator)
- {
-- return ubrk_last(bi);
-+ return ubrk_last(reinterpret_cast<UBreakIterator*>(iterator));
- }
-
--int textBreakNext(TextBreakIterator* bi)
-+int textBreakNext(TextBreakIterator* iterator)
- {
-- return ubrk_next(bi);
-+ return ubrk_next(reinterpret_cast<UBreakIterator*>(iterator));
- }
-
--int textBreakPrevious(TextBreakIterator* bi)
-+int textBreakPrevious(TextBreakIterator* iterator)
- {
-- return ubrk_previous(bi);
-+ return ubrk_previous(reinterpret_cast<UBreakIterator*>(iterator));
- }
-
--int textBreakPreceding(TextBreakIterator* bi, int pos)
-+int textBreakPreceding(TextBreakIterator* iterator, int pos)
- {
-- return ubrk_preceding(bi, pos);
-+ return ubrk_preceding(reinterpret_cast<UBreakIterator*>(iterator), pos);
- }
-
--int textBreakFollowing(TextBreakIterator* bi, int pos)
-+int textBreakFollowing(TextBreakIterator* iterator, int pos)
- {
-- return ubrk_following(bi, pos);
-+ return ubrk_following(reinterpret_cast<UBreakIterator*>(iterator), pos);
- }
-
--int textBreakCurrent(TextBreakIterator* bi)
-+int textBreakCurrent(TextBreakIterator* iterator)
- {
-- return ubrk_current(bi);
-+ return ubrk_current(reinterpret_cast<UBreakIterator*>(iterator));
- }
-
--bool isTextBreak(TextBreakIterator* bi, int pos)
-+bool isTextBreak(TextBreakIterator* iterator, int position)
- {
-- return ubrk_isBoundary(bi, pos);
-+ return ubrk_isBoundary(reinterpret_cast<UBreakIterator*>(iterator), position);
- }
-
- #ifndef BUILDING_ON_TIGER
-@@ -136,7 +135,7 @@ static TextBreakIterator* setUpIteratorWithRules(bool& createdIterator, TextBrea
- UParseError parseStatus;
- UErrorCode openStatus = U_ZERO_ERROR;
- String rules(breakRules);
-- iterator = static_cast<TextBreakIterator*>(ubrk_openRules(rules.characters(), rules.length(), 0, 0, &parseStatus, &openStatus));
-+ iterator = reinterpret_cast<TextBreakIterator*>(ubrk_openRules(rules.characters(), rules.length(), 0, 0, &parseStatus, &openStatus));
- createdIterator = true;
- ASSERT_WITH_MESSAGE(U_SUCCESS(openStatus), "ICU could not open a break iterator: %s (%d)", u_errorName(openStatus), openStatus);
- }
-@@ -144,7 +143,7 @@ static TextBreakIterator* setUpIteratorWithRules(bool& createdIterator, TextBrea
- return 0;
-
- UErrorCode setTextStatus = U_ZERO_ERROR;
-- ubrk_setText(iterator, string, length, &setTextStatus);
-+ ubrk_setText(reinterpret_cast<UBreakIterator*>(iterator), string, length, &setTextStatus);
- if (U_FAILURE(setTextStatus))
- return 0;
-
diff --git a/net-libs/webkit-gtk/metadata.xml b/net-libs/webkit-gtk/metadata.xml
index 6315a1f7754f..9469fa04d771 100644
--- a/net-libs/webkit-gtk/metadata.xml
+++ b/net-libs/webkit-gtk/metadata.xml
@@ -3,7 +3,9 @@
<pkgmetadata>
<herd>gnome</herd>
<use>
- <flag name="coverage">enable code coverage support</flag>
+ <flag name="coverage">enable code coverage support</flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
<flag name="websockets">enable full duplex single socket communication</flag>
</use>
</pkgmetadata>
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.2.1.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild
index dab3e14ad69d..2f9ff27a72ce 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.2.1.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.2.1.ebuild,v 1.4 2010/07/09 08:07:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild,v 1.1 2010/10/11 13:47:37 pacho Exp $
-EAPI="2"
+EAPI="3"
inherit autotools flag-o-matic eutils virtualx
@@ -14,9 +14,8 @@ SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-# geoclue
-# FIXME: we are still not ready for introspection
-IUSE="coverage debug doc +gstreamer +websockets" # aqua
+# geoclue is missing
+IUSE="coverage debug doc +gstreamer introspection" # aqua
# use sqlite, svg by default
# dependency on >=x11-libs/gtk+-2.13 for gail
@@ -38,11 +37,8 @@ RDEPEND="
gstreamer? (
media-libs/gstreamer:0.10
- >=media-libs/gst-plugins-base-0.10.25:0.10 )"
-# introspection? (
-# >=dev-libs/gobject-introspection-0.6.2
-# !!dev-libs/gir-repository[webkit]
-# dev-libs/gir-repository[libsoup] )
+ >=media-libs/gst-plugins-base-0.10.25:0.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )"
DEPEND="${RDEPEND}
>=sys-devel/flex-2.5.33
@@ -55,23 +51,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
- # Build failure with icu-4.4, bug 308699
- epatch "${FILESDIR}"/${PN}-1.2.1-icu-4.4.patch
-
# FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
# https://bugs.webkit.org/show_bug.cgi?id=19775
- use sparc && epatch "${FILESDIR}"/${PN}-1.1.15.2-unaligned.patch
+ use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
# Darwin/Aqua build is broken, needs autoreconf
# XXX: BROKEN. Patch does not apply anymore.
# https://bugs.webkit.org/show_bug.cgi?id=28727
#epatch "${FILESDIR}"/${PN}-1.1.15.4-darwin-quartz.patch
- # Make it libtool-1 compatible
- rm -v autotools/lt* autotools/libtool.m4 \
- || die "removing libtool macros failed"
# Don't force -O2
sed -i 's/-O2//g' "${S}"/configure.ac || die "sed failed"
+
# Prevent maintainer mode from being triggered during make
AT_M4DIR=autotools eautoreconf
}
@@ -87,10 +78,12 @@ src_configure() {
myconf="
--disable-introspection
+ --disable-web_sockets
$(use_enable coverage)
$(use_enable debug)
$(use_enable gstreamer video)
- $(use_enable websockets web_sockets)"
+ $(use_enable introspection)"
+ # Disable web-sockets per bug #326547
# quartz patch above does not apply anymore
#$(use aqua && echo "--with-target=quartz")"
@@ -105,14 +98,14 @@ src_test() {
Xemake check || die "Test phase failed"
}
-#src_compile() {
+src_compile() {
# Fix sandbox error with USE="introspection"
# https://bugs.webkit.org/show_bug.cgi?id=35471
-# addpredict "$(unset HOME; echo ~)/.local"
-# emake || die "Compile failed"
-#}
+ addpredict "$(unset HOME; echo ~)/.local"
+ emake || die "Compile failed"
+}
src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
+ emake DESTDIR="${ED}" install || die "Install failed"
dodoc WebKit/gtk/{NEWS,ChangeLog} || die "dodoc failed"
}