summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-06 05:09:38 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-06-06 05:09:38 +0000
commitd655ec2255fff10aa0969f9640687503da371d8a (patch)
treedcfd0d28d9c723c4e94a1271355a46438089b875 /net-libs/webkit-gtk
parentVersion bump. Convert to distutils-r1. Enable python3. (diff)
downloadgentoo-2-d655ec2255fff10aa0969f9640687503da371d8a.tar.gz
gentoo-2-d655ec2255fff10aa0969f9640687503da371d8a.tar.bz2
gentoo-2-d655ec2255fff10aa0969f9640687503da371d8a.zip
Fix linking failure with harfbuzz-0.9.18, and add a subslot dependency to allow for automatic rebuilding when 0.9.18-rX is subslotted.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.0.2-harfbuzz-0.9.18.patch32
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.0.1.ebuild4
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.0.2.ebuild7
4 files changed, 46 insertions, 5 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 5abb04d7f74a..a64ef224c57b 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.205 2013/05/28 05:23:26 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.206 2013/06/06 05:09:38 tetromino Exp $
+
+ 06 Jun 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ webkit-gtk-2.0.1.ebuild, webkit-gtk-2.0.2.ebuild,
+ +files/webkit-gtk-2.0.2-harfbuzz-0.9.18.patch:
+ Fix linking failure with harfbuzz-0.9.18, and add a subslot dependency to
+ allow for automatic rebuilding when 0.9.18-rX is subslotted.
28 May 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
webkit-gtk-1.10.2-r300.ebuild, +files/webkit-gtk-1.10.2-gcc-4.8.patch,
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.0.2-harfbuzz-0.9.18.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.0.2-harfbuzz-0.9.18.patch
new file mode 100644
index 000000000000..df054556ad60
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.0.2-harfbuzz-0.9.18.patch
@@ -0,0 +1,32 @@
+2013-05-30 Alberto Garcia <agarcia@igalia.com>
+
+ [GTK] Needs to check for harfbuzz-icu
+ https://bugs.webkit.org/show_bug.cgi?id=116978
+
+ Reviewed by Xan Lopez.
+
+ HarfBuzz 0.9.18 splits harbuzz-icu into a separate library so we
+ also need to check for it in order to get the necessary flags for
+ the compiler and the linker.
+
+ We keep this conditional for now since we still want to support
+ earlier versions of HarfBuzz.
+
+ * Source/autotools/FindDependencies.m4:
+
+Index: /trunk/Source/autotools/FindDependencies.m4
+===================================================================
+--- /trunk/Source/autotools/FindDependencies.m4 (revision 150962)
++++ /trunk/Source/autotools/FindDependencies.m4 (revision 150963)
+@@ -376,4 +376,11 @@
+ [cairo-ft fontconfig >= fontconfig_required_version freetype2 >= freetype2_required_version harfbuzz >= harfbuzz_required_version])
+ fi
++# HarfBuzz 0.9.18 splits harbuzz-icu into a separate library.
++# Since we support earlier HarfBuzz versions we keep this conditional for now.
++if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
++ PKG_CHECK_MODULES(HARFBUZZ_ICU, harfbuzz-icu >= $harfbuzz_required_version)
++ FREETYPE_CFLAGS+=" $HARFBUZZ_ICU_CFLAGS"
++ FREETYPE_LIBS+=" $HARFBUZZ_ICU_LIBS"
++fi
+ AC_SUBST([FREETYPE_CFLAGS])
+ AC_SUBST([FREETYPE_LIBS])
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.0.1.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.0.1.ebuild
index b5f149120af5..ed4aea5f4c38 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.0.1.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.0.1.ebuild,v 1.3 2013/05/01 09:31:28 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.0.1.ebuild,v 1.4 2013/06/06 05:09:38 tetromino Exp $
EAPI="5"
inherit autotools check-reqs eutils flag-o-matic gnome2-utils pax-utils toolchain-funcs versionator virtualx
@@ -25,7 +25,7 @@ RDEPEND="
app-crypt/libsecret
dev-libs/libxml2:2
dev-libs/libxslt
- media-libs/harfbuzz
+ media-libs/harfbuzz:=
media-libs/libwebp
virtual/jpeg:=
>=media-libs/libpng-1.4:0=
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.0.2.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.0.2.ebuild
index 98fe23a22a11..4826e6a2f6b7 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.0.2.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.0.2.ebuild,v 1.1 2013/05/15 11:53:32 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.0.2.ebuild,v 1.2 2013/06/06 05:09:38 tetromino Exp $
EAPI="5"
inherit autotools check-reqs eutils flag-o-matic gnome2-utils pax-utils toolchain-funcs versionator virtualx
@@ -25,7 +25,7 @@ RDEPEND="
app-crypt/libsecret
dev-libs/libxml2:2
dev-libs/libxslt
- media-libs/harfbuzz
+ media-libs/harfbuzz:=
media-libs/libwebp
virtual/jpeg:=
>=media-libs/libpng-1.4:0=
@@ -150,6 +150,9 @@ src_prepare() {
# garbage collection test fails intermittently if icedtea-web is installed, bug #????
epatch "${FILESDIR}/${PN}-1.7.90-test_garbage_collection.patch"
+ # Fix linking with harfbuzz-0.9.18; in 2.1.x
+ epatch "${FILESDIR}/${PN}-2.0.2-harfbuzz-0.9.18.patch"
+
# Respect CC, otherwise fails on prefix #395875
tc-export CC