summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-26 03:40:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-26 03:40:01 +0000
commitba95ead6b1aa78e14e27f7d26fbd84962a72c31e (patch)
treea522d90c00471e1e1d426242214c0eafab922cce /net-libs/wvstreams
parentAdded keyword for ia64. (diff)
downloadgentoo-2-ba95ead6b1aa78e14e27f7d26fbd84962a72c31e.tar.gz
gentoo-2-ba95ead6b1aa78e14e27f7d26fbd84962a72c31e.tar.bz2
gentoo-2-ba95ead6b1aa78e14e27f7d26fbd84962a72c31e.zip
gcc3 patches #28548
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/ChangeLog9
-rw-r--r--net-libs/wvstreams/files/3.70-gcc3.patch71
-rw-r--r--net-libs/wvstreams/files/3.70-openssl.patch12
-rw-r--r--net-libs/wvstreams/wvstreams-3.70-r2.ebuild27
4 files changed, 101 insertions, 18 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 9b3cdfaa370c..531ca44a28f3 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,14 +1,17 @@
# ChangeLog for net-libs/wvstreams
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.9 2003/07/28 15:52:40 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.10 2003/09/26 03:40:01 vapier Exp $
+
+*wvstreams-3.70-r2 (31 Oct 2002)
+
+ 25 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add gcc3 + openssl patches #28548.
12 Jun 2003; <msterret@gentoo.org> wvstreams-3.70-r2.ebuild:
fix Header
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-*wvstreams-3.70-r2 (31 Oct 2002)
-
28 Jul 2003; Guy Martin <gmsoft@gentoo.org> wvstreams-3.70-r2.ebuild :
Added hppa to KEYWORDS and -fPIC to CXXFLAGS for hppa.
diff --git a/net-libs/wvstreams/files/3.70-gcc3.patch b/net-libs/wvstreams/files/3.70-gcc3.patch
new file mode 100644
index 000000000000..e9b0f4b1d82f
--- /dev/null
+++ b/net-libs/wvstreams/files/3.70-gcc3.patch
@@ -0,0 +1,71 @@
+diff -ur wvstreams-3.70/src/ipstreams/wvaddr.cc wvstreams-3.70/src/ipstreams/wvaddr.cc
+--- wvstreams-3.70/src/ipstreams/wvaddr.cc 2002-03-04 18:39:42.000000000 -0500
++++ wvstreams-3.70/src/ipstreams/wvaddr.cc 2002-05-20 14:14:04.000000000 -0400
+@@ -637,7 +637,7 @@
+ }
+
+
+-WvIPPortAddr::WvIPPortAddr(const unsigned char _ipaddr[4], __u16 _port)
++WvIPPortAddr::WvIPPortAddr(const unsigned char *_ipaddr, __u16 _port)
+ : WvIPAddr(_ipaddr)
+ {
+ port = _port;
+diff -ur wvstreams-3.70/src/ipstreams/wvaddr.h wvstreams-3.70/src/ipstreams/wvaddr.h
+--- wvstreams-3.70/src/ipstreams/wvaddr.h 2002-04-02 15:53:20.000000000 -0500
++++ wvstreams-3.70/src/ipstreams/wvaddr.h 2002-05-20 14:13:54.000000000 -0400
+@@ -221,7 +221,7 @@
+ public:
+ unsigned char binaddr[4];
+
+- WvIPAddr(const unsigned char _binaddr[4])
++ WvIPAddr(const unsigned char *_binaddr)
+ { if (_binaddr) memcpy(binaddr, _binaddr, 4); }
+ WvIPAddr(const __u32 _binaddr = 0)
+ { memcpy(binaddr, &_binaddr, 4); }
+diff -ur wvstreams-3.70/src/ipstreams/wvresolver.cc wvstreams-3.70/src/ipstreams/wvresolver.cc
+--- wvstreams-3.70/src/ipstreams/wvresolver.cc 2002-03-01 23:33:08.000000000 -0500
++++ wvstreams-3.70/src/ipstreams/wvresolver.cc 2002-05-20 14:52:47.000000000 -0400
+@@ -128,7 +128,7 @@
+ // If addr==NULL, this just tests to see if the name exists.
+ int WvResolver::findaddr(int msec_timeout, const WvString &name,
+ WvIPAddr const **addr,
+- WvIPAddrList *addrlist = NULL)
++ WvIPAddrList *addrlist)
+ {
+ WvResolverHost *host;
+ time_t now = time(NULL);
+diff -ur wvstreams-3.70/wvrules.mk wvstreams-3.70/wvrules.mk
+--- wvstreams-3.70/wvrules.mk 2002-05-20 15:05:07.000000000 -0400
++++ wvstreams-3.70/wvrules.mk 2002-05-20 14:56:23.000000000 -0400
+@@ -245,16 +245,16 @@
+ ranlib $@
+
+ %.so:
+- @echo $(CC) $(LDFLAGS) $($@-LDFLAGS) -shared -o $@ $^ $($@-LIBS) $(LIBS) $(XX_LIBS)
++ @echo $(CXX) $(LDFLAGS) $($@-LDFLAGS) -shared -o $@ $^ $($@-LIBS) $(LIBS) $(XX_LIBS)
+ @set -e; \
+ $(define_libexpand); \
+- $(CC) $(LDFLAGS) $($@-LDFLAGS) -shared -o $@ \
++ $(CXX) $(LDFLAGS) $($@-LDFLAGS) -shared -o $@ \
+ $(filter %.o %.a %.so,$^) \
+ $$(libexpand . $(filter %.libs,$^)) \
+ $($@-LIBS) $(LIBS) $(XX_LIBS)
+
+ %: %.o
+- $(CC) $(LDFLAGS) $($@-LDFLAGS) -o $@ $(filter %.o %.a %.so, $^) $($@-LIBS) $(LIBS) $(XX_LIBS)
++ $(CXX) $(LDFLAGS) $($@-LDFLAGS) -o $@ $(filter %.o %.a %.so, $^) $($@-LIBS) $(LIBS) $(XX_LIBS)
+
+ # Force objects to be built before final binaries
+ $(addsuffix .o,$(basename $(wildcard *.c) $(wildcard *.cc) $(wildcard *.cpp))):
+diff -Nru wvstreams-3.70-clean/src/ipstreams/wvaddr.h wvstreams-3.70/src/ipstreams/wvaddr.h
+--- wvstreams-3.70-clean/src/ipstreams/wvaddr.h Tue Apr 2 20:53:20 2002
++++ wvstreams-3.70/src/ipstreams/wvaddr.h Thu Jul 4 02:32:27 2002
+@@ -369,7 +369,8 @@
+ __u16 port;
+
+ WvIPPortAddr();
+ WvIPPortAddr(const unsigned char _ipaddr[4], __u16 _port = 0);
++ WvIPPortAddr(unsigned char _ipaddr[4], __u16 _port = 0);
+ WvIPPortAddr(const WvIPAddr &_ipaddr, __u16 _port = 0);
+ WvIPPortAddr(const char string[]) : WvIPAddr(string)
+ { string_init(string); }
diff --git a/net-libs/wvstreams/files/3.70-openssl.patch b/net-libs/wvstreams/files/3.70-openssl.patch
new file mode 100644
index 000000000000..a3f97dd785f7
--- /dev/null
+++ b/net-libs/wvstreams/files/3.70-openssl.patch
@@ -0,0 +1,12 @@
+--- wvstreams-3.70/src/crypto/wvcrypto.cc 2003-01-03 12:51:22.000000000 -0500
++++ wvstreams-3.70/src/crypto/wvcrypto.cc 2003-01-03 12:51:51.000000000 -0500
+@@ -146,7 +146,8 @@
+ int bufsize = ((hexbytes < 2048) ? 2048 : hexbytes) + 16;
+ //int bufsize = hexbytes/2;
+
+- unsigned char *keybuf = new unsigned char[bufsize], *bufp;
++ unsigned char *keybuf = new unsigned char[bufsize];
++ const unsigned char *bufp;
+ char *keystr;
+ RSA *rp;
+
diff --git a/net-libs/wvstreams/wvstreams-3.70-r2.ebuild b/net-libs/wvstreams/wvstreams-3.70-r2.ebuild
index 44b732207584..311c4dbcc5de 100644
--- a/net-libs/wvstreams/wvstreams-3.70-r2.ebuild
+++ b/net-libs/wvstreams/wvstreams-3.70-r2.ebuild
@@ -1,37 +1,34 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.70-r2.ebuild,v 1.13 2003/09/10 04:53:57 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-3.70-r2.ebuild,v 1.14 2003/09/26 03:40:01 vapier Exp $
+
+inherit flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://open.nit.ca/wiki/?page=WvStreams"
SRC_URI="http://open.nit.ca/download/${P}.tar.gz"
-HOMEPAGE="http://open.nit.ca/wvstreams"
-
-DEPEND="virtual/glibc"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 sparc alpha amd64 hppa"
-src_unpack() {
+DEPEND="virtual/glibc"
+src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die "Patching failed"
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+ epatch ${FILESDIR}/${PV}-openssl.patch
if [ "${ARCH}" = "alpha" -o "${ARCH}" = "hppa" ]; then
- sed "s:CXXOPTS += :CXXOPTS += -fPIC :" <Makefile >Makefile.sed
- mv Makefile.sed Makefile
+ sed -i "s:CXXOPTS += :CXXOPTS += -fPIC :" Makefile
fi
}
src_compile() {
- CFLAGS="${CFLAGS} -Wno-deprecated"
+ append-flags -Wno-deprecated
make || die
}
src_install() {
-
- make \
- PREFIX=${D}/usr \
- install || die
+ make PREFIX=${D}/usr install || die
}