summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-27 13:26:09 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-27 13:26:09 +0000
commit000dd0d253eaf618408f4c5e63154126749ce0de (patch)
tree2e011c9455a239d1b5032573653861cfd273c987 /net-libs
parentRestrict libav to version >=9.11 when using vdpau USE flag, see bug #489534 c... (diff)
downloadgentoo-2-000dd0d253eaf618408f4c5e63154126749ce0de.tar.gz
gentoo-2-000dd0d253eaf618408f4c5e63154126749ce0de.tar.bz2
gentoo-2-000dd0d253eaf618408f4c5e63154126749ce0de.zip
net-im/ktp-call-ui still needs old version, thanks for johu for pointing this
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-farstream/ChangeLog7
-rw-r--r--net-libs/telepathy-farstream/telepathy-farstream-0.4.0.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/telepathy-farstream/ChangeLog b/net-libs/telepathy-farstream/ChangeLog
index 675401776788..5ba6e3342bf9 100644
--- a/net-libs/telepathy-farstream/ChangeLog
+++ b/net-libs/telepathy-farstream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-farstream
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.20 2013/10/27 09:47:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.21 2013/10/27 13:26:09 pacho Exp $
+
+*telepathy-farstream-0.4.0 (27 Oct 2013)
+
+ 27 Oct 2013; Pacho Ramos <pacho@gentoo.org> +telepathy-farstream-0.4.0.ebuild:
+ net-im/ktp-call-ui still needs old version, thanks for johu for pointing this
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> -telepathy-farstream-0.4.0.ebuild,
metadata.xml:
diff --git a/net-libs/telepathy-farstream/telepathy-farstream-0.4.0.ebuild b/net-libs/telepathy-farstream/telepathy-farstream-0.4.0.ebuild
new file mode 100644
index 000000000000..8be4baaabeaf
--- /dev/null
+++ b/net-libs/telepathy-farstream/telepathy-farstream-0.4.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/telepathy-farstream-0.4.0.ebuild,v 1.7 2013/10/27 13:26:09 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.5"
+PYTHON_USE_WITH="xml"
+PYTHON_USE_WITH_OPT="python"
+
+inherit python
+
+DESCRIPTION="Telepathy client library that uses Farstream to handle Call channels"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="examples python"
+
+RDEPEND=">=dev-libs/glib-2.30:2
+ >=sys-apps/dbus-0.60
+ >=dev-libs/dbus-glib-0.60
+ >=net-libs/telepathy-glib-0.17.5
+ >=net-libs/farstream-0.1.0:0.1
+ python? (
+ >=dev-python/pygobject-2.12.0:2
+ >=dev-python/gst-python-0.10.10 )"
+# python2 is needed at build time in all cases
+DEPEND="${RDEPEND}
+ !python? ( =dev-lang/python-2*[xml] )"
+
+pkg_setup() {
+ # Needed for xincludator.py at build time even if USE=-python
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ if use python; then
+ python_convert_shebangs -r 2 .
+ fi
+}
+
+src_configure() {
+ econf $(use_enable python) --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Remove .la files since static libs are disabled
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ if use python; then
+ insinto /usr/share/doc/${PF}/examples/python
+ doins python/examples/*.py
+ fi
+ fi
+}