summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-07-04 21:30:36 +0000
committerRick Farina <zerochaos@gentoo.org>2014-07-04 21:30:36 +0000
commit1b22354bd255be0444c02d80fa4cf80f5b35a641 (patch)
tree703b11344a6ec12e725fb0009735242b2e438fb3 /net-libs
parentStable on alpha, bug #495380 (diff)
downloadgentoo-2-1b22354bd255be0444c02d80fa4cf80f5b35a641.tar.gz
gentoo-2-1b22354bd255be0444c02d80fa4cf80f5b35a641.tar.bz2
gentoo-2-1b22354bd255be0444c02d80fa4cf80f5b35a641.zip
fix for bug 516178, wireshark 1.12 renamed a header file, backport from git
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libbtbb/ChangeLog6
-rw-r--r--net-libs/libbtbb/libbtbb-2012.10.3-r2.ebuild60
-rw-r--r--net-libs/libbtbb/libbtbb-2014.02.2.ebuild3
3 files changed, 7 insertions, 62 deletions
diff --git a/net-libs/libbtbb/ChangeLog b/net-libs/libbtbb/ChangeLog
index 0e6182735b1b..d746678891f3 100644
--- a/net-libs/libbtbb/ChangeLog
+++ b/net-libs/libbtbb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libbtbb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/ChangeLog,v 1.15 2014/04/04 19:51:31 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/ChangeLog,v 1.16 2014/07/04 21:30:36 zerochaos Exp $
+
+ 04 Jul 2014; Rick Farina <zerochaos@gentoo.org> -libbtbb-2012.10.3-r2.ebuild,
+ libbtbb-2014.02.2.ebuild, libbtbb-9999.ebuild:
+ fix for bug 516178, wireshark 1.12 renamed a header file, backport from git
*libbtbb-2014.02.2 (04 Apr 2014)
diff --git a/net-libs/libbtbb/libbtbb-2012.10.3-r2.ebuild b/net-libs/libbtbb/libbtbb-2012.10.3-r2.ebuild
deleted file mode 100644
index cfffe3f85793..000000000000
--- a/net-libs/libbtbb/libbtbb-2012.10.3-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/libbtbb-2012.10.3-r2.ebuild,v 1.2 2013/06/03 04:11:45 zerochaos Exp $
-
-EAPI=5
-
-inherit multilib cmake-utils
-
-DESCRIPTION="A library to decode Bluetooth baseband packets"
-HOMEPAGE="http://libbtbb.sourceforge.net/"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="http://git.code.sf.net/p/libbtbb/code"
- SRC_URI=""
- inherit git-2
- KEYWORDS=""
-else
- MY_P=${P/\./-}
- MY_P=${MY_P/./-R}
- S=${WORKDIR}/${MY_P}
- SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0/1"
-IUSE="+wireshark"
-
-RDEPEND="
- wireshark? (
- dev-libs/glib
- >=net-analyzer/wireshark-1.8.3-r1:=
- )
-"
-DEPEND="${RDEPEND}
- wireshark? ( virtual/pkgconfig )"
-
-get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
-
-CMAKE_USE_DIR="${S}"/wireshark/plugins/btbb
-
-src_prepare() {
- sed -i \
- -e '/set(CMAKE_INSTALL_LIBDIR/ d' \
- -e "s:R} N:R}/wireshark/plugins/$(get_PV net-analyzer/wireshark) N:" \
- ${CMAKE_USE_DIR}/CMakeLists.txt || die
-}
-
-src_compile() {
- default_src_compile
- use wireshark && cmake-utils_src_compile
-}
-
-src_install() {
- dodir /usr/$(get_libdir)
- dodir /usr/include
- emake LDCONFIG=true DESTDIR="${D}" INSTALL_DIR="${ED}/usr/$(get_libdir)" INCLUDE_DIR="${ED}/usr/include" install
-
- use wireshark && cmake-utils_src_install
-}
diff --git a/net-libs/libbtbb/libbtbb-2014.02.2.ebuild b/net-libs/libbtbb/libbtbb-2014.02.2.ebuild
index 2f11a8c16731..e488cfd85056 100644
--- a/net-libs/libbtbb/libbtbb-2014.02.2.ebuild
+++ b/net-libs/libbtbb/libbtbb-2014.02.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/libbtbb-2014.02.2.ebuild,v 1.1 2014/04/04 19:51:31 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/libbtbb-2014.02.2.ebuild,v 1.2 2014/07/04 21:30:36 zerochaos Exp $
EAPI=5
@@ -44,6 +44,7 @@ src_prepare(){
if use wireshark-plugins; then
for i in btbb btle btsm
do
+ sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
BUILD_DIR="${WORKDIR}"/${i}_build
cmake-utils_src_prepare