summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-16 20:48:14 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-16 20:48:14 +0000
commit1b63258130f60168e91a89f23d0d6b515b48c7d7 (patch)
tree0493c8adf7007dbc45e782d633bdc764e457b436 /net-libs
parentMigrate hardened/linux/uclibc to default/linux/uclibc (diff)
downloadgentoo-2-1b63258130f60168e91a89f23d0d6b515b48c7d7.tar.gz
gentoo-2-1b63258130f60168e91a89f23d0d6b515b48c7d7.tar.bz2
gentoo-2-1b63258130f60168e91a89f23d0d6b515b48c7d7.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/txtorcon/ChangeLog7
-rw-r--r--net-libs/txtorcon/txtorcon-0.11.0.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/net-libs/txtorcon/ChangeLog b/net-libs/txtorcon/ChangeLog
index 817c57a72ea1..a62e93b6014a 100644
--- a/net-libs/txtorcon/ChangeLog
+++ b/net-libs/txtorcon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/txtorcon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/ChangeLog,v 1.1 2014/08/04 22:34:45 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/ChangeLog,v 1.2 2014/08/16 20:48:14 mrueg Exp $
+
+*txtorcon-0.11.0 (16 Aug 2014)
+
+ 16 Aug 2014; Manuel Rüger <mrueg@gentoo.org> +txtorcon-0.11.0.ebuild:
+ Version bump.
*txtorcon-0.10.1 (04 Aug 2014)
diff --git a/net-libs/txtorcon/txtorcon-0.11.0.ebuild b/net-libs/txtorcon/txtorcon-0.11.0.ebuild
new file mode 100644
index 000000000000..59b8a52f1616
--- /dev/null
+++ b/net-libs/txtorcon/txtorcon-0.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/txtorcon-0.11.0.ebuild,v 1.1 2014/08/16 20:48:14 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Twisted-based Tor controller client, with state-tracking and configuration abstractions"
+HOMEPAGE="https://github.com/meejah/txtorcon https://pypi.python.org/pypi/txtorcon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ net-misc/tor
+ net-zope/zope-interface[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ trial --reporter=text test || die
+}