summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-25 11:43:56 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-25 11:43:56 +0000
commit49d546ec1892baeed6cc113e4023526e984e1ac1 (patch)
tree3d2b3f5b387ecfe11f01136d338f4bc892cd709e /net-libs
parentStable for HPPA (bug #385239). (diff)
downloadgentoo-2-49d546ec1892baeed6cc113e4023526e984e1ac1.tar.gz
gentoo-2-49d546ec1892baeed6cc113e4023526e984e1ac1.tar.bz2
gentoo-2-49d546ec1892baeed6cc113e4023526e984e1ac1.zip
Version bump.
(Portage version: 2.1.10.31/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-glib/ChangeLog7
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.16.1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 134c0ae236d8..efa8261ed22f 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.90 2011/10/21 15:01:18 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.91 2011/10/25 11:43:56 pacho Exp $
+
+*telepathy-glib-0.16.1 (25 Oct 2011)
+
+ 25 Oct 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-glib-0.16.1.ebuild:
+ Version bump.
21 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
telepathy-glib-0.14.10.ebuild:
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.16.1.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.16.1.ebuild
new file mode 100644
index 000000000000..07ca2b0bbfba
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.16.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.16.1.ebuild,v 1.1 2011/10/25 11:43:56 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+
+inherit python virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="debug +introspection +vala"
+
+RDEPEND=">=dev-libs/glib-2.28.0:2
+ >=dev-libs/dbus-glib-0.82
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ vala? (
+ dev-lang/vala:0.14[vapigen]
+ >=dev-libs/gobject-introspection-0.9.6 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_prepare() {
+ python_convert_shebangs -r 2 examples tests tools
+ default_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.14)
+ VAPIGEN=$(type -p vapigen-0.14)"
+ fi
+
+ econf --disable-static \
+ PYTHON=$(PYTHON -2 -a) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings) \
+ ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Needs dbus for tests (auto-launched)
+ Xemake -j1 check || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}