summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-06-17 09:21:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-06-17 09:21:32 +0000
commit65aaa55ee326239df8e3c22d6b2ebe146cb1a778 (patch)
treef3b47a3f4968c34ded0e2696e2c6c4bbb1160021 /net-libs
parentAdd init script to automatically start/save virtual machines on boot/shutdown... (diff)
downloadgentoo-2-65aaa55ee326239df8e3c22d6b2ebe146cb1a778.tar.gz
gentoo-2-65aaa55ee326239df8e3c22d6b2ebe146cb1a778.tar.bz2
gentoo-2-65aaa55ee326239df8e3c22d6b2ebe146cb1a778.zip
Version bump. Bug #415655
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/ChangeLog7
-rw-r--r--net-libs/libupnp/libupnp-1.6.17.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/net-libs/libupnp/ChangeLog b/net-libs/libupnp/ChangeLog
index dd8f4c42d389..576461e0e89a 100644
--- a/net-libs/libupnp/ChangeLog
+++ b/net-libs/libupnp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libupnp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/ChangeLog,v 1.27 2012/05/29 15:14:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/ChangeLog,v 1.28 2012/06/17 09:21:32 hwoarang Exp $
+
+*libupnp-1.6.17 (17 Jun 2012)
+
+ 17 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +libupnp-1.6.17.ebuild:
+ Version bump. Bug #415655
29 May 2012; Alexis Ballier <aballier@gentoo.org> libupnp-1.6.14.ebuild:
keyword ~amd64-fbsd
diff --git a/net-libs/libupnp/libupnp-1.6.17.ebuild b/net-libs/libupnp/libupnp-1.6.17.ebuild
new file mode 100644
index 000000000000..a64d2607b53c
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.6.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libupnp/libupnp-1.6.17.ebuild,v 1.1 2012/06/17 09:21:32 hwoarang Exp $
+
+EAPI="4"
+WANT_AUTOMAKE=1.9
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pupnp/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc ipv6 static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+DOCS="NEWS README ChangeLog"
+
+src_prepare() {
+ sed -e '/AX_CFLAGS_GCC_OPTION/s:-Os::g' \
+ -i "${S}/configure.ac" || die
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable static-libs static) \
+ $(use_with doc documentation "${EPREFIX}/usr/share/doc/${PF}")
+}
+
+src_install () {
+ default
+ dobin upnp/sample/.libs/tv_{combo,ctrlpt,device}
+ use static-libs || find "${ED}" -type f -name '*.la' -delete
+}
+
+pkg_postinst() {
+ ewarn "Please remember to run revdep-rebuild when upgrading"
+ ewarn "from libupnp 1.4.x to libupnp 1.6.x , so packages"
+ ewarn "gets linked with the new library."
+ ewarn ""
+ ewarn "The revdep-rebuild script is part of the"
+ ewarn "app-portage/gentoolkit package."
+}