summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-03-29 21:15:05 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-03-29 21:15:05 +0000
commit69188af106306ca722e0e511c2a50e64e70593f6 (patch)
treefeac87b7ce22e13f277e3f960ca83d64083cdb84 /net-libs
parentVersion bump (diff)
downloadgentoo-2-69188af106306ca722e0e511c2a50e64e70593f6.tar.gz
gentoo-2-69188af106306ca722e0e511c2a50e64e70593f6.tar.bz2
gentoo-2-69188af106306ca722e0e511c2a50e64e70593f6.zip
Fix perl-5.18 compatibility, bug#504028, thanks to Kerin Millar
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnutls/ChangeLog8
-rw-r--r--net-libs/gnutls/files/gnutls-2.12.23-gdoc-perl-5.18.patch137
-rw-r--r--net-libs/gnutls/gnutls-2.12.23-r5.ebuild118
3 files changed, 262 insertions, 1 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index ec0f1b2cc3a2..822fd7b173e8 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.482 2014/03/24 14:29:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.483 2014/03/29 21:15:05 alonbl Exp $
+
+*gnutls-2.12.23-r5 (29 Mar 2014)
+
+ 29 Mar 2014; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/gnutls-2.12.23-gdoc-perl-5.18.patch, +gnutls-2.12.23-r5.ebuild:
+ Fix perl-5.18 compatibility, bug#504028, thanks to Kerin Millar
24 Mar 2014; Agostino Sarubbo <ago@gentoo.org> gnutls-2.12.23-r4.ebuild:
Stable for ppc64, wrt bug #503394
diff --git a/net-libs/gnutls/files/gnutls-2.12.23-gdoc-perl-5.18.patch b/net-libs/gnutls/files/gnutls-2.12.23-gdoc-perl-5.18.patch
new file mode 100644
index 000000000000..a89e8f253058
--- /dev/null
+++ b/net-libs/gnutls/files/gnutls-2.12.23-gdoc-perl-5.18.patch
@@ -0,0 +1,137 @@
+--- gnutls-2.12.23.orig/doc/scripts/gdoc 2011-04-08 02:30:44.000000000 +0200
++++ gnutls-2.12.23/doc/scripts/gdoc 2014-03-10 01:53:28.899566076 +0200
+@@ -7,6 +7,8 @@
+ ## Copyright (c) 2001, 2002 Nikos Mavrogiannopoulos
+ ## added -tex
+ ## Copyright (c) 1998 Michael Zucchi
++## Copyright (c) 2013 Adam Sampson
++## made highlighting not depend on hash order, for Perl 5.18
+
+ # This program is free software: you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+@@ -143,44 +145,44 @@
+ # One for each output format
+
+ # these work fairly well
+-%highlights_html = ( $type_constant, "<i>\$2</i>",
+- $type_func, "<b>\$1</b>",
+- $type_struct, "<i>\$1</i>",
+- $type_param, "<tt><b>\$1</b></tt>" );
++@highlights_html = ( [$type_constant, "<i>\$2</i>"],
++ [$type_func, "<b>\$1</b>"],
++ [$type_struct, "<i>\$1</i>"],
++ [$type_param, "<tt><b>\$1</b></tt>"] );
+ $blankline_html = "<p>";
+
+-%highlights_texinfo = ( $type_constant, "\\\@code{\$2}",
+- $type_func, "\\\@code{\$1}",
+- $type_struct, "\\\@code{\$1}",
+- $type_param, "\\\@code{\$1}" );
++@highlights_texinfo = ( [$type_constant, "\\\@code{\$2}"],
++ [$type_func, "\\\@code{\$1}"],
++ [$type_struct, "\\\@code{\$1}"],
++ [$type_param, "\\\@code{\$1}"] );
+ $blankline_texinfo = "";
+
+-%highlights_tex = ( $type_constant, "{\\\\it \$2}",
+- $type_func, "{\\\\bf \$1}",
+- $type_struct, "{\\\\it \$1}",
+- $type_param, "{\\\\bf \$1}" );
++@highlights_tex = ( [$type_constant, "{\\\\it \$2}"],
++ [$type_func, "{\\\\bf \$1}"],
++ [$type_struct, "{\\\\it \$1}"],
++ [$type_param, "{\\\\bf \$1}"] );
+ $blankline_tex = "\\\\";
+
+ # sgml, docbook format
+-%highlights_sgml = ( $type_constant, "<replaceable class=\"option\">\$2</replaceable>",
+- $type_func, "<function>\$1</function>",
+- $type_struct, "<structname>\$1</structname>",
+- $type_env, "<envar>\$1</envar>",
+- $type_param, "<parameter>\$1</parameter>" );
++@highlights_sgml = ( [$type_constant, "<replaceable class=\"option\">\$2</replaceable>"],
++ [$type_func, "<function>\$1</function>"],
++ [$type_struct, "<structname>\$1</structname>"],
++ [$type_env, "<envar>\$1</envar>"],
++ [$type_param, "<parameter>\$1</parameter>"] );
+ $blankline_sgml = "</para><para>\n";
+
+ # these are pretty rough
+-%highlights_man = ( $type_constant, "\\\\fB\$2\\\\fP",
+- $type_func, "\\\\fB\$1\\\\fP",
+- $type_struct, "\\\\fB\$1\\\\fP",
+- $type_param, "\\\\fI\$1\\\\fP" );
++@highlights_man = ( [$type_constant, "\\\\fB\$2\\\\fP"],
++ [$type_func, "\\\\fB\$1\\\\fP"],
++ [$type_struct, "\\\\fB\$1\\\\fP"],
++ [$type_param, "\\\\fI\$1\\\\fP"] );
+ $blankline_man = "";
+
+ # text-mode
+-%highlights_text = ( $type_constant, "\$2",
+- $type_func, "\$1",
+- $type_struct, "\$1",
+- $type_param, "\$1" );
++@highlights_text = ( [$type_constant, "\$2"],
++ [$type_func, "\$1"],
++ [$type_struct, "\$1"],
++ [$type_param, "\$1"] );
+ $blankline_text = "";
+
+
+@@ -201,7 +203,7 @@
+
+ $verbose = 0;
+ $output_mode = "man";
+-%highlights = %highlights_man;
++@highlights = @highlights_man;
+ $blankline = $blankline_man;
+ $modulename = "API Documentation";
+ $sourceversion = strftime "%Y-%m-%d", localtime;
+@@ -210,27 +212,27 @@
+ $cmd = shift @ARGV;
+ if ($cmd eq "-html") {
+ $output_mode = "html";
+- %highlights = %highlights_html;
++ @highlights = @highlights_html;
+ $blankline = $blankline_html;
+ } elsif ($cmd eq "-man") {
+ $output_mode = "man";
+- %highlights = %highlights_man;
++ @highlights = @highlights_man;
+ $blankline = $blankline_man;
+ } elsif ($cmd eq "-tex") {
+ $output_mode = "tex";
+- %highlights = %highlights_tex;
++ @highlights = @highlights_tex;
+ $blankline = $blankline_tex;
+ } elsif ($cmd eq "-texinfo") {
+ $output_mode = "texinfo";
+ %highlights = %highlights_texinfo;
+- $blankline = $blankline_texinfo;
++ @blankline = @blankline_texinfo;
+ } elsif ($cmd eq "-text") {
+ $output_mode = "text";
+ %highlights = %highlights_text;
+- $blankline = $blankline_text;
++ @blankline = @blankline_text;
+ } elsif ($cmd eq "-docbook") {
+ $output_mode = "sgml";
+- %highlights = %highlights_sgml;
++ @highlights = @highlights_sgml;
+ $blankline = $blankline_sgml;
+ } elsif ($cmd eq "-listfunc") {
+ $output_mode = "listfunc";
+@@ -322,9 +324,10 @@
+ my $line;
+ my $ret = "";
+
+- foreach $pattern (keys %highlights) {
++ foreach $highlight (@highlights) {
++ my ($pattern, $replace) = @$highlight;
+ # print "scanning pattern $pattern ($highlights{$pattern})\n";
+- $contents =~ s:$pattern:repstr($pattern, $highlights{$pattern}, $1, $2, $3, $4):gse;
++ $contents =~ s:$pattern:repstr($pattern, $replace, $1, $2, $3, $4):gse;
+ }
+ foreach $line (split "\n", $contents) {
+ if ($line eq ""){
diff --git a/net-libs/gnutls/gnutls-2.12.23-r5.ebuild b/net-libs/gnutls/gnutls-2.12.23-r5.ebuild
new file mode 100644
index 000000000000..acab22340c82
--- /dev/null
+++ b/net-libs/gnutls/gnutls-2.12.23-r5.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.12.23-r5.ebuild,v 1.1 2014/03/29 21:15:05 alonbl Exp $
+
+EAPI=5
+
+inherit autotools libtool eutils versionator
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+SRC_URI="ftp://ftp.gnutls.org/gcrypt/gnutls/v$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+# LGPL-2.1 for libgnutls library and GPL-3 for libgnutls-extra library.
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="bindist +cxx doc examples guile lzo +nettle nls pkcs11 static-libs test zlib"
+
+RDEPEND=">=dev-libs/libtasn1-0.3.4
+ <dev-libs/libtasn1-3
+ guile? ( >=dev-scheme/guile-1.8[networking] )
+ nettle? ( >=dev-libs/nettle-2.1[gmp] )
+ !nettle? ( >=dev-libs/libgcrypt-1.4.0:0 )
+ nls? ( virtual/libintl )
+ pkcs11? ( >=app-crypt/p11-kit-0.11 )
+ zlib? ( >=sys-libs/zlib-1.2.3.1 )
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+ test? ( app-misc/datefudge )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS doc/TODO )
+
+pkg_setup() {
+ if use lzo && use bindist; then
+ ewarn "lzo support is disabled for binary distribution of GnuTLS due to licensing issues."
+ fi
+}
+
+src_prepare() {
+ # tests/suite directory is not distributed
+ sed -i -e 's|AC_CONFIG_FILES(\[tests/suite/Makefile\])|:|' \
+ configure.ac || die
+
+ sed -i -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
+ doc/Makefile.am || die
+
+ for dir in . lib libextra; do
+ sed -i -e '/^AM_INIT_AUTOMAKE/s/-Werror//' "${dir}/configure.ac" || die
+ done
+
+ epatch "${FILESDIR}"/${PN}-2.12.20-AF_UNIX.patch
+ epatch "${FILESDIR}"/${PN}-2.12.20-libadd.patch
+ epatch "${FILESDIR}"/${PN}-2.12.20-guile-parallelmake.patch
+ epatch "${FILESDIR}"/${PN}-2.12.23-CVE-2013-2116.patch
+ epatch "${FILESDIR}"/${PN}-2.12.23-hppa.patch
+ epatch "${FILESDIR}"/${PN}-2.12.23-CVE-2014-0092.patch
+ epatch "${FILESDIR}"/${PN}-2.12.23-CVE-2014-1959.patch
+ epatch "${FILESDIR}"/${P}-gl-tests-getaddrinfo-skip-if-no-network.patch
+ epatch "${FILESDIR}"/${P}-gdoc-perl-5.18.patch
+
+ # support user patches
+ epatch_user
+
+ eautoreconf
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+ use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
+ [[ "${VALGRIND_TESTS}" != "1" ]] && myconf+=" --disable-valgrind-tests"
+
+ econf \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ $(use_enable cxx) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc gtk-doc-pdf) \
+ $(use_enable guile) \
+ $(use_with !nettle libgcrypt) \
+ $(use_enable nls) \
+ $(use_with pkcs11 p11-kit) \
+ $(use_enable static-libs static) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_test() {
+ if has_version dev-util/valgrind && [[ ${VALGRIND_TESTS} != 1 ]]; then
+ elog
+ elog "You can set VALGRIND_TESTS=\"1\" to enable Valgrind tests."
+ elog
+ fi
+
+ # parallel testing often fails
+ emake -j1 check
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}