summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-03 13:43:05 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-03 13:43:05 +0000
commit7082b6a92ca1b8f7a80f21ea889e79919a665b21 (patch)
treeb08e68e1c11b9e29155e96a285d0dfcab3223749 /net-libs
parentFixed compilation with "gnome-keyring" USE flag (bug #534384) (diff)
downloadgentoo-2-7082b6a92ca1b8f7a80f21ea889e79919a665b21.tar.gz
gentoo-2-7082b6a92ca1b8f7a80f21ea889e79919a665b21.tar.bz2
gentoo-2-7082b6a92ca1b8f7a80f21ea889e79919a665b21.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgadu/ChangeLog9
-rw-r--r--net-libs/libgadu/libgadu-1.12.1.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/net-libs/libgadu/ChangeLog b/net-libs/libgadu/ChangeLog
index fa48697d5fd9..35f359b07430 100644
--- a/net-libs/libgadu/ChangeLog
+++ b/net-libs/libgadu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libgadu
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.90 2014/09/23 00:55:37 reavertm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.91 2015/01/03 13:43:05 mrueg Exp $
+
+*libgadu-1.12.1 (03 Jan 2015)
+
+ 03 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +libgadu-1.12.1.ebuild:
+ Version bump.
23 Sep 2014; Maciej Mrozowski <reavertm@gentoo.org> -libgadu-1.11.0.ebuild,
-libgadu-1.11.1.ebuild:
diff --git a/net-libs/libgadu/libgadu-1.12.1.ebuild b/net-libs/libgadu/libgadu-1.12.1.ebuild
new file mode 100644
index 000000000000..86d41343d3bd
--- /dev/null
+++ b/net-libs/libgadu/libgadu-1.12.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.12.1.ebuild,v 1.1 2015/01/03 13:43:05 mrueg Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
+HOMEPAGE="http://toxygen.net/libgadu/"
+SRC_URI="https://github.com/wojtekka/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE="doc gnutls ssl static-libs test threads"
+
+REQUIRED_USE="
+ gnutls? ( ssl )
+"
+COMMON_DEPEND="
+ >=dev-libs/protobuf-c-0.15
+ sys-libs/zlib
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( >=dev-libs/openssl-0.9.6m )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-libs/expat
+ dev-libs/libxml2:2
+ net-misc/curl
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ !=net-im/kadu-0.6.0.2
+ !=net-im/kadu-0.6.0.1
+"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12.0-tests.patch"
+)
+
+DOCS=(AUTHORS ChangeLog NEWS README)
+
+src_configure() {
+ local myeconfargs=(
+ --with-protobuf
+ $(use_enable test tests)
+ $(use_with threads pthread)
+ )
+
+ if use ssl; then
+ myeconfargs+=(
+ $(use_with gnutls gnutls)
+ $(use_with !gnutls openssl)
+ )
+ else
+ myeconfargs+=(
+ --without-gnutls
+ --without-openssl
+ )
+ fi
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=(docs/html/)
+ autotools-utils_src_install
+}