summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-01-31 14:54:21 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-01-31 14:54:21 +0000
commit76c0015b179f7a4c0f1ee828f7e606f212c21ba4 (patch)
treef12fb1e9e7914632296e20d736a7f8879f11857e /net-libs
parentInitial commit. Ebuild based on the one by Wang Jiajun in gentoo-zh overlay. (diff)
downloadgentoo-2-76c0015b179f7a4c0f1ee828f7e606f212c21ba4.tar.gz
gentoo-2-76c0015b179f7a4c0f1ee828f7e606f212c21ba4.tar.bz2
gentoo-2-76c0015b179f7a4c0f1ee828f7e606f212c21ba4.zip
Fix bug #454300
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/cyassl/ChangeLog7
-rw-r--r--net-libs/cyassl/cyassl-2.4.6.ebuild9
-rw-r--r--net-libs/cyassl/files/cyassl-2.4.6-fix-disable-debug.patch12
-rw-r--r--net-libs/cyassl/files/cyassl-2.4.6-respect-CFLAGS.patch12
4 files changed, 37 insertions, 3 deletions
diff --git a/net-libs/cyassl/ChangeLog b/net-libs/cyassl/ChangeLog
index 70aef82c5ec3..a902e45389d0 100644
--- a/net-libs/cyassl/ChangeLog
+++ b/net-libs/cyassl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/cyassl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.20 2013/01/30 14:28:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.21 2013/01/31 14:54:21 blueness Exp $
+
+ 31 Jan 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/cyassl-2.4.6-fix-disable-debug.patch,
+ +files/cyassl-2.4.6-respect-CFLAGS.patch, cyassl-2.4.6.ebuild:
+ Fix bug #454300
30 Jan 2013; Jeroen Roovers <jer@gentoo.org> cyassl-2.4.6.ebuild:
Stable for HPPA (bug #448980).
diff --git a/net-libs/cyassl/cyassl-2.4.6.ebuild b/net-libs/cyassl/cyassl-2.4.6.ebuild
index 667482534699..d3008253dd1d 100644
--- a/net-libs/cyassl/cyassl-2.4.6.ebuild
+++ b/net-libs/cyassl/cyassl-2.4.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-2.4.6.ebuild,v 1.2 2013/01/30 14:28:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-2.4.6.ebuild,v 1.3 2013/01/31 14:54:21 blueness Exp $
EAPI="4"
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Lightweight SSL/TLS library targeted at embedded and RTOS environments"
HOMEPAGE="http://www.yassl.com/yaSSL/Home.html"
@@ -36,6 +36,11 @@ src_prepare() {
#Apply unconditionally, but only triggered if USE="aes-ni"
epatch "${FILESDIR}"/${PN}-2.0.8-fix-gnustack.patch
+
+ #Bug #454300
+ epatch "${FILESDIR}"/${P}-fix-disable-debug.patch
+ epatch "${FILESDIR}"/${P}-respect-CFLAGS.patch
+ eautoreconf
}
src_configure() {
diff --git a/net-libs/cyassl/files/cyassl-2.4.6-fix-disable-debug.patch b/net-libs/cyassl/files/cyassl-2.4.6-fix-disable-debug.patch
new file mode 100644
index 000000000000..b6871da6bf18
--- /dev/null
+++ b/net-libs/cyassl/files/cyassl-2.4.6-fix-disable-debug.patch
@@ -0,0 +1,12 @@
+diff -Naur cyassl-2.4.6.orig/m4/ax_debug.m4 cyassl-2.4.6/m4/ax_debug.m4
+--- cyassl-2.4.6.orig/m4/ax_debug.m4 2012-10-19 16:01:02.000000000 -0400
++++ cyassl-2.4.6/m4/ax_debug.m4 2013-01-28 22:03:46.000000000 -0500
+@@ -49,7 +49,7 @@
+ AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+ [Add debug code/turns off optimizations (yes|no) @<:@default=no@:>@])],[
+- ax_enable_debug=yes
++ ax_enable_debug=$enableval
+ AC_DEFINE(DEBUG, [ 1 ], [Define to 1 to enable debugging code.])
+ ],[
+ ax_enable_debug=no
diff --git a/net-libs/cyassl/files/cyassl-2.4.6-respect-CFLAGS.patch b/net-libs/cyassl/files/cyassl-2.4.6-respect-CFLAGS.patch
new file mode 100644
index 000000000000..89b3764e2a74
--- /dev/null
+++ b/net-libs/cyassl/files/cyassl-2.4.6-respect-CFLAGS.patch
@@ -0,0 +1,12 @@
+diff -Naur cyassl-2.4.6.orig/configure.ac cyassl-2.4.6/configure.ac
+--- cyassl-2.4.6.orig/configure.ac 2012-12-20 16:25:33.000000000 -0500
++++ cyassl-2.4.6/configure.ac 2013-01-31 09:49:36.000000000 -0500
+@@ -42,7 +42,7 @@
+
+ # capture user C_EXTRA_FLAGS from ./configure line, CFLAGS may hold -g -O2 even
+ # if user doesn't override, no way to tell
+-USER_C_EXTRA_FLAGS="$C_EXTRA_FLAGS"
++USER_C_EXTRA_FLAGS="$CFLAGS"
+
+ LT_INIT([win32-dll])
+ LT_LANG([C++])