summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-27 10:36:14 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-27 10:36:14 +0000
commit956055305aca9877c2e6ccdece17896a8b838430 (patch)
tree365696270bc3600b88e31537362fb90d1b22f63a /net-libs
parentstable for x86 wrt #486228 (diff)
downloadgentoo-2-956055305aca9877c2e6ccdece17896a8b838430.tar.gz
gentoo-2-956055305aca9877c2e6ccdece17896a8b838430.tar.bz2
gentoo-2-956055305aca9877c2e6ccdece17896a8b838430.zip
Oops
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/farstream/ChangeLog7
-rw-r--r--net-libs/farstream/farstream-0.1.2-r1.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/net-libs/farstream/ChangeLog b/net-libs/farstream/ChangeLog
index 4d7c80fa9c9a..263222799079 100644
--- a/net-libs/farstream/ChangeLog
+++ b/net-libs/farstream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/farstream
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.26 2013/10/27 09:36:57 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/ChangeLog,v 1.27 2013/10/27 10:36:14 pacho Exp $
+
+*farstream-0.1.2-r1 (27 Oct 2013)
+
+ 27 Oct 2013; Pacho Ramos <pacho@gentoo.org> +farstream-0.1.2-r1.ebuild:
+ Oops
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> -farstream-0.1.2-r1.ebuild,
metadata.xml:
diff --git a/net-libs/farstream/farstream-0.1.2-r1.ebuild b/net-libs/farstream/farstream-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..97a7aaf9ec40
--- /dev/null
+++ b/net-libs/farstream/farstream-0.1.2-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/farstream/farstream-0.1.2-r1.ebuild,v 1.15 2013/10/27 10:36:14 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="http://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection python msn test upnp"
+
+SLOT="0.1"
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+RESTRICT="test"
+
+COMMONDEPEND=">=media-libs/gstreamer-0.10.33:0.10
+ >=media-libs/gst-plugins-base-0.10.33:0.10
+ >=dev-libs/glib-2.30:2
+ >=net-libs/libnice-0.1.0
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11 )
+ python? (
+ >=dev-python/pygobject-2.16:2
+ >=dev-python/gst-python-0.10.10 )
+ upnp? ( net-libs/gupnp-igd )"
+
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-good-0.10.17:0.10
+ >=media-libs/gst-plugins-bad-0.10.17:0.10
+ || (
+ >=media-plugins/gst-plugins-libnice-0.1.0:0.10
+ <=net-libs/libnice-0.1.3[gstreamer] )
+ msn? ( >=media-plugins/gst-plugins-mimic-0.10.17:0.10 )
+ !net-libs/farsight2"
+# This package is just a rename from farsight2
+
+DEPEND="${COMMONDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-vorbis:0.10 )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Fix building with gobject-introspection-1.33.x, bug #425096
+ epatch "${FILESDIR}/${P}-introspection-tag-order.patch"
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ use msn && plugins="${plugins},fsmsnconference"
+ econf --disable-static \
+ $(use_enable introspection) \
+ $(use_enable python) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS README ChangeLog
+
+ # Remove .la files since static libs are no longer being installed
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}
+
+src_test() {
+ # FIXME: do an out-of-tree build for tests if USE=-msn
+ if ! use msn; then
+ elog "Tests disabled without msn use flag"
+ return
+ fi
+
+ emake -j1 check
+}