summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-09-21 23:46:22 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-09-21 23:46:22 +0000
commit97828efc7ce59f17d16c4ff7c2126022a1b02261 (patch)
tree49a99162e0e40130514b1d895e167bc6fa59284f /net-libs
parentVersion bump. Fixes bug #148525. Cleaning old patch (diff)
downloadgentoo-2-97828efc7ce59f17d16c4ff7c2126022a1b02261.tar.gz
gentoo-2-97828efc7ce59f17d16c4ff7c2126022a1b02261.tar.bz2
gentoo-2-97828efc7ce59f17d16c4ff7c2126022a1b02261.zip
Change gnutls vs. ssl USE-flags logic: If gnutls is enabled, always build against gnutls, disabling openssl. Closes bug #142588, reported by Michal Kurgan <moloh@gentoo.org>.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libetpan/ChangeLog9
-rw-r--r--net-libs/libetpan/files/digest-libetpan-0.46-r13
-rw-r--r--net-libs/libetpan/libetpan-0.46-r1.ebuild56
3 files changed, 67 insertions, 1 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index d51ccd871f9d..75df3dfa5001 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.34 2006/08/09 21:43:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.35 2006/09/21 23:46:22 ticho Exp $
+
+*libetpan-0.46-r1 (21 Sep 2006)
+
+ 21 Sep 2006; <ticho@gentoo.org> +libetpan-0.46-r1.ebuild:
+ Change gnutls vs. ssl USE-flags logic: If gnutls is enabled, always build
+ against gnutls, disabling openssl. Closes bug #142588, reported by Michal
+ Kurgan <moloh@gentoo.org>.
09 Aug 2006; Jeroen Roovers <jer@gentoo.org> libetpan-0.45.ebuild:
Stable for HPPA.
diff --git a/net-libs/libetpan/files/digest-libetpan-0.46-r1 b/net-libs/libetpan/files/digest-libetpan-0.46-r1
new file mode 100644
index 000000000000..c99d75082b3d
--- /dev/null
+++ b/net-libs/libetpan/files/digest-libetpan-0.46-r1
@@ -0,0 +1,3 @@
+MD5 afa4abd73665e1a46b0510c4f4efa9a9 libetpan-0.46.tar.gz 1010995
+RMD160 482904916cda8156af171931af96cb68fa0b7391 libetpan-0.46.tar.gz 1010995
+SHA256 74c81e8c29de3fda2e196ce7082a5ec35aad9399a6c7f67bb906b3c9d91dc6f3 libetpan-0.46.tar.gz 1010995
diff --git a/net-libs/libetpan/libetpan-0.46-r1.ebuild b/net-libs/libetpan/libetpan-0.46-r1.ebuild
new file mode 100644
index 000000000000..0b7f26041782
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.46-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.46-r1.ebuild,v 1.1 2006/09/21 23:46:22 ticho Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb debug gnutls sasl ssl"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_compile() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ econf \
+ `use_enable debug` \
+ `use_enable berkdb db` \
+ `use_with sasl` \
+ ${sslconf} \
+ || die "econf failed"
+
+ # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc NEWS TODO ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "The soname for libetpan has changed after libetpan-0.45."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+}