summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-14 12:32:22 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-14 12:32:22 +0000
commitbff5aceeb363aa7c63c97fe3729bd6e35049c237 (patch)
tree0404e48e189be220b370fe39c4e8cf5b2b9c7c4a /net-libs
parentVersion bump, two patches now upstream. With thanks to Jaco Kroon for a new n... (diff)
downloadgentoo-2-bff5aceeb363aa7c63c97fe3729bd6e35049c237.tar.gz
gentoo-2-bff5aceeb363aa7c63c97fe3729bd6e35049c237.tar.bz2
gentoo-2-bff5aceeb363aa7c63c97fe3729bd6e35049c237.zip
Fix static lib handling and block newer nfs-utils due to man page collision #337213 by Robin Johnson.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnfsidmap/ChangeLog9
-rw-r--r--net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch12
-rw-r--r--net-libs/libnfsidmap/libnfsidmap-0.23-r1.ebuild44
3 files changed, 64 insertions, 1 deletions
diff --git a/net-libs/libnfsidmap/ChangeLog b/net-libs/libnfsidmap/ChangeLog
index 9cb3c5b06028..c92b7e0cd374 100644
--- a/net-libs/libnfsidmap/ChangeLog
+++ b/net-libs/libnfsidmap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libnfsidmap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/ChangeLog,v 1.33 2010/07/27 00:18:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/ChangeLog,v 1.34 2010/09/14 12:32:22 vapier Exp $
+
+*libnfsidmap-0.23-r1 (14 Sep 2010)
+
+ 14 Sep 2010; Mike Frysinger <vapier@gentoo.org>
+ files/libnfsidmap-0.21-headers.patch, +libnfsidmap-0.23-r1.ebuild:
+ Fix static lib handling and block newer nfs-utils due to man page collision
+ #337213 by Robin Johnson.
*libnfsidmap-0.23 (27 Jul 2010)
diff --git a/net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch b/net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch
index ee9371ec49e1..6ef12d44e44f 100644
--- a/net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch
+++ b/net-libs/libnfsidmap/files/libnfsidmap-0.21-headers.patch
@@ -1,3 +1,5 @@
+for toupper and such
+
--- a/nss.c
+++ b/nss.c
@@ -34,6 +34,7 @@
@@ -8,3 +10,13 @@
#include <sys/types.h>
#include <errno.h>
#include <unistd.h>
+--- a/libnfsidmap.c
++++ b/libnfsidmap.c
+@@ -37,6 +37,7 @@
+ * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
++#include <ctype.h>
+ #include <sys/types.h>
+ #include <errno.h>
+ #include <unistd.h>
diff --git a/net-libs/libnfsidmap/libnfsidmap-0.23-r1.ebuild b/net-libs/libnfsidmap/libnfsidmap-0.23-r1.ebuild
new file mode 100644
index 000000000000..45ca14483865
--- /dev/null
+++ b/net-libs/libnfsidmap/libnfsidmap-0.23-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/libnfsidmap-0.23-r1.ebuild,v 1.1 2010/09/14 12:32:22 vapier Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="NFSv4 ID <-> name mapping library"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ldap"
+
+DEPEND="ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ !<net-fs/nfs-utils-1.2.2
+ !net-fs/idmapd"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.19-getgrouplist.patch #169909
+ epatch "${FILESDIR}"/${PN}-0.21-headers.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable ldap)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ insinto /etc
+ doins idmapd.conf || die
+
+ # remove useless files
+ rm "${D}"/usr/lib*/libnfsidmap/*.{a,la} || die
+}