summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-07-17 10:24:45 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-07-17 10:24:45 +0000
commitc02dbc31c1c21b59078ede50f8c2b284fbaf8a38 (patch)
tree91a445422f1b3f18cccd73da1bdc12a159bb95b3 /net-libs
parentVersion bump (diff)
downloadgentoo-2-c02dbc31c1c21b59078ede50f8c2b284fbaf8a38.tar.gz
gentoo-2-c02dbc31c1c21b59078ede50f8c2b284fbaf8a38.tar.bz2
gentoo-2-c02dbc31c1c21b59078ede50f8c2b284fbaf8a38.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/xulrunner-bin/ChangeLog8
-rw-r--r--net-libs/xulrunner-bin/xulrunner-bin-1.8.1.16.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/net-libs/xulrunner-bin/ChangeLog b/net-libs/xulrunner-bin/ChangeLog
index 22cab189e077..07c71915108f 100644
--- a/net-libs/xulrunner-bin/ChangeLog
+++ b/net-libs/xulrunner-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/xulrunner-bin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner-bin/ChangeLog,v 1.8 2008/07/04 21:54:26 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner-bin/ChangeLog,v 1.9 2008/07/17 10:24:45 armin76 Exp $
+
+*xulrunner-bin-1.8.1.16 (17 Jul 2008)
+
+ 17 Jul 2008; Raúl Porcel <armin76@gentoo.org>
+ +xulrunner-bin-1.8.1.16.ebuild:
+ Version bump
04 Jul 2008; Thomas Anderson <gentoofan23@gentoo.org>
xulrunner-bin-1.8.1.15.ebuild:
diff --git a/net-libs/xulrunner-bin/xulrunner-bin-1.8.1.16.ebuild b/net-libs/xulrunner-bin/xulrunner-bin-1.8.1.16.ebuild
new file mode 100644
index 000000000000..02ea58c0222b
--- /dev/null
+++ b/net-libs/xulrunner-bin/xulrunner-bin-1.8.1.16.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner-bin/xulrunner-bin-1.8.1.16.ebuild,v 1.1 2008/07/17 10:24:45 armin76 Exp $
+
+inherit eutils multilib mozilla-launcher
+
+DESCRIPTION="Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications"
+HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
+SRC_URI="mirror://gentoo/${P}.tbz2
+ http://dev.gentoo.org/~armin76/dist/${P}.tbz2"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+DEPEND=""
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-compat
+ )"
+
+S="${WORKDIR}/usr/lib/xulrunner/"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/opt/xulrunner"
+
+ # Install firefox in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME}
+
+ # Create /usr/bin/xulrunner-bin
+ install_mozilla_launcher_stub xulrunner-bin ${MOZILLA_FIVE_HOME}
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10xulrunner-bin
+
+ # install ldpath env.d
+ doenvd "${FILESDIR}"/71xulrunner-bin
+
+ insinto /etc/gre.d
+ newins "${FILESDIR}"/${PN}.conf ${PV}-bin.conf
+ sed -i -e \
+ "s|version|${PV}|
+ s|instpath|${MOZILLA_FIVE_HOME}|" \
+ "${D}"/etc/gre.d/${PV}-bin.conf
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME="/opt/xulrunner"
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}"${MOZILLA_FIVE_HOME}
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit xulrunner"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}