summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-09 09:48:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-09 09:48:23 +0000
commitc1e2f38148ff91575116ef9629ef5c3b947474aa (patch)
tree161b1ee651c197dc79a2205b4d72cf29df4a214c /net-libs
parentx86 stable wrt bug #400251 (diff)
downloadgentoo-2-c1e2f38148ff91575116ef9629ef5c3b947474aa.tar.gz
gentoo-2-c1e2f38148ff91575116ef9629ef5c3b947474aa.tar.bz2
gentoo-2-c1e2f38148ff91575116ef9629ef5c3b947474aa.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/vanessa-socket/ChangeLog9
-rw-r--r--net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/net-libs/vanessa-socket/ChangeLog b/net-libs/vanessa-socket/ChangeLog
index d62718dfbd6f..c46f2eec3578 100644
--- a/net-libs/vanessa-socket/ChangeLog
+++ b/net-libs/vanessa-socket/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/vanessa-socket
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/vanessa-socket/ChangeLog,v 1.18 2010/06/02 11:56:30 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/vanessa-socket/ChangeLog,v 1.19 2012/03/09 09:48:23 patrick Exp $
+
+*vanessa-socket-0.0.12 (09 Mar 2012)
+
+ 09 Mar 2012; Patrick Lauer <patrick@gentoo.org> +vanessa-socket-0.0.12.ebuild:
+ Bump
02 Jun 2010; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Assimilating package
diff --git a/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild b/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild
new file mode 100644
index 000000000000..0152d25f32c6
--- /dev/null
+++ b/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/vanessa-socket/vanessa-socket-0.0.12.ebuild,v 1.1 2012/03/09 09:48:23 patrick Exp $
+
+inherit eutils
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Simplifies TCP/IP socket operations."
+HOMEPAGE="http://www.vergenet.net/linux/vanessa/"
+SRC_URI="http://www.vergenet.net/linux/vanessa/download/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/vanessa-logger-0.0.6"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf || die "error configure"
+ emake || die "error compiling"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "error installing"
+ dodoc README NEWS AUTHORS TODO
+}