summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-02 14:31:14 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-02 14:31:14 +0000
commitddc56569cfc756510d63f704b33691903123d48b (patch)
tree7af021dab335f84ef7d5becc6a0bbc512f5cc10e /net-libs
parentVersion bump. (diff)
downloadgentoo-2-ddc56569cfc756510d63f704b33691903123d48b.tar.gz
gentoo-2-ddc56569cfc756510d63f704b33691903123d48b.tar.bz2
gentoo-2-ddc56569cfc756510d63f704b33691903123d48b.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libkolabxml/ChangeLog9
-rw-r--r--net-libs/libkolabxml/libkolabxml-1.1.0.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-libs/libkolabxml/ChangeLog b/net-libs/libkolabxml/ChangeLog
index 340e9f2ad6b5..1a1e8bfb4b0e 100644
--- a/net-libs/libkolabxml/ChangeLog
+++ b/net-libs/libkolabxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libkolabxml
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/ChangeLog,v 1.34 2014/11/28 15:57:18 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/ChangeLog,v 1.35 2015/01/02 14:31:14 mrueg Exp $
+
+*libkolabxml-1.1.0 (02 Jan 2015)
+
+ 02 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +libkolabxml-1.1.0.ebuild:
+ Version bump.
28 Nov 2014; Manuel Rüger <mrueg@gentoo.org> -libkolabxml-0.8.4.ebuild:
Cleanup old.
diff --git a/net-libs/libkolabxml/libkolabxml-1.1.0.ebuild b/net-libs/libkolabxml/libkolabxml-1.1.0.ebuild
new file mode 100644
index 000000000000..f3da30cb65c4
--- /dev/null
+++ b/net-libs/libkolabxml/libkolabxml-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkolabxml/libkolabxml-1.1.0.ebuild,v 1.1 2015/01/02 14:31:14 mrueg Exp $
+
+EAPI=5
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Kolab XML format schema definitions library"
+HOMEPAGE="http://www.kolab.org"
+SRC_URI="http://mirror.kolabsys.com/pub/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0 ZLIB LGPL-3+ public-domain"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="csharp java python php test"
+
+RDEPEND="
+ >=dev-libs/boost-1.42.0:=
+ dev-libs/xerces-c
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ dev-cpp/xsd
+ csharp? ( >=dev-lang/swig-2.0.7 dev-lang/mono )
+ java? ( >=dev-lang/swig-2.0.7 virtual/jre )
+ php? ( >=dev-lang/swig-2.0.7 dev-lang/php )
+ python? ( >=dev-lang/swig-2.0.7 dev-lang/python )
+ test? ( dev-qt/qttest:4 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ $(cmake-utils_use csharp CSHARP_BINDINGS)
+ $(cmake-utils_use java JAVA_BINDINGS)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ $(cmake-utils_use php PHP_BINDINGS)
+ $(cmake-utils_use_build test TESTS)
+ )
+ cmake-utils_src_configure
+}