summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-03-28 21:38:10 +0000
committerJeroen Roovers <jer@gentoo.org>2012-03-28 21:38:10 +0000
commite366fc98f448ac868fdc77c1c23762073f01fda0 (patch)
treec1a00eb52c4fd71c0b7c07a33ad171a15dd46ab1 /net-libs
parentamd64 stable - 410045 (diff)
downloadgentoo-2-e366fc98f448ac868fdc77c1c23762073f01fda0.tar.gz
gentoo-2-e366fc98f448ac868fdc77c1c23762073f01fda0.tar.bz2
gentoo-2-e366fc98f448ac868fdc77c1c23762073f01fda0.zip
Version bump.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnet/ChangeLog9
-rw-r--r--net-libs/libnet/libnet-1.1.6_rc3.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index a943afd31fa9..84991028fa12 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnet
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.75 2011/09/19 04:50:45 naota Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.76 2012/03/28 21:38:09 jer Exp $
+
+*libnet-1.1.6_rc3 (28 Mar 2012)
+
+ 28 Mar 2012; Jeroen Roovers <jer@gentoo.org> +libnet-1.1.6_rc3.ebuild:
+ Version bump.
19 Sep 2011; Naohiro Aota <naota@gentoo.org> libnet-1.0.2a-r3.ebuild:
Add ~x86-fbsd for 1.0.2a-r3
diff --git a/net-libs/libnet/libnet-1.1.6_rc3.ebuild b/net-libs/libnet/libnet-1.1.6_rc3.ebuild
new file mode 100644
index 000000000000..a0108026ec0d
--- /dev/null
+++ b/net-libs/libnet/libnet-1.1.6_rc3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.1.6_rc3.ebuild,v 1.1 2012/03/28 21:38:10 jer Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
+HOMEPAGE="http://libnet-dev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}-dev/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+DEPEND="sys-devel/autoconf"
+RDEPEND=""
+
+DOCS=(
+ README doc/{CHANGELOG,CONTRIB,DESIGN_NOTES,MIGRATION}
+ doc/{PACKET_BUILDING,PORTED,RAWSOCKET_NON_SEQUITUR,TODO}
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ docinto sample
+ dodoc sample/*.[ch]
+ fi
+
+ if ! use static-libs; then
+ rm "${D}"/usr/lib*/libnet.la || die
+ fi
+}