summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-10-27 09:54:18 +0000
committerPacho Ramos <pacho@gentoo.org>2013-10-27 09:54:18 +0000
commitec0c426608ef051b8ecffcc24c1136ff11d9cccf (patch)
tree56c2bff505f0e57aeaf978b0f79c95c976e5963d /net-libs
parentVoip herd is removed: http://article.gmane.org/gmane.linux.gentoo.devel/88434 (diff)
downloadgentoo-2-ec0c426608ef051b8ecffcc24c1136ff11d9cccf.tar.gz
gentoo-2-ec0c426608ef051b8ecffcc24c1136ff11d9cccf.tar.bz2
gentoo-2-ec0c426608ef051b8ecffcc24c1136ff11d9cccf.zip
Needed by net-misc/siproxd
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libosip/ChangeLog7
-rw-r--r--net-libs/libosip/libosip-3.6.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/net-libs/libosip/ChangeLog b/net-libs/libosip/ChangeLog
index 11f954b7feb6..04860a052e25 100644
--- a/net-libs/libosip/ChangeLog
+++ b/net-libs/libosip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libosip
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/ChangeLog,v 1.57 2013/10/27 09:41:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/ChangeLog,v 1.58 2013/10/27 09:54:18 pacho Exp $
+
+*libosip-3.6.0 (27 Oct 2013)
+
+ 27 Oct 2013; Pacho Ramos <pacho@gentoo.org> +libosip-3.6.0.ebuild:
+ Needed by net-misc/siproxd
27 Oct 2013; Pacho Ramos <pacho@gentoo.org> -libosip-3.5.0.ebuild,
-libosip-3.6.0.ebuild, metadata.xml:
diff --git a/net-libs/libosip/libosip-3.6.0.ebuild b/net-libs/libosip/libosip-3.6.0.ebuild
new file mode 100644
index 000000000000..9ebb8cc8add6
--- /dev/null
+++ b/net-libs/libosip/libosip-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libosip/libosip-3.6.0.ebuild,v 1.6 2013/10/27 09:54:18 pacho Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="a simple way to support the Session Initiation Protocol"
+HOMEPAGE="http://www.gnu.org/software/osip/"
+SRC_URI="mirror://gnu/osip/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="amd64 ppc ~sparc x86 ~ppc-macos ~x86-macos"
+IUSE="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.3.0-out-source-build.patch"
+ AT_M4DIR="scripts" eautoreconf
+}
+
+src_configure() {
+ econf --enable-mt \
+ $(use_enable test)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dodoc AUTHORS ChangeLog FEATURES HISTORY README NEWS TODO || die
+}