summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-11 04:19:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-11 04:19:30 +0000
commitf8b22aee64a1b78007e664ab9e293fe9b528303a (patch)
tree78297a2871ea4624c02b78d8fc8552782dd2669b /net-libs
parentAdd support for ruby 1.9 (works fine). (diff)
downloadgentoo-2-f8b22aee64a1b78007e664ab9e293fe9b528303a.tar.gz
gentoo-2-f8b22aee64a1b78007e664ab9e293fe9b528303a.tar.bz2
gentoo-2-f8b22aee64a1b78007e664ab9e293fe9b528303a.zip
Update to use the new curl USE flags.
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/liboauth/ChangeLog6
-rw-r--r--net-libs/liboauth/liboauth-0.9.5.ebuild82
-rw-r--r--net-libs/liboauth/liboauth-0.9.6.ebuild6
3 files changed, 8 insertions, 86 deletions
diff --git a/net-libs/liboauth/ChangeLog b/net-libs/liboauth/ChangeLog
index 294320212e27..1cb63eda95ce 100644
--- a/net-libs/liboauth/ChangeLog
+++ b/net-libs/liboauth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/liboauth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.12 2012/05/05 02:54:24 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/ChangeLog,v 1.13 2012/05/11 04:19:30 flameeyes Exp $
+
+ 11 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> -liboauth-0.9.5.ebuild,
+ liboauth-0.9.6.ebuild:
+ Update to use the new curl USE flags.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> liboauth-0.9.5.ebuild,
liboauth-0.9.6.ebuild:
diff --git a/net-libs/liboauth/liboauth-0.9.5.ebuild b/net-libs/liboauth/liboauth-0.9.5.ebuild
deleted file mode 100644
index 8a1b7818b9eb..000000000000
--- a/net-libs/liboauth/liboauth-0.9.5.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/liboauth-0.9.5.ebuild,v 1.2 2012/05/05 02:54:24 jdhore Exp $
-
-EAPI=4
-
-DESCRIPTION="C library implementing the OAuth secure authentication protocol"
-HOMEPAGE="http://liboauth.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- http://liboauth.sourceforge.net/pool/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 MIT )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="curl doc bindist +nss"
-
-REQUIRED_USE="bindist? ( nss )"
-
-CDEPEND="
- nss? ( dev-libs/nss
- curl? ( || ( net-misc/curl[ssl,nss,-gnutls] net-misc/curl[-ssl] ) )
- )
-
- !nss? ( dev-libs/openssl
- curl? ( || ( net-misc/curl[ssl,-nss,-gnutls] net-misc/curl[-ssl] ) )
- )
-
- net-misc/curl
-"
-
-RDEPEND="${CDEPEND}"
-
-DEPEND="${CDEPEND}
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- media-fonts/freefont-ttf
- )
- virtual/pkgconfig"
-
-src_configure() {
- local myconf=
-
- if use nss || use bindist; then
- myconf="${myconf} --enable-nss"
- else
- myconf="${myconf} --disable-nss"
- fi
-
- econf \
- --disable-dependency-tracking \
- --enable-fast-install \
- --disable-static \
- $(use_enable !curl curl) \
- $(use_enable curl libcurl) \
- ${myconf}
-}
-
-src_compile() {
- emake
-
- if use doc ; then
- # make sure fonts are found
- export DOTFONTPATH="${EPREFIX}"/usr/share/fonts/freefont-ttf
- emake dox
- fi
-}
-
-src_test() {
- # explicitly allow parallel test build
- emake check
-}
-
-DOCS=( AUTHORS ChangeLog LICENSE.OpenSSL NEWS README )
-
-src_install() {
- default
-
- if use doc; then
- dohtml -r doc/html/*
- fi
-}
diff --git a/net-libs/liboauth/liboauth-0.9.6.ebuild b/net-libs/liboauth/liboauth-0.9.6.ebuild
index 90fa74a4ad4c..2bd3a0d49239 100644
--- a/net-libs/liboauth/liboauth-0.9.6.ebuild
+++ b/net-libs/liboauth/liboauth-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/liboauth-0.9.6.ebuild,v 1.2 2012/05/05 02:54:24 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboauth/liboauth-0.9.6.ebuild,v 1.3 2012/05/11 04:19:30 flameeyes Exp $
EAPI=4
@@ -18,11 +18,11 @@ REQUIRED_USE="bindist? ( nss )"
CDEPEND="
nss? ( dev-libs/nss
- curl? ( || ( net-misc/curl[ssl,nss,-gnutls] net-misc/curl[-ssl] ) )
+ curl? ( || ( net-misc/curl[ssl,curl_ssl_nss] net-misc/curl[-ssl] ) )
)
!nss? ( dev-libs/openssl
- curl? ( || ( net-misc/curl[ssl,-nss,-gnutls] net-misc/curl[-ssl] ) )
+ curl? ( || ( net-misc/curl[ssl,curl_ssl_openssl] net-misc/curl[-ssl] ) )
)
net-misc/curl