summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-25 03:53:44 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-25 03:53:44 +0000
commitf9513f01c6c99c4d7eb1c7ae0458a3dd585f6308 (patch)
tree8d4bb5f7dbc243ad2cad221319208ed0f3a6d268 /net-mail/autorespond
parentBug #225879, fix infinite looping during usb_bulk operations. (diff)
downloadgentoo-2-f9513f01c6c99c4d7eb1c7ae0458a3dd585f6308.tar.gz
gentoo-2-f9513f01c6c99c4d7eb1c7ae0458a3dd585f6308.tar.bz2
gentoo-2-f9513f01c6c99c4d7eb1c7ae0458a3dd585f6308.zip
Version bump per bug #173333.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'net-mail/autorespond')
-rw-r--r--net-mail/autorespond/ChangeLog11
-rw-r--r--net-mail/autorespond/autorespond-2.0.5.ebuild38
-rw-r--r--net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch23
3 files changed, 70 insertions, 2 deletions
diff --git a/net-mail/autorespond/ChangeLog b/net-mail/autorespond/ChangeLog
index 1c231a71c6f9..67bc8c2e53e2 100644
--- a/net-mail/autorespond/ChangeLog
+++ b/net-mail/autorespond/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/autorespond
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/autorespond/ChangeLog,v 1.12 2006/02/20 00:11:02 hansmi Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/autorespond/ChangeLog,v 1.13 2008/06/25 03:53:43 robbat2 Exp $
+
+*autorespond-2.0.5 (25 Jun 2008)
+
+ 25 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/autorespond-2.0.5-no-include-bounce.patch,
+ +autorespond-2.0.5.ebuild:
+ Version bump per bug #173333.
20 Feb 2006; Michael Hanselmann <hansmi@gentoo.org>
autorespond-2.0.4.ebuild:
diff --git a/net-mail/autorespond/autorespond-2.0.5.ebuild b/net-mail/autorespond/autorespond-2.0.5.ebuild
new file mode 100644
index 000000000000..0dbba59fb5fb
--- /dev/null
+++ b/net-mail/autorespond/autorespond-2.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Autoresponder add on package for qmailadmin"
+HOMEPAGE="http://inter7.com/devel/"
+SRC_URI="http://inter7.com/devel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/qmail"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-no-include-bounce.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ into /var/qmail
+ dobin autorespond || die "dobin failed"
+ into /usr
+ dodoc README help_message qmail-auto #ChangeLog
+ doman *.1
+}
+
+pkg_postinst() {
+ ewarn "Please note that original messages are now NOT included with bounces"
+ ewarn "by default. Use the flag per the help output if you want them."
+}
diff --git a/net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch b/net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch
new file mode 100644
index 000000000000..5131ad16bcfa
--- /dev/null
+++ b/net-mail/autorespond/files/autorespond-2.0.5-no-include-bounce.patch
@@ -0,0 +1,23 @@
+diff -Nuar autorespond-2.0.5.orig/autorespond.c autorespond-2.0.5/autorespond.c
+--- autorespond-2.0.5.orig/autorespond.c 2003-09-18 13:17:57.000000000 -0700
++++ autorespond-2.0.5/autorespond.c 2008-06-24 20:46:15.615642827 -0700
+@@ -80,7 +80,7 @@
+ #include <sys/wait.h>
+ #include <ctype.h>
+
+-#define DEFAULT_MH 1 /* default value for message_handling flag */
++#define DEFAULT_MH 0 /* default value for message_handling flag */
+ #define DEFAULT_FROM "$" /* default "from" for the autorespond */
+
+ #define WITH_OMESSAGE 1
+@@ -562,8 +562,8 @@
+ fprintf(stderr, "dir - the directory to hold the log of messages\n\n");
+ fprintf(stderr, "optional parameters:\n\n");
+ fprintf(stderr, "flag - handling of original message:\n\n");
+- fprintf(stderr, "0 - append nothing\n");
+- fprintf(stderr, "1 - append quoted original message without attachments <default>\n\n");
++ fprintf(stderr, "0 - append nothing <default>\n");
++ fprintf(stderr, "1 - append quoted original message without attachments\n\n");
+ fprintf(stderr, "arsender - from address in generated message, or:\n\n");
+ fprintf(stderr, "+ = blank from envelope !\n");
+ fprintf(stderr, "$ = To: address will be used\n\n");