summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-12-13 04:05:11 +0000
committerNick Hadaway <raker@gentoo.org>2002-12-13 04:05:11 +0000
commitf596968b439e90f80e9e7c71f3ad876ff86c1b7c (patch)
tree8191d05e501ee5b368517bd068ea1d711cdc2575 /net-mail/courier-imap
parenttweak fix (diff)
downloadgentoo-2-f596968b439e90f80e9e7c71f3ad876ff86c1b7c.tar.gz
gentoo-2-f596968b439e90f80e9e7c71f3ad876ff86c1b7c.tar.bz2
gentoo-2-f596968b439e90f80e9e7c71f3ad876ff86c1b7c.zip
Version bump. Currently marked unstable.
Diffstat (limited to 'net-mail/courier-imap')
-rw-r--r--net-mail/courier-imap/ChangeLog8
-rw-r--r--net-mail/courier-imap/courier-imap-1.5.3.ebuild4
-rw-r--r--net-mail/courier-imap/courier-imap-1.6.1.ebuild165
-rw-r--r--net-mail/courier-imap/files/digest-courier-imap-1.6.11
4 files changed, 175 insertions, 3 deletions
diff --git a/net-mail/courier-imap/ChangeLog b/net-mail/courier-imap/ChangeLog
index 05f41e096d3b..0a66e57b91c9 100644
--- a/net-mail/courier-imap/ChangeLog
+++ b/net-mail/courier-imap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/courier-imap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/ChangeLog,v 1.16 2002/12/09 04:33:13 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/ChangeLog,v 1.17 2002/12/13 04:05:11 raker Exp $
+
+courier-imap-1.6.1 (12 Dec 2002)
+
+ 12 Dec 2002; Nick Hadaway <raker@gentoo.org>
+ courier-imap-1.6.1.ebuild, files/digest-courier-imap-1.6.1 :
+ Version bump.
\* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
diff --git a/net-mail/courier-imap/courier-imap-1.5.3.ebuild b/net-mail/courier-imap/courier-imap-1.5.3.ebuild
index e78e442629d6..4304ff1123cf 100644
--- a/net-mail/courier-imap/courier-imap-1.5.3.ebuild
+++ b/net-mail/courier-imap/courier-imap-1.5.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-1.5.3.ebuild,v 1.5 2002/12/09 04:33:13 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-1.5.3.ebuild,v 1.6 2002/12/13 04:05:11 raker Exp $
DESCRIPTION="An IMAP daemon designed specifically for maildirs"
SRC_URI="http://ftp1.sourceforge.net/courier/${P}.tar.gz"
HOMEPAGE="http://www.courier-mta.org/"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc"
LICENSE="GPL-2"
SLOT="0"
IUSE="ipv6 gdbm tcltk ldap berkdb mysql pam"
diff --git a/net-mail/courier-imap/courier-imap-1.6.1.ebuild b/net-mail/courier-imap/courier-imap-1.6.1.ebuild
new file mode 100644
index 000000000000..8bf33413c0f3
--- /dev/null
+++ b/net-mail/courier-imap/courier-imap-1.6.1.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier-imap/courier-imap-1.6.1.ebuild,v 1.1 2002/12/13 04:05:11 raker Exp $
+
+DESCRIPTION="An IMAP daemon designed specifically for maildirs"
+SRC_URI="http://twtelecom.dl.sourceforge.net/sourceforge/courier/${P}.tar.bz2"
+HOMEPAGE="http://www.courier-mta.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc "
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ipv6 gdbm tcltk ldap berkdb mysql pam"
+
+PROVIDE="virtual/imapd"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/openssl-0.9.6
+ pam? ( >=sys-libs/pam-0.75 )
+ berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ mysql? ( >=dev-db/mysql-3.23.36 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ tcltk? ( >=dev-tcltk/expect-5.33.0 )"
+DEPEND="${RDEPEND} sys-devel/perl sys-apps/procps"
+
+# This package is complete if you just need basic IMAP functionality.
+# Here are some things that still need fixing:
+# o supervise support (of course)
+# o tweaking of config files
+# o We need to add an /etc/mail.conf.
+
+src_compile() {
+ local myconf
+ use pam || myconf="${myconf} --without-authpam"
+ use ldap || myconf="${myconf} --without-authldap"
+ use mysql || myconf="${myconf} --without-authmysql"
+ use berkdb \
+ && myconf="${myconf} --with-db=db" \
+ || myconf="${myconf} --with-db=gdbm"
+ use ipv6 || myconf="${myconf} --without-ipv6"
+
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/sbin \
+ --disable-root-check \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/courier-imap \
+ --libexecdir=/usr/lib/courier-imap \
+ --localstatedir=/var/lib/courier-imap \
+ --enable-workarounds-for-imap-client-bugs \
+ --with-authdaemonvar=/var/lib/courier-imap/authdaemon \
+ --enable-unicode \
+ --without-authvchkpw \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ # change the pem file location..
+ cp imap/imapd-ssl.dist imap/imapd-ssl.dist.old
+ sed -e "s:^\(TLS_CERTFILE=\).*:\1/etc/courier-imap/imapd.pem:" \
+ imap/imapd-ssl.dist.old > imap/imapd-ssl.dist
+
+ cp imap/pop3d-ssl.dist imap/pop3d-ssl.dist.old
+ sed -e "s:^\(TLS_CERTFILE=\).*:\1/etc/courier-imap/pop3d.pem:" \
+ imap/pop3d-ssl.dist.old > imap/pop3d-ssl.dist
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ dodir /var/lib/courier-imap /etc/pam.d
+ make install DESTDIR=${D} || die
+
+ # avoid name collisions in /usr/sbin wrt imapd and pop3d
+ cd ${D}/usr/sbin
+ for name in imapd pop3d
+ do
+ mv ${name} "courier-${name}"
+ done
+
+ # hack /usr/lib/courier-imap/foo.rc to use ${MAILDIR} instead of
+ # 'Maildir', and to use /usr/sbin/courier-foo names.
+ cd ${D}/usr/lib/courier-imap
+ local service
+ for service in imapd pop3d
+ do
+ local type
+ for type in "" "-ssl"
+ do
+ local file
+ file="${service}${type}.rc"
+ cp ${file} ${file}.orig
+ sed -e 's/Maildir/${MAILDIR}/' \
+ -e "s/\/usr\/sbin\/${service}/\/usr\/sbin\/courier-${service}/" \
+ ${file}.orig > ${file}
+ done
+ done
+
+ cd ${D}/etc/courier-imap
+ local x
+ for x in pop3d pop3d-ssl imapd imapd-ssl authdaemonrc
+ do
+ mv ${x}.dist ${x}
+ done
+
+ insinto /etc/courier-imap
+ doins ${FILESDIR}/authdaemond.conf
+
+ # add a value for ${MAILDIR} to /etc/courier-imap/imapd
+ for service in imapd pop3d
+ do
+ echo -e '\n#Hardwire a value for ${MAILDIR}' >> ${service}
+ echo 'MAILDIR=.maildir' >> ${service}
+ done
+
+ cd ${D}/usr/sbin
+ for x in *
+ do
+ if [ -L ${x} ]
+ then
+ rm ${x}
+ fi
+ done
+
+ cd ../share
+ mv * ../sbin
+ mv ../sbin/man .
+ cd ..
+
+ rm -f ${D}/usr/sbin/mkimapdcert ${D}/usr/sbin/mkpop3dcert
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/mkimapdcert ${FILESDIR}/mkpop3dcert
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/authdaemond.rc6 authdaemond
+ newexe ${FILESDIR}/courier-imapd.rc6 courier-imapd
+ newexe ${FILESDIR}/courier-imapd-ssl.rc6 courier-imapd-ssl
+ newexe ${FILESDIR}/courier-pop3d.rc6 courier-pop3d
+ newexe ${FILESDIR}/courier-pop3d-ssl.rc6 courier-pop3d-ssl
+
+ exeinto /usr/lib/courier-imap
+ doexe ${FILESDIR}/gentoo-imapd.rc ${FILESDIR}/gentoo-imapd-ssl.rc \
+ ${FILESDIR}/gentoo-pop3d.rc ${FILESDIR}/gentoo-pop3d-ssl.rc
+
+ dodir /usr/bin
+ mv ${D}/usr/sbin/maildirmake ${D}/usr/bin/maildirmake
+
+ dodoc ${S}/imap/ChangeLog
+
+}
+
+pkg_postinst() {
+ # rebuild init deps to include deps on authdaemond
+ /etc/init.d/depscan.sh
+ echo
+ einfo "Courier-IMAP version 1.4.5-r1 and higher have new init scripts."
+ einfo "Please use courier-imapd instead of courier-imap."
+ einfo "This release also includes support for the included pop3 server."
+ einfo "If you choose not to switch your init files, you server will "
+ einfo "continue to function as it currently does."
+ echo
+ einfo "Make sure to change /etc/courier-imap/authdaemond.conf if"
+ einfo "you would like to use something other than the"
+ einfo "authdaemond.plain authenticator"
+ echo
+
+}
diff --git a/net-mail/courier-imap/files/digest-courier-imap-1.6.1 b/net-mail/courier-imap/files/digest-courier-imap-1.6.1
new file mode 100644
index 000000000000..64aa62f003a5
--- /dev/null
+++ b/net-mail/courier-imap/files/digest-courier-imap-1.6.1
@@ -0,0 +1 @@
+MD5 313a1b1c7a6813c81f543b524f4f2a3d courier-imap-1.6.1.tar.bz2 1200262