summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2007-10-31 11:05:19 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2007-10-31 11:05:19 +0000
commitd93b30c45df1195a1a22fb9a2999fc2f4a80dc45 (patch)
tree513ba2b32328c2b09af9f315d710fe57d4e5ec56 /net-mail/dbmail
parentLinux 2.6.22.10. (diff)
downloadgentoo-2-d93b30c45df1195a1a22fb9a2999fc2f4a80dc45.tar.gz
gentoo-2-d93b30c45df1195a1a22fb9a2999fc2f4a80dc45.tar.bz2
gentoo-2-d93b30c45df1195a1a22fb9a2999fc2f4a80dc45.zip
added 2.2.7 release
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-mail/dbmail')
-rw-r--r--net-mail/dbmail/ChangeLog14
-rw-r--r--net-mail/dbmail/dbmail-2.2.7.ebuild102
-rw-r--r--net-mail/dbmail/dbmail-2.2.7_rc4.ebuild102
-rw-r--r--net-mail/dbmail/files/digest-dbmail-2.2.73
-rw-r--r--net-mail/dbmail/files/digest-dbmail-2.2.7_rc43
5 files changed, 223 insertions, 1 deletions
diff --git a/net-mail/dbmail/ChangeLog b/net-mail/dbmail/ChangeLog
index 18411166d579..2419d00a4c57 100644
--- a/net-mail/dbmail/ChangeLog
+++ b/net-mail/dbmail/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-mail/dbmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.12 2007/10/12 13:32:55 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.13 2007/10/31 11:05:18 lordvan Exp $
+
+*dbmail-2.2.7 (31 Oct 2007)
+
+ 31 Oct 2007; Thomas Raschbacher <lordvan@gentoo.org>
+ +dbmail-2.2.7_rc4.ebuild, +dbmail-2.2.7.ebuild:
+ added 2.2.7 release
+
+*dbmail-2.2.7_rc4 (25 Oct 2007)
+
+ 25 Oct 2007; Thomas Raschbacher <lordvan@gentoo.org>
+ +dbmail-2.2.7_rc4.ebuild:
+ added 2.2.7 rc4
12 Oct 2007; Thomas Raschbacher <lordvan@gentoo.org>
dbmail-2.2.7_rc2.ebuild:
diff --git a/net-mail/dbmail/dbmail-2.2.7.ebuild b/net-mail/dbmail/dbmail-2.2.7.ebuild
new file mode 100644
index 000000000000..5bf297f8496b
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.7.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.7.ebuild,v 1.1 2007/10/31 11:05:18 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/dbmail-2.2.7_rc4.ebuild b/net-mail/dbmail/dbmail-2.2.7_rc4.ebuild
new file mode 100644
index 000000000000..f46f17376899
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.7_rc4.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.7_rc4.ebuild,v 1.1 2007/10/31 11:05:18 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/files/digest-dbmail-2.2.7 b/net-mail/dbmail/files/digest-dbmail-2.2.7
new file mode 100644
index 000000000000..fdb16831f50b
--- /dev/null
+++ b/net-mail/dbmail/files/digest-dbmail-2.2.7
@@ -0,0 +1,3 @@
+MD5 2d50867e5833de28a3ec19a968ecfd86 dbmail-2.2.7.tar.gz 895586
+RMD160 aac1d5a7d049b7384455b37e8380d4e57eae5164 dbmail-2.2.7.tar.gz 895586
+SHA256 9e2ab6d45eb841fc08b8d38a1a08fb95b3fdeae3fbc00c50b8acba624ff565e6 dbmail-2.2.7.tar.gz 895586
diff --git a/net-mail/dbmail/files/digest-dbmail-2.2.7_rc4 b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc4
new file mode 100644
index 000000000000..33d2ed2672f9
--- /dev/null
+++ b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc4
@@ -0,0 +1,3 @@
+MD5 e24cf7baa398dd38974cfe1ab180316a dbmail-2.2.7-rc4.tar.gz 896482
+RMD160 c6ad3ffd13482159321f943403c7009a73d32cdd dbmail-2.2.7-rc4.tar.gz 896482
+SHA256 1302dc5ac6e28035e41f38a20e914b2f77e25232d7b6e4a8e8ed9cb76b48e654 dbmail-2.2.7-rc4.tar.gz 896482