summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-05 09:02:36 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-05 09:02:36 +0000
commitdf8ac25adb3aa4123cd3fe462d3387df27673935 (patch)
tree5cb258bcc08c225fc1d150aa48acd1725ad18990 /net-mail/disspam/disspam-0.12.ebuild
parentwhitespace cleanup (diff)
downloadgentoo-2-df8ac25adb3aa4123cd3fe462d3387df27673935.tar.gz
gentoo-2-df8ac25adb3aa4123cd3fe462d3387df27673935.tar.bz2
gentoo-2-df8ac25adb3aa4123cd3fe462d3387df27673935.zip
use sed -i
Diffstat (limited to 'net-mail/disspam/disspam-0.12.ebuild')
-rw-r--r--net-mail/disspam/disspam-0.12.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-mail/disspam/disspam-0.12.ebuild b/net-mail/disspam/disspam-0.12.ebuild
index 4654820ccbcb..dcdd09430f4b 100644
--- a/net-mail/disspam/disspam-0.12.ebuild
+++ b/net-mail/disspam/disspam-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/disspam/disspam-0.12.ebuild,v 1.4 2003/09/05 09:00:24 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/disspam/disspam-0.12.ebuild,v 1.5 2003/09/05 09:02:34 msterret Exp $
S=${WORKDIR}/disspam
DESCRIPTION="A Perl script that removes spam from POP3 mailboxes based on RBLs."
@@ -13,12 +13,14 @@ KEYWORDS="x86 ~ppc ~sparc ~hppa ~alpha ~mips"
DEPEND=">=dev-lang/perl-5.6.1
>=dev-perl/libnet-1.11
+ >=sys-apps/sed-4
>=dev-perl/Net-DNS-0.12"
src_install() {
#This doesnt look neat but makes it work
- sed -e 's/\/usr\/local\/bin\/perl/\/usr\/bin\/perl/' disspam.pl > disspam-fixed.pl
- mv disspam-fixed.pl disspam.pl
+ sed -i \
+ -e 's/\/usr\/local\/bin\/perl/\/usr\/bin\/perl/' disspam.pl || \
+ die "sed disspam.pl failed"
dobin disspam.pl
dodoc changes.txt configuration.txt readme.txt sample.conf
}