summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-06-16 08:42:06 +0000
committerRoy Marples <uberlord@gentoo.org>2006-06-16 08:42:06 +0000
commit30211f65fa8c940554983ca69d5f57f327defb81 (patch)
tree304b4ba67f08859387ba50646662f24495e7d7f4 /net-mail/dovecot/files
parentBump. Fixes PCIE suspend/resume, lots of EXA fixes, interrupt handling, and m... (diff)
downloadgentoo-2-30211f65fa8c940554983ca69d5f57f327defb81.tar.gz
gentoo-2-30211f65fa8c940554983ca69d5f57f327defb81.tar.bz2
gentoo-2-30211f65fa8c940554983ca69d5f57f327defb81.zip
New version that works for glibc-2.4 users who haven't emerged glibc against linux-headers-2.6.16
(Portage version: 2.1)
Diffstat (limited to 'net-mail/dovecot/files')
-rw-r--r--net-mail/dovecot/files/digest-dovecot-1.0_beta9-r13
-rw-r--r--net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch191
2 files changed, 194 insertions, 0 deletions
diff --git a/net-mail/dovecot/files/digest-dovecot-1.0_beta9-r1 b/net-mail/dovecot/files/digest-dovecot-1.0_beta9-r1
new file mode 100644
index 000000000000..5e22728901a3
--- /dev/null
+++ b/net-mail/dovecot/files/digest-dovecot-1.0_beta9-r1
@@ -0,0 +1,3 @@
+MD5 5c19a21afb8a02c95f3f62fa37d8e1ed dovecot-1.0.beta9.tar.gz 1245601
+RMD160 30d423b9fd2056fd8d898bc4bc630d3806cc64c4 dovecot-1.0.beta9.tar.gz 1245601
+SHA256 1bc44e2ab23ac8863aea42ce4ea5045d5f6ee2375804e432d8e7f918c14379b8 dovecot-1.0.beta9.tar.gz 1245601
diff --git a/net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch b/net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch
new file mode 100644
index 000000000000..02b4f7a43502
--- /dev/null
+++ b/net-mail/dovecot/files/dovecot-1.0_beta9-configure.patch
@@ -0,0 +1,191 @@
+Add detection for working epoll, inotify, kqueue, dnotify and poll.
+This should solve the issue of inotify.h being present but the kernel
+and/or glibc does not support it.
+
+--- configure.in 2006-06-13 12:24:58.000000000 +0100
++++ configure.in 2006-06-15 14:46:05.620287008 +0100
+@@ -364,29 +364,39 @@
+ dnl * I/O loop function
+ have_ioloop=no
+
+-dnl we currently don't use epoll automatically because it fails at runtime
+-dnl if we're not running 2.6 kernel
+-if test "$ioloop" = "epoll"; then
+- AC_CHECK_FUNC(epoll_create, [
++if test "$ioloop" = "" || test "$ioloop" = "epoll"; then
++ AC_TRY_RUN([
++ #include <stdint.h>
++ #include <sys/epoll.h>
++ #include <errno.h>
++
++ #include <asm/unistd.h>
++
++ _syscall1 (int, epoll_create, int, size)
++
++ int main()
++ {
++ return epoll_create(5) < 1;
++ }
++ ], [
+ AC_DEFINE(IOLOOP_EPOLL,, Implement I/O loop with Linux 2.6 epoll())
+ have_ioloop=yes
++ ioloop=epoll
+ ], [
+- ioloop=""
++ if test "$ioloop" != "" ; then
++ AC_MSG_WARN([epoll ioloop requested but epoll_create() is not available])
++ fi
+ ])
+ fi
+
+-if test "$ioloop" = "kqueue"; then
+- if test "$ac_cv_func_kqueue" != yes ; then
+- AC_MSG_WARN([kqueue ioloop requested but kqueue() is not available])
+- ioloop=""
+- elif test "$ac_cv_func_kevent" != yes ; then
+- AC_MSG_WARN([kqueue ioloop requested but kevent() is not available])
+- ioloop=""
+- else
+- AC_DEFINE(IOLOOP_KQUEUE,, [Implement I/O loop with BSD kqueue()])
+- ioloop=kqueue
+- have_ioloop=yes
+- fi
++if test "$ioloop" = "" || test "$ioloop" = "kqueue"; then
++ if test "$ac_cv_func_kqueue" = yes && test "$ac_cv_func_kevent" == yes ; then
++ AC_DEFINE(IOLOOP_KQUEUE,, [Implement I/O loop with BSD kqueue()])
++ ioloop=kqueue
++ have_ioloop=yes
++ elif test "$ioloop" = "kqueue"; then
++ AC_MSG_WARN([kqueue ioloop requested but kqueue() is not available])
++ fi
+ fi
+
+ if test "$ioloop" = "" || test "$ioloop" = "poll"; then
+@@ -404,69 +414,83 @@
+
+ have_notify=none
+
+-if test "$notify" = "" || test "$notify" = "dnotify"; then
+- dnl * dnotify?
+- AC_TRY_COMPILE([
+- #define _GNU_SOURCE
+- #include <fcntl.h>
+- #include <signal.h>
+- #include <unistd.h>
+- ], [
+- fcntl(0, F_SETSIG, SIGRTMIN);
+- fcntl(0, F_NOTIFY, DN_CREATE | DN_DELETE | DN_RENAME | DN_MULTISHOT);
+- ], [
+- AC_DEFINE(IOLOOP_NOTIFY_DNOTIFY,, Use Linux dnotify)
+- have_notify=dnotify
+- ], [
+- if test "$notify" = "dnotify"; then
+- AC_MSG_ERROR([dnotify requested but not available])
+- fi
+- ])
+-elif test "$notify" = "inotify"; then
++if test "$notify" = "" || test "$notify" = "inotify" ; then
+ dnl * inotify?
+- AC_TRY_COMPILE([
++ AC_TRY_RUN([
+ #define _GNU_SOURCE
+ #include <sys/ioctl.h>
+ #include <fcntl.h>
+ #include <sys/inotify.h>
+ #include <stdio.h>
+- ], [
+- int wd, fd;
+- char * fn = "/tmp";
++
++ int main()
++ {
++ int wd, fd;
++ char * fn = "/tmp";
+
+- fd = inotify_init ();
+- if (fd < 0)
+- perror ("inotify_init");
+-
+- wd = inotify_add_watch (fd, fn, IN_ALL_EVENTS);
++ fd = inotify_init ();
++ if (fd < 0)
++ {
++ perror ("inotify_init");
++ return (-1);
++ }
++
++ wd = inotify_add_watch (fd, fn, IN_ALL_EVENTS);
++
++ if (wd < 0)
++ {
++ perror ("inotify_add_watch");
++ return (-2);
++ }
+
+- if (wd < 0)
+- perror ("inotify_add_watch");
++ inotify_rm_watch (fd, wd);
+
+- inotify_rm_watch (fd, wd);
+-
+- close (fd);
++ close (fd);
++ }
+ ], [
+ have_notify=inotify
++ notify=inotify
+ AC_DEFINE(IOLOOP_NOTIFY_INOTIFY,, Use Linux inotify)
+ ], [
+- AC_MSG_ERROR([inotify requested but not available, check for existence of <sys/inotify.h>])
++ if test "$notify" = "inotify"; then
++ AC_MSG_WARN([inotify requested but not available])
++ fi
+ ])
+-elif test "$notify" = "kqueue"; then
++fi
++
++if test "$notify" = "" || test "$notify" = "kqueue"; then
+ dnl * BSD kqueue() notify
+- if test "$ac_cv_func_kqueue" != yes ; then
+- AC_MSG_WARN([kqueue notify requested but kqueue() is not available])
+- notify=""
+- elif test "$ac_cv_func_kevent" != yes ; then
+- AC_MSG_WARN([kqueue notify requested but kevent() is not available])
+- notify=""
+- else
++ if test "$ac_cv_func_kqueue" == yes && test "$ac_cv_func_kevent" == yes ; then
+ have_notify=kqueue
++ notify=kqueue
+ AC_DEFINE(IOLOOP_NOTIFY_KQUEUE,,
+ Use BSD kqueue directory changes notificaton)
++ else
++ if test "$notfify" = "kqueue" ; then
++ AC_MSG_WARN([kqueue notify requested but kqueue() is not available])
++ fi
+ fi
+-else
+- AC_MSG_ERROR([Unknown notify method: $notify])
++fi
++
++if test "$notify" = "" || test "$notify" = "dnotify"; then
++ dnl * dnotify?
++ AC_TRY_COMPILE([
++ #define _GNU_SOURCE
++ #include <fcntl.h>
++ #include <signal.h>
++ #include <unistd.h>
++ ], [
++ fcntl(0, F_SETSIG, SIGRTMIN);
++ fcntl(0, F_NOTIFY, DN_CREATE | DN_DELETE | DN_RENAME | DN_MULTISHOT);
++ ], [
++ AC_DEFINE(IOLOOP_NOTIFY_DNOTIFY,, Use Linux dnotify)
++ have_notify=dnotify
++ notify=dnotify
++ ], [
++ if test "$notify" = "dnotify"; then
++ AC_MSG_WARN([dnotify requested but not available])
++ fi
++ ])
+ fi
+
+ if test "$have_notify" = "none"; then