summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-10 18:48:17 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-10 18:48:17 +0000
commit7d9ef7f0aa498c1299e37d2a88968bac57274454 (patch)
treef86a32359311f5c4b8a77a9e7764fe1a608e2696 /net-mail/email/email-3.0.5.ebuild
parentFix pkgconfig dep (#205440) (diff)
downloadgentoo-2-7d9ef7f0aa498c1299e37d2a88968bac57274454.tar.gz
gentoo-2-7d9ef7f0aa498c1299e37d2a88968bac57274454.tar.bz2
gentoo-2-7d9ef7f0aa498c1299e37d2a88968bac57274454.zip
Version bump (#225445)
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-mail/email/email-3.0.5.ebuild')
-rw-r--r--net-mail/email/email-3.0.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-mail/email/email-3.0.5.ebuild b/net-mail/email/email-3.0.5.ebuild
new file mode 100644
index 000000000000..e41bc902a496
--- /dev/null
+++ b/net-mail/email/email-3.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/email/email-3.0.5.ebuild,v 1.1 2008/06/10 18:48:17 dertobi123 Exp $
+
+DESCRIPTION="Advanced CLI tool for sending email."
+HOMEPAGE="http://www.cleancode.org/projects/email"
+SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ local myconf=""
+
+ if [ -f /etc/conf.d/clock ]; then
+ . /etc/conf.d/clock
+ if [ x$CLOCK = "xUTC" ]; then
+ elog "Using UTC timestamps (from /etc/conf.d/clock)"
+ myconf="${myconf} --with-utc"
+ fi
+ fi
+
+ sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
+ sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ doman email.1
+ dodoc INSTALL quoted-printable.rfc RFC821 TODO
+ make DESTDIR=${D} install || die "install failed"
+}
+
+pkg_preinst() {
+ rm ${D}/usr/share/doc/${P}/email.1
+}
+
+pkg_postinst() {
+ echo
+ elog "Do not forget to edit /etc/email/email.conf file before using email."
+ echo
+}