summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-20 19:00:35 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-20 19:00:35 +0000
commit7a8e02833720b56f4f8fcecf421b4f7f14db5591 (patch)
tree10d42703b2e7998463e0dab3e79e750f4635f53a /net-mail/exim
parentVersion bump (diff)
downloadgentoo-2-7a8e02833720b56f4f8fcecf421b4f7f14db5591.tar.gz
gentoo-2-7a8e02833720b56f4f8fcecf421b4f7f14db5591.tar.bz2
gentoo-2-7a8e02833720b56f4f8fcecf421b4f7f14db5591.zip
Updated ebuild based on suggestions by Eric Renfro. Please report any
issues with this ebuild on bug #6117. Added mta-pgsql use variable and dependancy. Updated LOOKUP_LIBS and LOOKUP_INCLUDES logic for cleaner installs.
Diffstat (limited to 'net-mail/exim')
-rw-r--r--net-mail/exim/ChangeLog10
-rw-r--r--net-mail/exim/exim-4.04-r2.ebuild204
-rw-r--r--net-mail/exim/files/digest-exim-4.04-r21
3 files changed, 214 insertions, 1 deletions
diff --git a/net-mail/exim/ChangeLog b/net-mail/exim/ChangeLog
index cc069ee47830..ff79923e376a 100644
--- a/net-mail/exim/ChangeLog
+++ b/net-mail/exim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/exim
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/exim/ChangeLog,v 1.6 2002/08/15 22:24:50 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/exim/ChangeLog,v 1.7 2002/08/20 19:00:35 raker Exp $
+
+*exim-4.04-r2 (20 Aug 2002)
+
+ 20 Aug 2002; Nick Hadaway <raker@gentoo.org>
+ exim-4.04-r2.ebuild, files/digest-exim-4.04-r2 :
+ Updated ebuild with a cleaner LOOKUP_INCLUDE and LOOKUP_LIBS scheme
+ as suggested by Eric Renfro. Added support for mta-pgsql USE variable
+ and updated dependancies.
*exim-4.04-r1 (15 Aug 2002)
diff --git a/net-mail/exim/exim-4.04-r2.ebuild b/net-mail/exim/exim-4.04-r2.ebuild
new file mode 100644
index 000000000000..52da637c8e68
--- /dev/null
+++ b/net-mail/exim/exim-4.04-r2.ebuild
@@ -0,0 +1,204 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Updated to exim-4 by Ben Lutgens <lamer@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/exim/exim-4.04-r2.ebuild,v 1.1 2002/08/20 19:00:35 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A highly configurable, drop-in replacement for sendmail"
+SRC_URI="ftp://ftp.exim.org/pub/exim/exim4/${P}.tar.gz"
+HOMEPAGE="http://www.exim.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/db-3.2
+ >=sys-devel/perl-5.6.0
+ >=dev-libs/libpcre-3.4
+ pam? ( >=sys-libs/pam-0.75 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ mta-tls? ( >=dev-libs/openssl-0.9.6 )
+ mta-ldap? ( >=net-nds/openldap-2.0.7 )
+ mta-mysql? ( >=dev-db/mysql-3.23.28 )
+ mta-pgsql? ( >=dev-db/postgresql-7 )"
+
+RDEPEND="${DEPEND}
+ !virtual/mta
+ >=net-mail/mailbase-0.00"
+
+PROVIDE="virtual/mta"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+src_unpack() {
+
+ local myconf
+ unpack ${A}
+ cd ${S}
+
+ # Don't need this in exim4 dir exists
+ #mkdir Local
+ sed -e "48i\CFLAGS=${CFLAGS}" \
+ -e "s:# AUTH_CRAM_MD5=yes:AUTH_CRAM_MD5=yes:" \
+ -e "s:# AUTH_PLAINTEXT=yes:AUTH_PLAINTEXT=yes:" \
+ -e "s:BIN_DIRECTORY=/usr/exim/bin:BIN_DIRECTORY=/usr/sbin:" \
+ -e "s:COMPRESS_COMMAND=/opt/gnu/bin/gzip:COMPRESS_COMMAND=/usr/bin/gzip:" \
+ -e "s:ZCAT_COMMAND=/opt/gnu/bin/zcat:ZCAT_COMMAND=/usr/bin/zcat:" \
+ -e "s:CONFIGURE_FILE=/usr/exim/configure:CONFIGURE_FILE=/etc/exim/configure:" \
+ -e "s:EXIM_MONITOR=eximon.bin:# EXIM_MONITOR=eximon.bin:" \
+ -e "s:# EXIM_PERL=perl.o:EXIM_PERL=perl.o:" \
+ -e "s:# INFO_DIRECTORY=/usr/local/info:INFO_DIRECTORY=/usr/share/info:" \
+ -e "s:# LOG_FILE_PATH=syslog:LOG_FILE_PATH=syslog:" \
+ -e "s:LOG_FILE_PATH=syslog\:/var/log/exim_%slog::" \
+ -e "s:# PID_FILE_PATH=/var/lock/exim%s.pid:PID_FILE_PATH=/var/run/exim%s.pid:" \
+ -e "s:# SPOOL_DIRECTORY=/var/spool/exim:SPOOL_DIRECTORY=/var/spool/exim:" \
+ -e "s:# SUPPORT_MAILDIR=yes:SUPPORT_MAILDIR=yes:" \
+ -e "s:# SUPPORT_MAILSTOR=yes:SUPPORT_MAILSTORE=yes:" \
+ -e "s:# SUPPORT_MBX=yes:SUPPORT_MBX=yes:" \
+ -e "s:EXIM_USER=:EXIM_USER=mail:" \
+ -e "s:# AUTH_SPA=yes:AUTH_SPA=yes:" \
+ src/EDITME > Local/Makefile
+
+ cd Local
+ if use pam; then
+ cp Makefile Makefile.orig
+ sed -e "s:# SUPPORT_PAM=yes:SUPPORT_PAM=yes:" Makefile.orig > Makefile
+ myconf="${myconf} -lpam"
+ fi
+ if use tcpd; then
+ cp Makefile Makefile.orig
+ sed -e "s:# USE_TCP_WRAPPERS=yes:USE_TCP_WRAPPERS=yes:" Makefile.orig > Makefile
+ myconf="${myconf} -lwrap"
+ fi
+ if [ -n "$myconf" ] ; then
+ echo "EXTRALIBS=${myconf}" >> Makefile
+ fi
+
+ cd ${S}
+ if use mta-tls; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# SUPPORT_TLS=yes:SUPPORT_TLS=yes:" \
+ -e "s:# TLS_LIBS=-lssl -lcrypto:TLS_LIBS=-lssl -lcrypto:" Local/Makefile.tmp > Local/Makefile
+ fi
+
+ LOOKUP_INCLUDE=
+ LOOKUP_LIBS=
+
+ if use mta-ldap; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_LDAP=yes:LOOKUP_LDAP=yes:" \
+ -e "s:# LDAP_LIB_TYPE=OPENLDAP2:LDAP_LIB_TYPE=OPENLDAP2:" \
+ Local/Makefile.tmp >| Local/Makefile
+ LOOKUP_INCLUDE="-I/usr/include/ldap"
+ LOOKUP_LIBS="-L/usr/lib -lldap -llber"
+ fi
+
+ if use mta-mysql; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_MYSQL=yes:LOOKUP_MYSQL=yes:" \
+ Local/Makefile.tmp >| Local/Makefile
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I/usr/include/mysql"
+ LOOKUP_LIBS="$LOOKUP_LIBS -L/usr/lib -lmysqlclient"
+ fi
+
+ if use mta-pgsql; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_PGSQL=yes:LOOKUP_PGSQL=yes:" \
+ Local/Makefile.tmp >| Local/Makefile
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I/usr/include/postgresql"
+ LOOKUP_LIBS="$LOOKUP_LIBS -lpg"
+ fi
+
+ if [ -n "$LOOKUP_INCLUDE" ]; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include:LOOKUP_INCLUDE=$LOOKUP_INCLUDE:" \
+ Local/Makefile.tmp >| Local/Makefile
+ fi
+
+ if [ -n "$LOOKUP_LIBS" ]; then
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq:LOOKUP_LIBS=$LOOKUP_LIBS:" \
+ Local/Makefile.tmp >| Local/Makefile
+ fi
+
+
+ cat Makefile | sed -e 's/^buildname=.*/buildname=exim-gentoo/g' > Makefile.gentoo && mv -f Makefile.gentoo Makefile
+
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_DSEARCH=yes:LOOKUP_DSEARCH=yes:" Local/Makefile.tmp >| Local/Makefile
+
+ cp Local/Makefile Local/Makefile.tmp
+ sed -e "s:# LOOKUP_CDB=yes:LOOKUP_CDB=yes:" Local/Makefile.tmp >| Local/Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+
+src_install () {
+
+ cd ${S}/build-exim-gentoo
+ insopts -o root -g root -m 4755
+ insinto /usr/sbin
+ doins exim
+
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosym /usr/sbin/exim /usr/bin/mailq
+ dosym /usr/sbin/exim /usr/bin/newaliases
+ dosym /usr/sbin/exim /usr/bin/mail
+ dosym /usr/sbin/exim /usr/lib/sendmail
+ dosym /usr/sbin/exim /usr/sbin/sendmail
+
+ exeinto /usr/sbin
+ for i in exicyclog exim_dbmbuild exim_dumpdb exim_fixdb exim_lock \
+ exim_tidydb exinext exiwhat exigrep eximstats exiqsumm
+ do
+ doexe $i
+ done
+
+ # This stuff shows up in ${S}/exim-build-gentoo now. Wierd.
+ #cd ${S}/util
+ #exeinto /usr/sbin
+ #for i in exigrep eximstats exiqsumm
+ #do
+ # doexe $i
+ #done
+
+ dodir /etc/exim /etc/exim/samples
+
+ insopts -o root -g root -m 0644
+ insinto /etc/exim/samples
+ doins ${FILESDIR}/smtp-auth-tls-client-configure
+ cd ${S}/src
+ insopts -o root -g root -m 0644
+ insinto /etc/exim
+ doins configure.default
+
+ dodoc ${S}/doc/*
+ doman ${S}/doc/exim.8
+ # INSTALL a pam.d file for SMTP AUTH that works with gentoo's pam
+ insinto /etc/pam.d
+ doins ${FILESDIR}/pam.d-exim
+
+ # A nice filter for exim to protect your windows clients.
+ insinto /etc/exim
+ doins ${FILESDIR}/system_filter.exim
+ dodoc ${FILESDIR}/auth_conf.sub
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/exim.rc6 exim
+ insinto /etc/conf.d
+ newins ${FILESDIR}/exim.confd exim
+}
+
+
+pkg_config() {
+
+ ${ROOT}/usr/sbin/rc-update add exim
+}
+pkg_postinst() {
+ einfo "Read the bottom of /etc/exim/system_filter.exim for usage."
+ einfo "/usr/share/doc/${P}/auth_conf.sub.gz contains the configuration sub for using smtp auth."
+ einfo "Please create /etc/exim/configure from /etc/exim/configure.default."
+ einfo "Also see /etc/exim/samples dir for example configs."
+}
diff --git a/net-mail/exim/files/digest-exim-4.04-r2 b/net-mail/exim/files/digest-exim-4.04-r2
new file mode 100644
index 000000000000..3a9c1aaa7444
--- /dev/null
+++ b/net-mail/exim/files/digest-exim-4.04-r2
@@ -0,0 +1 @@
+MD5 cfe70a927d66a4bd5ec075b5127d3529 exim-4.04.tar.gz 1338993