summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2004-07-30 15:59:15 +0000
committerTuan Van <langthang@gentoo.org>2004-07-30 15:59:15 +0000
commit7544a9380c9754bc4799583cb1783e8d7ac9e7e0 (patch)
tree06721947789d64ad15811eab82316e6d2cc1be91 /net-mail/getmail
parentnew version on cpan (Manifest recommit) (diff)
downloadgentoo-2-7544a9380c9754bc4799583cb1783e8d7ac9e7e0.tar.gz
gentoo-2-7544a9380c9754bc4799583cb1783e8d7ac9e7e0.tar.bz2
gentoo-2-7544a9380c9754bc4799583cb1783e8d7ac9e7e0.zip
version bump, resolve bug #56673.
Diffstat (limited to 'net-mail/getmail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/Manifest2
-rw-r--r--net-mail/getmail/files/digest-getmail-4.0.11
-rw-r--r--net-mail/getmail/getmail-4.0.1.ebuild53
4 files changed, 62 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 0485697a268f..31e06043b2d7 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.13 2004/07/07 20:45:35 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.14 2004/07/30 15:59:15 langthang Exp $
+
+*getmail-4.0.1 (30 Jul 2004)
+
+ 30 Jul 2004; Tuan Van <langthang@gentoo.org> +getmail-4.0.1.ebuild:
+ version bump, resolve bug #56673.
07 Jul 2004; Tuan Van<langthang@gentoo.org> :
Version bump bug #47741. Thanks to tove <bugs-at-veller-dot-net>, Daniel
diff --git a/net-mail/getmail/Manifest b/net-mail/getmail/Manifest
index ea8bbcce5e64..27f1ca208ae5 100644
--- a/net-mail/getmail/Manifest
+++ b/net-mail/getmail/Manifest
@@ -1,3 +1,4 @@
+MD5 10a8b5acb90ad2a73c65a335f1d6f436 getmail-4.0.1.ebuild 1518
MD5 821f8506642ad867a99f337be131eaa0 getmail-3.2.4.ebuild 941
MD5 beab59d24d98394525c6f4fc7e07ee44 getmail-3.1.3.ebuild 933
MD5 40fa089fe8eaa04a4acb613dbe571b56 getmail-3.2.1.ebuild 940
@@ -10,3 +11,4 @@ MD5 db2acd3a4b93154ffb08d5c145dd21e0 files/digest-getmail-3.1.3 64
MD5 caec3387c9daa726c3e2a68ae906e5ba files/digest-getmail-3.1.7 64
MD5 02e47482585d06da914552e487232ceb files/digest-getmail-3.2.1 64
MD5 998916c10355bce7b9a852cd17a7fc9e files/digest-getmail-3.2.4 64
+MD5 6d81a58c9173338fc9824c593464b875 files/digest-getmail-4.0.1 65
diff --git a/net-mail/getmail/files/digest-getmail-4.0.1 b/net-mail/getmail/files/digest-getmail-4.0.1
new file mode 100644
index 000000000000..c989e97fe2c0
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.0.1
@@ -0,0 +1 @@
+MD5 d13b987306dec7a9fd33e77fb97970ca getmail-4.0.1.tar.gz 101629
diff --git a/net-mail/getmail/getmail-4.0.1.ebuild b/net-mail/getmail/getmail-4.0.1.ebuild
new file mode 100644
index 000000000000..a6759c05d907
--- /dev/null
+++ b/net-mail/getmail/getmail-4.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.0.1.ebuild,v 1.1 2004/07/30 15:59:15 langthang Exp $
+
+inherit distutils
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://www.qcc.ca/~charlesc/software/getmail-4/"
+SRC_URI="http://www.qcc.ca/~charlesc/software/getmail-4/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+warn() {
+ echo
+ ewarn "getmail version 4 has been completely rewritten. Visit:"
+ echo "http://www.qcc.ca/~charlesc/software/getmail-4/documentation.html#v4differences"
+ ewarn "for changes it might affect you upgrading from getmail version 3."
+ echo
+ ewarn "This version has been SLOTTED to co-exist with getmail 3."
+ ewarn "The three main scripts are getmail4, getmail_maildir4, getmail_mbox4."
+ ewarn "Please remember to \`env-update; source /etc/profile\` before the first use."
+ echo
+ ewarn "Waiting 15 seconds before continuing..."
+ sleep 15
+}
+
+pkg_setup() {
+ warn
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ LIBPATH=${ROOT}/usr/lib/${P}
+ echo "PYTHONPATH=\"${LIBPATH}\"" > 99${P}
+ insinto ${ROOT}/etc/env.d
+ doins 99${P}
+ python setup.py install --install-scripts=${D}/usr/bin/ \
+ --install-data=${D}/usr/share/ --install-lib=${D}/usr/lib/${P}/
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+}
+
+pkg_postinst() {
+ warn
+}