summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-08-28 22:32:13 +0000
committerBen Lutgens <lamer@gentoo.org>2001-08-28 22:32:13 +0000
commit9ffb9743c862c6ab924bb84800d17c7054a3d007 (patch)
tree16dab5e3d0f13ee69e5d834a59e0bb00d1a4e2c1 /net-mail/procmail
parentfixing digest for fixed archive (diff)
downloadgentoo-2-9ffb9743c862c6ab924bb84800d17c7054a3d007.tar.gz
gentoo-2-9ffb9743c862c6ab924bb84800d17c7054a3d007.tar.bz2
gentoo-2-9ffb9743c862c6ab924bb84800d17c7054a3d007.zip
added new category x11-misc and updated portage.py to reflect that.
changed "try make" to "make || die" in xinetd. The rest got moved out of incomming and into main tree. fakeidentd has a shitty init script, and leafnode don't have one at all yet.
Diffstat (limited to 'net-mail/procmail')
-rw-r--r--net-mail/procmail/files/digest-procmail-3.211
-rw-r--r--net-mail/procmail/procmail-3.21.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/procmail/files/digest-procmail-3.21 b/net-mail/procmail/files/digest-procmail-3.21
new file mode 100644
index 000000000000..4179aa89d137
--- /dev/null
+++ b/net-mail/procmail/files/digest-procmail-3.21
@@ -0,0 +1 @@
+MD5 2a0491030e7bff3292257d02a93cbe91 procmail-3.21.tar.gz
diff --git a/net-mail/procmail/procmail-3.21.ebuild b/net-mail/procmail/procmail-3.21.ebuild
new file mode 100644
index 000000000000..5171c373c77c
--- /dev/null
+++ b/net-mail/procmail/procmail-3.21.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# Modified by $HOME/.maildir by Craig Joly <craig@taipan.mudshark.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/procmail-3.21.ebuild,v 1.1 2001/08/28 22:32:13 lamer Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Mail delivery agent/filter"
+SRC_URI="http://www.procmail.org/${A}"
+HOMEPAGE="http://www.procmail.org/"
+
+DEPEND="virtual/glibc
+ virtual/mta"
+
+src_compile() {
+
+ cp Makefile Makefile.orig
+ sed -e "s:CFLAGS0 = -O:CFLAGS0 = ${CFLAGS}:" \
+ -e "s:LOCKINGTEST=__defaults__:#LOCKINGTEST=__defaults__:" \
+ -e "s:#LOCKINGTEST=/tmp:LOCKINGTEST=/tmp:" Makefile.orig > Makefile
+ cd ${S}/src
+ cp authenticate.c authenticate.c.orig
+ sed -e "s:/\*#define MAILSPOOLHOME \"/.mail\":#define MAILSPOOLHOME \"/.maildir/\":" authenticate.c.orig > authenticate.c
+ cd ${S}
+ emake || die
+}
+
+src_install () {
+ cd ${S}/new
+ insinto /usr/bin
+ insopts -m 6755
+ doins procmail
+
+ insopts -m 2755
+ doins lockfile
+
+ dobin formail mailstat
+
+ doman *.1 *.5
+
+ cd ${S}
+ dodoc Artistic COPYING FAQ FEATURES HISTORY INSTALL KNOWN_BUGS README
+
+ docinto examples
+ dodoc examples/*
+}
+