summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-12 02:29:38 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-12 02:29:38 +0000
commit89a1d4edaa83bd3e8bafef764012cb307e22d4a2 (patch)
tree76a95ef8d93dab320948e0733b7f3590bb98d36d /net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild
parentfix bug #26430, cleanup ebuild a bit (diff)
downloadgentoo-2-89a1d4edaa83bd3e8bafef764012cb307e22d4a2.tar.gz
gentoo-2-89a1d4edaa83bd3e8bafef764012cb307e22d4a2.tar.bz2
gentoo-2-89a1d4edaa83bd3e8bafef764012cb307e22d4a2.zip
fix bug #26430, cleanup ebuild a bit
Diffstat (limited to 'net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild')
-rw-r--r--net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild b/net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild
new file mode 100644
index 000000000000..6fa0f45fb88d
--- /dev/null
+++ b/net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-notify/qmail-notify-0.93-r1.ebuild,v 1.1 2003/08/12 02:29:33 robbat2 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Delayed delivery notification for qmail."
+SRC_URI="http://untroubled.org/qmail-notify/${P}.tar.gz"
+HOMEPAGE="http://untroubled.org/qmail-notify/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="virtual/cron
+ net-mail/qmail"
+
+src_compile() {
+ cd ${S}
+ echo "${CC} ${CFLAGS}" > conf-cc
+ echo "${CC} ${LDFLAGS}" > conf-ld
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/sbin
+ doexe qmail-notify
+
+ exeinto /etc/cron.hourly
+ doexe ${FILESDIR}/qmail-notify.cron
+
+ dodoc README ANNOUNCEMENT TODO cron.hourly NEWS VERSION
+}
+
+
+pkg_postinst() {
+
+ echo
+ einfo "Edit qmail-notify.cron in /etc/cron.hourly"
+ einfo "to activate qmail-notify!"
+ echo
+
+
+}