summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-12-26 17:22:39 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-12-26 17:22:39 +0000
commit38a37f1d95313d20bad7c908e3e21ca5a2d8e70b (patch)
treea0e6e412b58bcc9219d9f431ca9304f0a326c75c /net-mail/sylpheed
parentnew version (diff)
downloadgentoo-2-38a37f1d95313d20bad7c908e3e21ca5a2d8e70b.tar.gz
gentoo-2-38a37f1d95313d20bad7c908e3e21ca5a2d8e70b.tar.bz2
gentoo-2-38a37f1d95313d20bad7c908e3e21ca5a2d8e70b.zip
version bump, fixes mime issue
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/ChangeLog9
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.8.81
-rw-r--r--net-mail/sylpheed/sylpheed-0.8.8.ebuild69
3 files changed, 78 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index 4422efe5cdc7..d8d7e224e4e8 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.22 2002/12/20 16:28:09 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.23 2002/12/26 17:20:57 bcowan Exp $
+
+*sylpheed-0.8.8 (26 Dec 2002)
+
+ 26 Dec 2002; Brad Cowan <bcowan@gentoo.org> sylpheed-0.8.8.ebuild,
+ files/digest-sylpheed-0.8.8:
+
+ Version bump, fixes mime issue.
*sylpheed-0.8.7 (20 Dec 2002)
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.8.8 b/net-mail/sylpheed/files/digest-sylpheed-0.8.8
new file mode 100644
index 000000000000..c853aff16fd8
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.8.8
@@ -0,0 +1 @@
+MD5 95985b7e967938e805ad7583e9d248da sylpheed-0.8.8.tar.bz2 1959172
diff --git a/net-mail/sylpheed/sylpheed-0.8.8.ebuild b/net-mail/sylpheed/sylpheed-0.8.8.ebuild
new file mode 100644
index 000000000000..62e0dcff5574
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.8.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.8.8.ebuild,v 1.1 2002/12/26 17:20:57 bcowan Exp $
+
+IUSE="ssl xface ipv6 nls gnome ldap crypt pda"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ xface? ( >=media-libs/compface-1.4 )
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+
+ local myconf
+
+ use gnome || myconf="${myconf} --disable-gdk-pixbuf --disable-imlib"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use xface || myconf="${myconf} --disable-compface"
+
+ econf ${myconf}
+
+ emake || die
+}
+
+src_install () {
+
+ einstall
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ if use gnome
+ then
+ dodir /usr/share/gnome/apps/Internet
+ insinto /usr/share/gnome/apps/Internet
+ doins sylpheed.desktop
+ fi
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+