summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-10 07:49:49 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-10 07:49:49 +0000
commit4e344b2052977b6bb8fecbbbea8b1918e0bac792 (patch)
tree9a18e99520fb92ca27391f7a43f3f889003be9c3 /net-mail/sylpheed
parentnew version (diff)
downloadgentoo-2-4e344b2052977b6bb8fecbbbea8b1918e0bac792.tar.gz
gentoo-2-4e344b2052977b6bb8fecbbbea8b1918e0bac792.tar.bz2
gentoo-2-4e344b2052977b6bb8fecbbbea8b1918e0bac792.zip
New version
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/sylpheed-0.5.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/sylpheed/sylpheed-0.5.0.ebuild b/net-mail/sylpheed/sylpheed-0.5.0.ebuild
new file mode 100644
index 000000000000..52c4183df5be
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.5.0.ebuild,v 1.1 2001/07/10 07:49:49 achim Exp $
+
+#P=
+A=${PN}-0.5.0.tar.bz2
+S=${WORKDIR}/${PN}-0.5.0
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/sylpheed/${A}"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+DEPEND=">=x11-libs/gtk+-1.2
+ >=media-libs/compface-1.4
+ gnome? ( >=gnome-base/gdk-pixbuf-0.10 )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND=">=x11-libs/gtk+-1.2
+ gnome? ( >=gnome-base/gdk-pixbuf-0.10 )"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use gnome`" ] ; then
+ myconf="--disable-gdk-pixbuf --disable-imlib"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST} --enable-ipv6 $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr manualdir=${D}/usr/share/doc/${PF}/html install
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+
+}
+