summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-11-17 01:53:26 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-11-17 01:53:26 +0000
commit277d96b7c05ff22779d5b9467cc7c0d11dbac844 (patch)
tree73b95399201e3b003c72a59cd19bd4c71e43b28f /net-mail/tmda/tmda-0.65.ebuild
parentsupport for a new gtk engine (diff)
downloadgentoo-2-277d96b7c05ff22779d5b9467cc7c0d11dbac844.tar.gz
gentoo-2-277d96b7c05ff22779d5b9467cc7c0d11dbac844.tar.bz2
gentoo-2-277d96b7c05ff22779d5b9467cc7c0d11dbac844.zip
Version bump.
Diffstat (limited to 'net-mail/tmda/tmda-0.65.ebuild')
-rw-r--r--net-mail/tmda/tmda-0.65.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/tmda/tmda-0.65.ebuild b/net-mail/tmda/tmda-0.65.ebuild
new file mode 100644
index 000000000000..6e0b21d40073
--- /dev/null
+++ b/net-mail/tmda/tmda-0.65.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.65.ebuild,v 1.1 2002/11/17 01:51:52 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.1
+ virtual/mta"
+
+SRC_URI="http://tmda.net/releases/${P}.tgz
+ http://tmda.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="x86 sparc sparc64"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO
+ dodoc contrib/tmda.spec contrib/sample.tmdarc
+ dohtml -r htdocs/*.html
+
+ # Contributed binaries and stuff
+ cd contrib
+ exeinto /usr/lib/tmda/bin
+ doexe printcdb printdbm collectaddys def2html
+ insinto /usr/lib/tmda/lisp
+ doins tmda.el
+}