summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-02-20 03:19:48 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-02-20 03:19:48 +0000
commit1a6cda640cfdd8de8300b19ff54771cb08a71f35 (patch)
tree4ed60515fd7c10dc2c88eb7f77b9cab6a2c30d4e /net-mail/tmda
parentAdded ebuild for BubbleFishyMon Gkrellm plug-in from Seemant Kulleen. (diff)
downloadgentoo-2-1a6cda640cfdd8de8300b19ff54771cb08a71f35.tar.gz
gentoo-2-1a6cda640cfdd8de8300b19ff54771cb08a71f35.tar.bz2
gentoo-2-1a6cda640cfdd8de8300b19ff54771cb08a71f35.zip
Updated to version 0.47.
Diffstat (limited to 'net-mail/tmda')
-rw-r--r--net-mail/tmda/ChangeLog8
-rw-r--r--net-mail/tmda/files/digest-tmda-0.471
-rw-r--r--net-mail/tmda/tmda-0.47.ebuild48
3 files changed, 56 insertions, 1 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 2808ce1cd978..78d32fd06061 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/tmda
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.3 2002/02/15 05:17:32 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.4 2002/02/20 03:19:48 agenkin Exp $
+
+*tmda-0.47 ( 19 Feb 2002 )
+
+ 14 Feb 2002; Arcady Genkin <agenkin@thpoon.com> tmda-0.47.ebuild :
+
+ Version 0.47 is released.
*tmda-0.46 ( 8 Feb 2002 )
diff --git a/net-mail/tmda/files/digest-tmda-0.47 b/net-mail/tmda/files/digest-tmda-0.47
new file mode 100644
index 000000000000..185500be4b25
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.47
@@ -0,0 +1 @@
+MD5 3e036a71c1ef3238551006eb911fb632 tmda-0.47.tgz 102404
diff --git a/net-mail/tmda/tmda-0.47.ebuild b/net-mail/tmda/tmda-0.47.ebuild
new file mode 100644
index 000000000000..942953f3c3ba
--- /dev/null
+++ b/net-mail/tmda/tmda-0.47.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Arcady Genkin <agenkin@thpoon.com>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.47.ebuild,v 1.1 2002/02/20 03:19:48 agenkin Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Python-based SPAM reduction system"
+SRC_URI="http://software.libertine.org/tmda/releases/${P}.tgz"
+HOMEPAGE="http://software.libertine.org/tmda/index.html"
+
+DEPEND=">=dev-lang/python-2.0
+ virtual/mta"
+
+src_compile() {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYRIGHT ChangeLog README THANKS UPGRADE CRYPTO
+ dohtml -r htdocs/*.html
+
+ # Contributed binaries and stuff
+ cd contrib
+ dodoc README.RELAY qmail-smtpd_auth.patch tmda.spec sample.tmdarc
+ exeinto /usr/lib/tmda/bin
+ doexe list2cdb list2dbm printcdb printdbm
+ insinto /usr/lib/tmda
+ doins setup.pyc
+ exeinto /usr/lib/tmda
+ doexe setup.py
+}