summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-05-23 09:57:11 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-05-23 09:57:11 +0000
commitc852fa864aa27fc27492324b241b63ad2355238e (patch)
tree0ff2cbf5c30010724d5e6cf1f17fa0524e65892b /net-mail/vchkuser
parentAdd a patch to build with glibc 2.10, getline redefinitions, by Constantin Ba... (diff)
downloadgentoo-2-c852fa864aa27fc27492324b241b63ad2355238e.tar.gz
gentoo-2-c852fa864aa27fc27492324b241b63ad2355238e.tar.bz2
gentoo-2-c852fa864aa27fc27492324b241b63ad2355238e.zip
version bump
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'net-mail/vchkuser')
-rw-r--r--net-mail/vchkuser/ChangeLog7
-rw-r--r--net-mail/vchkuser/vchkuser-0.3.2.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/net-mail/vchkuser/ChangeLog b/net-mail/vchkuser/ChangeLog
index 990443c9ed22..ba359d260f85 100644
--- a/net-mail/vchkuser/ChangeLog
+++ b/net-mail/vchkuser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/vchkuser
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vchkuser/ChangeLog,v 1.1 2009/02/14 19:55:55 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vchkuser/ChangeLog,v 1.2 2009/05/23 09:57:11 hollow Exp $
+
+*vchkuser-0.3.2 (23 May 2009)
+
+ 23 May 2009; Benedikt Böhm <hollow@gentoo.org> +vchkuser-0.3.2.ebuild:
+ version bump
*vchkuser-0.3.1 (14 Feb 2009)
diff --git a/net-mail/vchkuser/vchkuser-0.3.2.ebuild b/net-mail/vchkuser/vchkuser-0.3.2.ebuild
new file mode 100644
index 000000000000..ac372d4b4603
--- /dev/null
+++ b/net-mail/vchkuser/vchkuser-0.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vchkuser/vchkuser-0.3.2.ebuild,v 1.1 2009/05/23 09:57:11 hollow Exp $
+
+EAPI="2"
+
+inherit autotools qmail
+
+DESCRIPTION="qmail-spp plugin to check recipient existance with vpopmail"
+HOMEPAGE="http://bb.xnull.de/projects/vchkuser/"
+SRC_URI="http://bb.xnull.de/projects/vchkuser/dist/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="net-mail/vpopmail
+ || ( mail-mta/netqmail[qmail-spp] mail-mta/qmail-ldap[qmail-spp] )"
+RDEPEND=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --with-vpopuser=vpopmail \
+ --with-qmailgroup=nofiles \
+ --with-vpopmaildir=/var/vpopmail \
+ --with-qmaildir=${QMAIL_HOME}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ fowners vpopmail:nofiles "${QMAIL_HOME}"/plugins/vchkuser
+ fperms 4750 "${QMAIL_HOME}"/plugins/vchkuser
+}