summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-03 07:22:33 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-03 07:22:33 +0000
commitff5ff91d2925c3df7a7534288192f47741bcec4e (patch)
treefa16a1ee8e0a1c6e78e2e4a3acb0971321fae2f9 /net-mail/xfmail
parentinitial (diff)
downloadgentoo-2-ff5ff91d2925c3df7a7534288192f47741bcec4e.tar.gz
gentoo-2-ff5ff91d2925c3df7a7534288192f47741bcec4e.tar.bz2
gentoo-2-ff5ff91d2925c3df7a7534288192f47741bcec4e.zip
New ebuild. See bug #7929
Diffstat (limited to 'net-mail/xfmail')
-rw-r--r--net-mail/xfmail/ChangeLog9
-rw-r--r--net-mail/xfmail/files/digest-xfmail-1.5.31
-rw-r--r--net-mail/xfmail/xfmail-1.5.3.ebuild48
3 files changed, 58 insertions, 0 deletions
diff --git a/net-mail/xfmail/ChangeLog b/net-mail/xfmail/ChangeLog
new file mode 100644
index 000000000000..21b4cb0b2a1b
--- /dev/null
+++ b/net-mail/xfmail/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-mail/xfmail
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/xfmail/ChangeLog,v 1.1 2002/11/03 07:22:33 raker Exp $
+
+*xfmail-1.5.3 (03 Nov 2002)
+
+ 03 Nov 2002; Nick Hadaway <raker@gentoo.org> xfmail-1.5.3.ebuild,
+ files/digest-xfmail-1.5.3 :
+ New ebuild.
diff --git a/net-mail/xfmail/files/digest-xfmail-1.5.3 b/net-mail/xfmail/files/digest-xfmail-1.5.3
new file mode 100644
index 000000000000..9432c24aabcc
--- /dev/null
+++ b/net-mail/xfmail/files/digest-xfmail-1.5.3
@@ -0,0 +1 @@
+MD5 ce7fb31306642ba336f41ac2e0e9738f xfmail-1.5.3.tar.bz2 799591
diff --git a/net-mail/xfmail/xfmail-1.5.3.ebuild b/net-mail/xfmail/xfmail-1.5.3.ebuild
new file mode 100644
index 000000000000..632defa26d64
--- /dev/null
+++ b/net-mail/xfmail/xfmail-1.5.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/xfmail/xfmail-1.5.3.ebuild,v 1.1 2002/11/03 07:22:33 raker Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A full-featured mail program using XForms"
+SRC_URI="ftp://ftp.xfmail.org/pub/${PN}/release/1.5.3/source/${P}.tar.bz2"
+HOMEPAGE="http://www.xfmail.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="virtual/x11
+ >=x11-libs/xforms-1.0_rc4
+ ldap? ( >=net-nds/openldap-2.0.11 )"
+
+
+RDEPEND="virtual/x11
+ >=x11-libs/xforms-1.0_rc4
+ ldap? ( >=net-nds/openldap-2.0.11 )"
+
+src_compile() {
+
+ local myconf
+
+ use ldap && myconf="$myconf --with-ldap"
+
+ ./autogen.sh \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-faces $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS ChangeLog* NEWS README* TODO*
+
+}
+