summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-10-15 03:04:12 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-10-15 03:04:12 +0000
commit2a32c0b9158311cf14cc8505eeb34fcef0304bb6 (patch)
tree51f9a59ef79905b720dc65ba8476351097cca2b6 /net-mail
parentFixing manifest. (diff)
downloadgentoo-2-2a32c0b9158311cf14cc8505eeb34fcef0304bb6.tar.gz
gentoo-2-2a32c0b9158311cf14cc8505eeb34fcef0304bb6.tar.bz2
gentoo-2-2a32c0b9158311cf14cc8505eeb34fcef0304bb6.zip
Update to 0.87
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/tmda/ChangeLog7
-rw-r--r--net-mail/tmda/Manifest2
-rw-r--r--net-mail/tmda/files/digest-tmda-0.871
-rw-r--r--net-mail/tmda/tmda-0.87.ebuild58
4 files changed, 67 insertions, 1 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 0292715f6de2..25f8a5cf03df 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/tmda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.35 2003/10/02 20:20:49 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.36 2003/10/15 03:04:12 agenkin Exp $
+
+*tmda-0.87 (14 Oct 2003)
+
+ 14 Oct 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
*tmda-0.86 (02 Oct 2003)
diff --git a/net-mail/tmda/Manifest b/net-mail/tmda/Manifest
index d31ce22d4190..a22cd011dc70 100644
--- a/net-mail/tmda/Manifest
+++ b/net-mail/tmda/Manifest
@@ -1,8 +1,10 @@
+MD5 3dc6bf25fd1e0d7c47d9964709f33a3a tmda-0.87.ebuild 1552
MD5 5e45366e2e8a6f86b22c15c0af70a339 ChangeLog 5336
MD5 08044297da7d9f2face8e1edce1c8298 tmda-0.80.ebuild 1551
MD5 c98081c92f693a7c4faf4d5b32d1bb5b tmda-0.82.ebuild 1551
MD5 4ba4a6d08c451e52eeb86ac25ac0cb6d metadata.xml 253
MD5 3dc6bf25fd1e0d7c47d9964709f33a3a tmda-0.86.ebuild 1552
+MD5 95616117ddaf3c139d00283eb765647e files/digest-tmda-0.87 58
MD5 42462478761427da2aeb91f7bdd47328 files/digest-tmda-0.80 58
MD5 cd268ee6ff6b0b618d5033beafe75465 files/digest-tmda-0.82 58
MD5 e19a7fd18db9b20bbc8b6670d4abcbbf files/digest-tmda-0.86 58
diff --git a/net-mail/tmda/files/digest-tmda-0.87 b/net-mail/tmda/files/digest-tmda-0.87
new file mode 100644
index 000000000000..d3ea96fa8f04
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.87
@@ -0,0 +1 @@
+MD5 d04c514ae9e3807197c0f97a5cc317fc tmda-0.87.tgz 309957
diff --git a/net-mail/tmda/tmda-0.87.ebuild b/net-mail/tmda/tmda-0.87.ebuild
new file mode 100644
index 000000000000..3da4dd9c7cfc
--- /dev/null
+++ b/net-mail/tmda/tmda-0.87.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.87.ebuild,v 1.1 2003/10/15 03:04:12 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.2
+ virtual/mta"
+
+SRC_URI="http://tmda.net/releases/${P}.tgz
+ http://tmda.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+S="${WORKDIR}/${P}"
+
+src_compile () {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html getuserinfo-vpopmail.sh printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog sample.config tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+
+}