summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-11-30 11:36:51 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-11-30 11:36:51 +0000
commit2e995fd0c414b5f133531a6875cb2eefb016bc06 (patch)
tree7ec04c5e88ae93c00412991369750bb98371847a /net-mail
parentAdd missing blocker on emul-linux-x86-baselibs, bug #527138. (diff)
downloadgentoo-2-2e995fd0c414b5f133531a6875cb2eefb016bc06.tar.gz
gentoo-2-2e995fd0c414b5f133531a6875cb2eefb016bc06.tar.bz2
gentoo-2-2e995fd0c414b5f133531a6875cb2eefb016bc06.zip
Version bump.
NEWS ~~~~ Command-Line Interface ---------------------- - Stopped `notmuch dump` failing if someone writes to the database - `notmuch insert` requires succesful message indexing for success status - `notmuch insert` has gained support for `post-insert` hook - `notmuch deliver` is deprecated - `notmuch search` now supports `--duplicate=N` option with `--output=messages` - Added `notmuch address` subcommand Emacs Interface --------------- - Use the `j` key to access saved searches from anywhere in notmuch - Improved handling of the unread tag - Expanded default saved search settings - Improved `q` binding in notmuch buffers - `notmuch-show-stash-mlarchive-link-alist` now supports functions Library changes --------------- - Introduced database version 3 with support for "database features." - Library users are no longer required to call `notmuch_database_upgrade` - Library users can now abort an atomic section by closing the database - Add return status to notmuch_database_close and notmuch_database_destroy - Bug fixes and performance improvements for thread linking nmbug ----- `nmbug help` is not `nmbug --help`, and the following nmbug commands have slightly different interfaces: `archive`, `commit`, `fetch`, `log`, `pull`, `push`, and `status`. For details on the new interface for a given command, run `nmbug COMMAND --help`. nmbug-status ------------ `nmbug-status` can now optionally load header and footer templates from the config file. Use something like: Python Bindings --------------- Add support for `notmuch_query_add_tag_exclude` (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog57
-rw-r--r--net-mail/notmuch/notmuch-0.19.ebuild188
2 files changed, 244 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index f8b1d375d47a..5fa7d7465375 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,61 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.108 2014/11/28 13:56:06 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.109 2014/11/30 11:36:51 aidecoe Exp $
+
+*notmuch-0.19 (30 Nov 2014)
+
+ 30 Nov 2014; Amadeusz Żołnowski <aidecoe@gentoo.org> +notmuch-0.19.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+ Command-Line Interface
+ ----------------------
+
+ - Stopped `notmuch dump` failing if someone writes to the database
+ - `notmuch insert` requires succesful message indexing for success status
+ - `notmuch insert` has gained support for `post-insert` hook
+ - `notmuch deliver` is deprecated
+ - `notmuch search` now supports `--duplicate=N` option with
+ `--output=messages`
+ - Added `notmuch address` subcommand
+
+ Emacs Interface
+ ---------------
+
+ - Use the `j` key to access saved searches from anywhere in notmuch
+ - Improved handling of the unread tag
+ - Expanded default saved search settings
+ - Improved `q` binding in notmuch buffers
+ - `notmuch-show-stash-mlarchive-link-alist` now supports functions
+
+ Library changes
+ ---------------
+
+ - Introduced database version 3 with support for "database features."
+ - Library users are no longer required to call `notmuch_database_upgrade`
+ - Library users can now abort an atomic section by closing the database
+ - Add return status to notmuch_database_close and notmuch_database_destroy
+ - Bug fixes and performance improvements for thread linking
+
+ nmbug
+ -----
+
+ `nmbug help` is not `nmbug --help`, and the following nmbug commands have
+ slightly different interfaces: `archive`, `commit`, `fetch`, `log`, `pull`,
+ `push`, and `status`. For details on the new interface for a given command,
+ run `nmbug COMMAND --help`.
+
+ nmbug-status
+ ------------
+
+ `nmbug-status` can now optionally load header and footer templates
+ from the config file. Use something like:
+
+ Python Bindings
+ ---------------
+
+ Add support for `notmuch_query_add_tag_exclude`
28 Nov 2014; Pacho Ramos <pacho@gentoo.org> notmuch-0.18.2.ebuild:
Support python 3.4
diff --git a/net-mail/notmuch/notmuch-0.19.ebuild b/net-mail/notmuch/notmuch-0.19.ebuild
new file mode 100644
index 000000000000..8b15a9328a01
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.19.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.19.ebuild,v 1.1 2014/11/30 11:36:51 aidecoe Exp $
+
+EAPI=5
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit elisp-common eutils flag-o-matic pax-utils distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt debug emacs python )
+ "
+IUSE="crypt debug doc emacs mutt nmbug python test"
+
+CDEPEND="
+ >=app-shells/bash-completion-1.9
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ !=dev-libs/gmime-2.6.19
+ <dev-libs/xapian-1.3
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ python? ( dev-python/sphinx[${PYTHON_USEDEP}] ) )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-Pod-Parser
+ )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+MY_PATCHES=( )
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "There are few not backward compatible changes between"
+ ewarn "<notmuch-0.18 and >=notmuch-0.18. See NEWS file"
+ ewarn "(0.18 section) for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_prepare() {
+ [[ "${MY_PATCHES[@]}" ]] && epatch "${MY_PATCHES[@]}"
+
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ rm -f Makefile.config # assure that new Makefile.config will be generated
+
+ if use debug; then
+ append-cflags -g
+ append-cxxflags -g
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${EPREFIX}/usr/share/bash-completion"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --with-gmime-version=2.6
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with emacs)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ emake download-test-databases
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/nmbug-status
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dohtml -r python
+}
+
+pkg_preinst() {
+ if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}