summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2004-12-07 21:19:48 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2004-12-07 21:19:48 +0000
commit5f61e97bd35b50510084a604ec39cde91f786c51 (patch)
treee4a0fde236853ad9148dac4aa99bb40332236776 /net-mail
parentUpdate to 1.0 (Manifest recommit) (diff)
downloadgentoo-2-5f61e97bd35b50510084a604ec39cde91f786c51.tar.gz
gentoo-2-5f61e97bd35b50510084a604ec39cde91f786c51.tar.bz2
gentoo-2-5f61e97bd35b50510084a604ec39cde91f786c51.zip
Version bump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog7
-rw-r--r--net-mail/dovecot/Manifest2
-rw-r--r--net-mail/dovecot/dovecot-0.99.12.ebuild159
-rw-r--r--net-mail/dovecot/files/digest-dovecot-0.99.121
4 files changed, 168 insertions, 1 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index 602d2d95ab75..532fdbb71b7e 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.17 2004/11/01 17:58:09 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.18 2004/12/07 21:19:48 g2boojum Exp $
+
+*dovecot-0.99.12 (07 Dec 2004)
+
+ 07 Dec 2004; Grant Goodyear <g2boojum@gentoo.org> +dovecot-0.99.12.ebuild:
+ Version bump; thanks to Andreas Simon (bug #73561).
*dovecot-0.99.11-r1 (01 Nov 2004)
diff --git a/net-mail/dovecot/Manifest b/net-mail/dovecot/Manifest
index df80150da522..f04885e2a808 100644
--- a/net-mail/dovecot/Manifest
+++ b/net-mail/dovecot/Manifest
@@ -1,6 +1,8 @@
+MD5 876386cb1bd33f430423f380a8c10fc6 dovecot-0.99.12.ebuild 4767
MD5 876386cb1bd33f430423f380a8c10fc6 dovecot-0.99.11-r1.ebuild 4767
MD5 83f280e3d4b3f115044c983cac0e2172 ChangeLog 3722
MD5 61e0d05b1306513aede2838fa81b05b5 metadata.xml 225
MD5 07b795b2b49257dee3743d5698d0d919 files/dovecot.init 517
+MD5 917d034526e2a1f0cf99041fd20dbc47 files/digest-dovecot-0.99.12 67
MD5 3d6d703cf014f2defc8fed34b50849a9 files/digest-dovecot-0.99.11-r1 67
MD5 1c0a9ca75cadf12377e70c2ef725ba0e files/dovecot.pam 220
diff --git a/net-mail/dovecot/dovecot-0.99.12.ebuild b/net-mail/dovecot/dovecot-0.99.12.ebuild
new file mode 100644
index 000000000000..f3960d1af410
--- /dev/null
+++ b/net-mail/dovecot/dovecot-0.99.12.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-0.99.12.ebuild,v 1.1 2004/12/07 21:19:48 g2boojum Exp $
+
+IUSE="debug ipv6 ldap mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
+inherit eutils
+
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="http://dovecot.org/"
+SRC_URI="http://dovecot.org/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+
+#PROVIDE="virtual/imapd"
+
+# Note: current dovecot will break on gnutls
+# http://www.dovecot.org/list/dovecot/2004-November/005169.html
+DEPEND=">=sys-libs/db-3.2
+ >=sys-apps/sed-4
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( sys-libs/pam )
+ sasl? ( >=dev-libs/cyrus-sasl-2.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )
+ postgres? ( dev-db/postgresql )
+ mysql? ( dev-db/mysql )
+ vpopmail? ( net-mail/vpopmail )"
+ #gnutls? ( <=net-libs/gnutls-1.0.4 )
+
+RDEPEND="${DEPEND}
+ net-mail/mailbase"
+
+
+pkg_setup() {
+ # Add user and group for login process (same as for fedora/redhat)
+ enewgroup dovecot 97
+ enewuser dovecot 97 /bin/false /dev/null dovecot
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-debug"
+ use ldap && myconf="${myconf} --with-ldap"
+ use ipv6 || myconf="${myconf} --disable-ipv6"
+ use nopop3d && myconf="${myconf} --without-pop3d"
+ use pam || myconf="${myconf} --without-pam"
+ use postgres && myconf="${myconf} --with-pgsql"
+ use mysql && myconf="${myconf} --with-mysql"
+ use sasl && myconf="${myconf} --with-cyrus-sasl2"
+ # gnutls support no longer working
+ # (http://www.dovecot.org/list/dovecot/2004-November/005169.html)
+ use ssl && myconf="${myconf} --with-ssl=openssl"
+ if use gnutls; then
+ eerror 'GNUTLS support no longer available, see'
+ eerror 'http://www.dovecot.org/list/dovecot/2004-November/005169.html'
+ eerror
+ eerror 'Please set USE="-gnutls ssl" if you want TLS support.'
+ die
+ fi
+ # prefer gnutls to ssl if both gnutls and ssl are defined
+ #use gnutls && myconf="${myconf} --with-ssl=gnutls"
+ #use ssl && ! use gnutls && myconf="${myconf} --with-ssl=openssl"
+ #! use gnutls && ! use ssl && myconf="${myconf} --without-ssl"
+ use vpopmail || myconf="${myconf} --without-vpopmail"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ ${myconf} || die "configure failed"
+ emake || die
+}
+
+src_install () {
+ # Create the dovecot.conf file from the dovecot-example.conf file that
+ # the dovecot folks nicely left for us, changing the default
+ # mail spool locations to the Gentoo defaults.
+ if use mbox
+ then
+ # /var/spool/mail/$USER mail spool
+ # The location of the INDEX may be overridden by the user if desired.
+ if [ -z ${DOVECOT_INDEX_PATH} ]
+ then
+ DOVECOT_INDEX_PATH="/var/dovecot/%d/%n"
+ dodir /var/dovecot
+ fi
+ sed -e \
+ "s|#default_mail_env =|#default_mail_env = mbox:/var/spool/mail/%u:INDEX=${DOVECOT_INDEX_PATH}|" \
+ dovecot-example.conf > dovecot.conf
+ else
+ # $HOME/.maildir mail spool.
+ sed -e \
+ 's|#default_mail_env =|default_mail_env = maildir:%h/.maildir|' \
+ dovecot-example.conf > dovecot.conf
+ fi
+ insinto /etc
+ doins dovecot.conf
+
+ make DESTDIR=${D} install || die
+ rm ${D}/etc/dovecot-example.conf
+
+ # Documentation
+ rm -fr ${D}/usr/share/doc/dovecot
+ cd ${S}
+ dodoc AUTHORS COPYING* NEWS README TODO dovecot-example.conf
+ dodoc doc/*.txt doc/*.conf doc/*.cnf
+
+ # per default dovecot wants it ssl cert called dovecot.pem
+ # fix this in mkcert.sh, which we use to generate the ssl certs
+ cd ${S}/doc
+ sed -ie 's/imapd.pem/dovecot.pem/g' mkcert.sh
+ dodoc mkcert.sh
+
+ # rc script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dovecot.init dovecot
+
+ # PAM
+ if use pam
+ then
+ dodir /etc/pam.d
+ insinto /etc/pam.d
+ newins ${FILESDIR}/dovecot.pam dovecot
+ fi
+
+ # Create SSL certificates
+ if use ssl || use gnutls
+ then
+ cd ${S}/doc
+ dodir /etc/ssl/certs
+ dodir /etc/ssl/private
+ # Let's not make a new certificate if we already have one
+ [ -e /etc/ssl/certs/dovecot.pem -a -e /etc/ssl/private/dovecot.pem ] \
+ || SSLDIR=${D}/etc/ssl sh mkcert.sh
+ fi
+
+ dodir /var/run/dovecot
+ fowners root:root /var/run/dovecot
+ fperms 0700 /var/run/dovecot
+ keepdir /var/run/dovecot/login
+ fowners root:dovecot /var/run/dovecot/login
+ fperms 0750 /var/run/dovecot/login
+ fperms 0600 /etc/dovecot.conf
+}
+
+pkg_postinst() {
+ if use pam
+ then
+ ewarn "If you are upgrading from Dovecot prior to 0.99.10, be aware"
+ ewarn "that the PAM profile was changed from 'imap' to 'dovecot'."
+ einfo "Please review /etc/pam.d/dovecot."
+ fi
+ einfo "Please review /etc/dovecot.conf, particularly auth_userdb and auth_passdb."
+}
diff --git a/net-mail/dovecot/files/digest-dovecot-0.99.12 b/net-mail/dovecot/files/digest-dovecot-0.99.12
new file mode 100644
index 000000000000..16447dd8782b
--- /dev/null
+++ b/net-mail/dovecot/files/digest-dovecot-0.99.12
@@ -0,0 +1 @@
+MD5 51eb80597f9d7b04e007cea6f1faad49 dovecot-0.99.12.tar.gz 867819