summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-08-30 20:58:16 +0000
committerDonny Davies <woodchip@gentoo.org>2001-08-30 20:58:16 +0000
commit9c1e12dced5c103dd0a4de781e2ba86c795aa9b2 (patch)
tree79fd1a348cc76ff0db61b1e4133ba51fe7c8df1f /net-mail
parentremove bbweather blockage. works fine (diff)
downloadgentoo-2-9c1e12dced5c103dd0a4de781e2ba86c795aa9b2.tar.gz
gentoo-2-9c1e12dced5c103dd0a4de781e2ba86c795aa9b2.tar.bz2
gentoo-2-9c1e12dced5c103dd0a4de781e2ba86c795aa9b2.zip
added pkg_postinst()
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/bbmail/bbmail-0.6.11.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/net-mail/bbmail/bbmail-0.6.11.ebuild b/net-mail/bbmail/bbmail-0.6.11.ebuild
index 3b57e31100d4..230255569b05 100644
--- a/net-mail/bbmail/bbmail-0.6.11.ebuild
+++ b/net-mail/bbmail/bbmail-0.6.11.ebuild
@@ -1,37 +1,33 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Craig Joly <joly@ee.ualberta.ca>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/bbmail/bbmail-0.6.11.ebuild,v 1.2 2001/08/30 17:31:35 pm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/bbmail/bbmail-0.6.11.ebuild,v 1.3 2001/08/30 20:58:16 woodchip Exp $
-
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="blackbox mail notification, patched for maildir"
-SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${A}.tar.gz"
+SRC_URI="http://bbtools.thelinuxcommunity.org/sources/${P}.tar.gz"
HOMEPAGE="http://bbtools.thelinuxcommunity.org/available.phtml"
DEPEND=">=x11-wm/blackbox-0.61"
src_unpack () {
-
- unpack ${P}.tar.gz
+ unpack ${A}
cd ${S}
# This is a patch for bbmail to support qmail style maildirs
- try patch -p1 < ${FILESDIR}/bbmail-qmail.patch
+ patch -p1 < ${FILESDIR}/bbmail-qmail.patch || die
}
src_compile() {
-
- try ./configure --prefix=/usr/X11R6 --host=${CHOST}
- try emake
-
+ ./configure --prefix=/usr/X11R6 --host=${CHOST} || die
+ emake || die
}
src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO data/README.bbmail
+}
- try make DESTDIR=${D} install
- dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO data/README.bbmail
- cd /usr/X11R6/bin/wm
- cp blackbox blackbox.bak
- sed -e s:.*blackbox:"exec /usr/X11R6/bin/bbmail \&\n&": blackbox.bak > blackbox
+pkg_postinst() {
+ cd ${ROOT}usr/X11R6/bin/wm
+ sed -e "s/.*blackbox/exec \/usr\/X11R6\/bin\/bbmail \&\n&/" blackbox | cat > blackbox
}