summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2006-09-20 07:04:01 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2006-09-20 07:04:01 +0000
commitbaea18dba4b4182a77b86e031943292682b74b8c (patch)
tree0dd97c286a0b0aebf8dc3786d5798a4f3350b651 /net-mail
parentCleanup econf call, fix missing quotes, add lua useflag (and patch to disable... (diff)
downloadgentoo-2-baea18dba4b4182a77b86e031943292682b74b8c.tar.gz
gentoo-2-baea18dba4b4182a77b86e031943292682b74b8c.tar.bz2
gentoo-2-baea18dba4b4182a77b86e031943292682b74b8c.zip
Fixed gcc 4 problems (bug #147085)
(Portage version: 2.1-r2)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/libdbx/ChangeLog8
-rw-r--r--net-mail/libdbx/files/bad_c.patch41
-rw-r--r--net-mail/libdbx/files/digest-libdbx-1.0.32
-rw-r--r--net-mail/libdbx/libdbx-1.0.3.ebuild7
4 files changed, 54 insertions, 4 deletions
diff --git a/net-mail/libdbx/ChangeLog b/net-mail/libdbx/ChangeLog
index 26e0b291cef7..5fc88fa965d0 100644
--- a/net-mail/libdbx/ChangeLog
+++ b/net-mail/libdbx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-mail/libdbx
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/ChangeLog,v 1.2 2004/06/24 23:23:49 agriffis Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/ChangeLog,v 1.3 2006/09/20 07:04:01 phosphan Exp $
+
+ 20 Sep 2006; Patrick Kursawe <phosphan@gentoo.org> +files/bad_c.patch,
+ libdbx-1.0.3.ebuild:
+ Fixed gcc 4 problems (bug #147085)
*libdbx-1.0.3 (05 Mar 2004)
diff --git a/net-mail/libdbx/files/bad_c.patch b/net-mail/libdbx/files/bad_c.patch
new file mode 100644
index 000000000000..1f7dc6d8ba03
--- /dev/null
+++ b/net-mail/libdbx/files/bad_c.patch
@@ -0,0 +1,41 @@
+diff -ru libdbx_1.0.3/libdbx.c libdbx_1.0.3-new/libdbx.c
+--- libdbx_1.0.3/libdbx.c 2002-10-05 15:07:36.000000000 +0200
++++ libdbx_1.0.3-new/libdbx.c 2006-09-20 08:53:46.000000000 +0200
+@@ -485,11 +485,11 @@
+ switch (blockp.type) {
+ case 0x01: //pointer to flag
+ email->flag = 0;
+- ((int*)bufx) = &(email->flag);
++ bufx = (char **)&(email->flag);
+ readtype = CHAR_TYPE;
+ break;
+ case 0x04: //pointer to dataptr
+- ((int*)bufx) = &(email->data_offset);
++ bufx = (char **)&(email->data_offset);
+ readtype = INT_TYPE;
+ break;
+ case 0x05: //asciiz string of subject (without RE: or FWD: etc...)
+@@ -521,7 +521,7 @@
+ readtype = STRING_TYPE;
+ break;
+ case 0x12: //date - of what i'm not sure. It is in a win32 FILETIME structure. needs converting to something
+- ((struct FILETIME*)bufx) = &(email->date);
++ bufx = (char **)&(email->date);
+ readtype = W32FT_TYPE;
+ break;
+ case 0x13: //recipient's name
+Only in libdbx_1.0.3-new: libdbx.o
+Only in libdbx_1.0.3-new: readdbx
+diff -ru libdbx_1.0.3/readdbx.c libdbx_1.0.3-new/readdbx.c
+--- libdbx_1.0.3/readdbx.c 2002-10-05 15:20:25.000000000 +0200
++++ libdbx_1.0.3-new/readdbx.c 2006-09-20 08:54:10.000000000 +0200
+@@ -19,6 +19,7 @@
+ #include <getopt.h>
+ #include <time.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #include "libdbx.h"
+ #include "common.h"
+Only in libdbx_1.0.3-new: readoe
+Files libdbx_1.0.3/timeconv.o and libdbx_1.0.3-new/timeconv.o differ
diff --git a/net-mail/libdbx/files/digest-libdbx-1.0.3 b/net-mail/libdbx/files/digest-libdbx-1.0.3
index 6833f448cda7..075f9a5e4249 100644
--- a/net-mail/libdbx/files/digest-libdbx-1.0.3
+++ b/net-mail/libdbx/files/digest-libdbx-1.0.3
@@ -1 +1,3 @@
MD5 fa169c99d5245c836f017badf392529d libdbx_1.0.3.tgz 24927
+RMD160 b93cde7889c78b53bfd92b2ec7d0a1eede81e841 libdbx_1.0.3.tgz 24927
+SHA256 eb2a6913a9f338164b2b62a9955da974ad44c94d8bb5e7cd68e4cd6ec175a636 libdbx_1.0.3.tgz 24927
diff --git a/net-mail/libdbx/libdbx-1.0.3.ebuild b/net-mail/libdbx/libdbx-1.0.3.ebuild
index c992d7e50b70..1cb3125f5e3f 100644
--- a/net-mail/libdbx/libdbx-1.0.3.ebuild
+++ b/net-mail/libdbx/libdbx-1.0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/libdbx-1.0.3.ebuild,v 1.3 2004/06/24 23:23:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/libdbx/libdbx-1.0.3.ebuild,v 1.4 2006/09/20 07:04:01 phosphan Exp $
+
+inherit eutils
DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
HOMEPAGE="http://sourceforge.net/projects/ol2mbox"
@@ -23,6 +25,7 @@ S="${WORKDIR}/${MY_PN}_${PV}"
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/bad_c.patch
sed -i -e 's/-g/$(CFLAGS)/' Makefile
}