summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-31 10:19:39 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-31 10:19:39 +0000
commitce9783ce481fd848fe003745738c9b1281f658d9 (patch)
treec7c14e13a26eb036b8344d93a914334f76048190 /net-mail
parentfix to test phase, switch to use of manage.py (diff)
downloadgentoo-2-ce9783ce481fd848fe003745738c9b1281f658d9.tar.gz
gentoo-2-ce9783ce481fd848fe003745738c9b1281f658d9.tar.bz2
gentoo-2-ce9783ce481fd848fe003745738c9b1281f658d9.zip
Revbump to fix tests and make python features truly optional (fixes bug #471882).
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog10
-rw-r--r--net-mail/fetchmail/fetchmail-6.3.26-r1.ebuild97
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch14
-rw-r--r--net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch11
4 files changed, 131 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index c7d28a1ad9ab..d84c2a365d01 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/fetchmail
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.251 2013/05/30 07:32:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.252 2013/05/31 10:19:38 radhermit Exp $
+
+*fetchmail-6.3.26-r1 (31 May 2013)
+
+ 31 May 2013; Tim Harder <radhermit@gentoo.org> +fetchmail-6.3.26-r1.ebuild,
+ +files/fetchmail-6.3.26-python-optional.patch,
+ +files/fetchmail-6.3.26-tests.patch:
+ Revbump to fix tests and make python features truly optional (fixes bug
+ #471882).
30 May 2013; Tim Harder <radhermit@gentoo.org> fetchmail-6.3.26.ebuild:
Add PYTHON_REQUIRED_USE for python-single-r1.
diff --git a/net-mail/fetchmail/fetchmail-6.3.26-r1.ebuild b/net-mail/fetchmail/fetchmail-6.3.26-r1.ebuild
new file mode 100644
index 000000000000..ab7cd9e4e08f
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.3.26-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.3.26-r1.ebuild,v 1.1 2013/05/31 10:19:39 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1 user toolchain-funcs autotools eutils
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://fetchmail.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos hesiod tk socks"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="hesiod? ( net-dns/hesiod )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 >=dev-libs/openssl-0.9.6 )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ tk? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+
+ epatch "${FILESDIR}"/${P}-python-optional.patch
+ epatch "${FILESDIR}"/${P}-tests.patch
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ $(use_with hesiod) \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ # fetchmail's homedir (holds fetchmail's .fetchids)
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 700 /var/lib/${PN}
+
+ default
+
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch b/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch
new file mode 100644
index 000000000000..2eafe4dcbb24
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.26-python-optional.patch
@@ -0,0 +1,14 @@
+--- fetchmail-6.3.26/Makefile.am
++++ fetchmail-6.3.26/Makefile.am
+@@ -16,9 +16,11 @@
+ pys= fetchmailconf.py
+ pym= fetchmailconf.man
+
++if HAVE_PYTHON
+ nodist_bin_SCRIPTS= fetchmailconf
+ python_PYTHON= $(pys)
+ dist_man1_MANS+= $(pym)
++endif
+
+ CLEANFILES= $(nodist_bin_SCRIPTS)
+
diff --git a/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch b/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch
new file mode 100644
index 000000000000..a0b3e8b5dfbb
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail-6.3.26-tests.patch
@@ -0,0 +1,11 @@
+--- fetchmail-6.3.26/Makefile.am
++++ fetchmail-6.3.26/Makefile.am
+@@ -45,7 +47,7 @@
+ check_PROGRAMS=
+
+ TESTS= t.smoke t.validate-xhtml10 t.validate-xhtml t.x509_name_match
+-TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)" $(SHELL)
++TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)"
+
+ if NEED_TRIO
+ noinst_LIBRARIES+= libtrio.a