summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-09-26 01:58:55 +0000
committerAron Griffis <agriffis@gentoo.org>2001-09-26 01:58:55 +0000
commitfee1224f74863e86705948c0d3c63a5cc60c934e (patch)
treef21196e3f48a45ab9502ed8f97de116af67d2022 /net-mail
parent*** empty log message *** (diff)
downloadgentoo-2-fee1224f74863e86705948c0d3c63a5cc60c934e.tar.gz
gentoo-2-fee1224f74863e86705948c0d3c63a5cc60c934e.tar.bz2
gentoo-2-fee1224f74863e86705948c0d3c63a5cc60c934e.zip
Fixed mutt ebuild: (1) use ncurses properly if slang isn't desired,
(2) fix installation to be more sensible by using --with-docdir and --mandir on the configure command-line, (3) install a system-wide Muttrc that doesn't force colors and other user preferences on the user. Hopefully this won't upset anybody's applecart, since the old Muttrc/Muttrc.color files will be preserved by Gentoo's config-protection for anybody dependent on them.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mutt/files/Muttrc34
-rw-r--r--net-mail/mutt/files/digest-mutt-1.3.22-r11
-rw-r--r--net-mail/mutt/mutt-1.3.22-r1.ebuild48
3 files changed, 63 insertions, 20 deletions
diff --git a/net-mail/mutt/files/Muttrc b/net-mail/mutt/files/Muttrc
index 90cc116a532e..b751753210f2 100644
--- a/net-mail/mutt/files/Muttrc
+++ b/net-mail/mutt/files/Muttrc
@@ -1,26 +1,20 @@
-set mbox_type = Maildir
-set use_8bitmime
+# Some minimal Mutt settings, Gentoo-style. These reflect the Gentoo
+# predilection for maildir folders.
+#
+# Please don't add settings to this file to change other user
+# preferences (such as colors), since those can be hard for a user to
+# undo if their preference doesn't match yours! For example, it is
+# *impossible* currently in mutt to remove color settings from objects
+# other than the index.
+
+set mbox_type=Maildir
set folder=~/.maildir
set spoolfile=~/.maildir/
-unset mbox
-source /etc/mutt/Muttrc.color
set record=~/.maildir-sent/
+unset mbox
set move=no
-set sort=date-received
-unset use_domain
-set abort_nosubject=no
-set abort_unmodified=no
-ignore *
-unignore from date subject to cc lines
-unignore organization organisation
-unignore posted-to:
-hdr_order to cc organization organisation date from subject
-set index_format="%4C %Z %{%b %d} %-16.16L %s"
-
-bind pager <home> top
-bind pager <end> bottom
-bind pager <up> previous-line
-bind pager <down> next-line
-set pager_index_lines=6
+# Maybe we shouldn't set index_format here, but this is a recommended
+# one for maildir-style folders.
+set index_format="%4C %Z %{%b %d} %-16.16L %s"
diff --git a/net-mail/mutt/files/digest-mutt-1.3.22-r1 b/net-mail/mutt/files/digest-mutt-1.3.22-r1
new file mode 100644
index 000000000000..44c100d9f8d7
--- /dev/null
+++ b/net-mail/mutt/files/digest-mutt-1.3.22-r1
@@ -0,0 +1 @@
+MD5 c69053fc5fe4cc92d56c6e03cc99aef9 mutt-1.3.22i.tar.gz
diff --git a/net-mail/mutt/mutt-1.3.22-r1.ebuild b/net-mail/mutt/mutt-1.3.22-r1.ebuild
new file mode 100644
index 000000000000..30b2ba6b1c41
--- /dev/null
+++ b/net-mail/mutt/mutt-1.3.22-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Server Team <server@gentoo.org>
+# Authors: Achim Gottinger <achim@gentoo.org>,
+# Daniel Robbins <drobbins@gentoo.org>,
+# Anonymous,
+# Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.3.22-r1.ebuild,v 1.1 2001/09/26 01:58:55 agriffis Exp $
+
+S=$WORKDIR/$P
+DESCRIPTION="a small but very powerful text-based mail client"
+SRC_URI="ftp://ftp.mutt.org/pub/mutt/mutt-${PV}i.tar.gz"
+HOMEPAGE="http://www.mutt.org"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-libs/ncurses-5.2
+ slang? ( >=sys-libs/slang-1.4.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+ use ssl && myconf="$myconf --with-ssl" \
+ || myconf="$myconf --without-ssl"
+ # --without-slang doesn't work;
+ # specify --with-curses if you don't want slang
+ # (26 Sep 2001 agriffis)
+ use slang && myconf="$myconf --with-slang" \
+ || myconf="$myconf --with-curses"
+ ./configure --host=$CHOST \
+ --prefix=/usr --sysconfdir=/etc/mutt \
+ --mandir=/usr/share/man --with-docdir=/usr/share/doc/mutt-$PVR \
+ --with-regex --enable-pop --enable-imap --enable-nfs-fix \
+ --with-homespool=Maildir $myconf
+ assert "./configure failed (myconf=$myconf)"
+ cp doc/Makefile doc/Makefile.orig
+ sed 's/README.UPGRADE//' doc/Makefile.orig > doc/Makefile
+ make || die "make failed (myconf=$myconf)"
+}
+
+src_install () {
+ make DESTDIR=$D install || die
+ find $D/usr/share/doc -type f | xargs gzip
+ insinto /etc/mutt
+ doins $FILESDIR/Muttrc
+}