summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-10-15 05:56:53 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-10-15 05:56:53 +0000
commit78767b587b100629a74387c715f62ad67255d99b (patch)
tree0b43f80b926b95baff0354aeaf858e1f0b609436 /net-misc/anyremote/anyremote-5.0.ebuild
parenttidy (diff)
downloadgentoo-2-78767b587b100629a74387c715f62ad67255d99b.tar.gz
gentoo-2-78767b587b100629a74387c715f62ad67255d99b.tar.bz2
gentoo-2-78767b587b100629a74387c715f62ad67255d99b.zip
Version bump ( fixes bug #289052 )
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/anyremote/anyremote-5.0.ebuild')
-rw-r--r--net-misc/anyremote/anyremote-5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/anyremote/anyremote-5.0.ebuild b/net-misc/anyremote/anyremote-5.0.ebuild
new file mode 100644
index 000000000000..dafb3e7298f1
--- /dev/null
+++ b/net-misc/anyremote/anyremote-5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/anyremote/anyremote-5.0.ebuild,v 1.1 2009/10/15 05:56:53 hwoarang Exp $
+
+EAPI="2"
+
+DESCRIPTION="Anyremote provides wireless bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth dbus"
+
+RDEPEND="bluetooth? ( || ( net-wireless/bluez ( net-wireless/bluez-libs net-wireless/bluez-utils ) ) )
+ dbus? ( sys-apps/dbus )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable bluetooth) $(use_enable dbus)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "install doc failed"
+}