summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-06 07:08:08 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-06 07:08:08 +0000
commit3e79df582bdfd71563468283a265255697f3476f (patch)
tree849e42585943dce6139232ad9414a8698b85cfed /net-misc/apt-cacher-ng
parentRequire at least Python 3.2 wrt upstream documentation. (diff)
downloadgentoo-2-3e79df582bdfd71563468283a265255697f3476f.tar.gz
gentoo-2-3e79df582bdfd71563468283a265255697f3476f.tar.bz2
gentoo-2-3e79df582bdfd71563468283a265255697f3476f.zip
Version bump.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/apt-cacher-ng')
-rw-r--r--net-misc/apt-cacher-ng/ChangeLog7
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-0.6.10.ebuild120
2 files changed, 126 insertions, 1 deletions
diff --git a/net-misc/apt-cacher-ng/ChangeLog b/net-misc/apt-cacher-ng/ChangeLog
index 8a8aa5d73a95..58ee1593b13f 100644
--- a/net-misc/apt-cacher-ng/ChangeLog
+++ b/net-misc/apt-cacher-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/apt-cacher-ng
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-cacher-ng/ChangeLog,v 1.5 2011/10/17 18:32:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-cacher-ng/ChangeLog,v 1.6 2011/12/06 07:08:08 jer Exp $
+
+*apt-cacher-ng-0.6.10 (06 Dec 2011)
+
+ 06 Dec 2011; Jeroen Roovers <jer@gentoo.org> +apt-cacher-ng-0.6.10.ebuild:
+ Version bump.
17 Oct 2011; Jeroen Roovers <jer@gentoo.org> -apt-cacher-ng-0.6.2.ebuild,
-apt-cacher-ng-0.6.3.ebuild:
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.10.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.10.ebuild
new file mode 100644
index 000000000000..5618157ff955
--- /dev/null
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.10.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-cacher-ng/apt-cacher-ng-0.6.10.ebuild,v 1.1 2011/12/06 07:08:08 jer Exp $
+
+EAPI="4"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Yet another implementation of an HTTP proxy for Debian/Ubuntu software packages written in C++"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~bloch/acng/"
+LICENSE="as-is"
+SLOT="0"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.orig.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fuse lzma tcpd"
+
+COMMON_DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/cmake
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ lzma? ( app-arch/xz-utils )
+ fuse? ( sys-fs/fuse )
+ tcpd? ( sys-apps/tcp-wrappers )
+ dev-lang/perl
+"
+
+pkg_setup() {
+ # add new user & group for daemon
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_configure(){
+ mycmakeargs="-DCMAKE_INSTALL_PREFIX=/usr"
+ if use fuse; then
+ mycmakeargs="-DHAVE_FUSE_26=yes ${mycmakeargs}"
+ else
+ mycmakeargs="-DHAVE_FUSE_26=no ${mycmakeargs}"
+ fi
+ if use lzma; then
+ mycmakeargs="-DHAVE_LZMA=yes ${mycmakeargs}"
+ else
+ mycmakeargs="-DHAVE_LZMA=no ${mycmakeargs}"
+ fi
+ if use tcpd; then
+ mycmakeargs="-DHAVE_LIBWRAP=yes ${mycmakeargs}"
+ else
+ mycmakeargs="-DHAVE_LIBWRAP=no ${mycmakeargs}"
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ pushd ${CMAKE_BUILD_DIR}
+ dosbin ${PN}
+ if use fuse; then
+ dobin acngfs
+ fi
+ popd
+
+ newinitd "${FILESDIR}"/initd ${PN}
+ newconfd "${FILESDIR}"/confd ${PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/logrotate ${PN}
+
+ doman doc/man/${PN}*
+ if use fuse; then
+ doman doc/man/acngfs*
+ fi
+
+ # Documentation
+ dodoc README TODO VERSION INSTALL ChangeLog
+ if use doc; then
+ dodoc doc/*.pdf
+ dohtml doc/html/*
+ docinto examples/conf
+ dodoc conf/*
+ fi
+
+ # perl daily cron script
+ dosbin expire-caller.pl
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/cron.daily ${PN}
+
+ # default configuration
+ insinto /etc/${PN}
+ newins conf/acng.conf ${PN}.conf
+ newins conf/report.html report.html
+ newins conf/deb_mirrors.gz deb_mirrors.gz
+ newins conf/debvol_mirrors.gz debvol_mirrors.gz
+ newins conf/ubuntu_mirrors ubuntu_mirrors
+ newins conf/archlx_mirrors archlx_mirrors
+ newins conf/sfnet_mirrors sfnet_mirrors
+ newins conf/cygwin_mirrors cygwin_mirrors
+ newins conf/security.conf security.conf
+ newins conf/maint.html maint.html
+ newins conf/userinfo.html userinfo.html
+ newins conf/style.css style.css
+
+ dodir /var/cache/${PN}
+ dodir /var/log/${PN}
+ # Some directories must exists
+ keepdir /var/log/${PN}
+ keepdir /var/run/${PN}
+ fowners -R ${PN}:${PN} \
+ /etc/${PN} \
+ /var/log/${PN} \
+ /var/cache/${PN} \
+ /var/run/${PN}
+}